Τώρα είναι Παρ 25 Σεπ 2020 06:15 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΔΙΑΓΩΝΙΣΜΟΣ ΑΣΕΠ
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 18 Δεκ 2006 11:41 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ============================================================================
! Στο διαγωνισμό του ΑΣΕΠ για την ειδικότητα των φυσικών έλαβαν μέρος
! 500 άτομα και εξετάστηκαν στο γνωστικό τους αντικείμενο με βαθμό
! από 1 έως 100 και στα παιδαγωγικά με βαθμό από 1 έως 100 επίσης.
! Ο τελικός βαθμός προκύπτει κατά 70 % από το βαθμό στο γνωστικό αντικείμενο
! και κατά 30 % από το βαθμό στα παιδαγωγικά.
! Πρόκειται να προσληφθούν 150 άτομα.
! Η πρόσληψη θα γίνει μόνο αν ο τελικός βαθμός είναι πάνω από 60.
! Σε περίπτωση που κάποιοι διαγωνιζόμενοι ισοβαθμούν με τον τελευταίο
! προσλαμβάνονται και αυτοί.
! Να γραφεί πρόγραμμα το οποίο :
!  α) ζητά και καταχωρεί σε κατάλληλους πίνακες τα ονόματα και
!     τις βαθμολογίες των διαγωνισθέντων.
!  β) υπολογίζει και καταχωρεί σε πίνακα την τελική βαθμολογία κάθε ενός.
!  γ) υπολογίζει και εμφανίζει πόσοι προσλαμβάνονται.
!     Σε περίπτωση που υπάρξουν κενές θέσεις εμφανίζει κατάλληλο μήνυμα
!     και τον αριθμό των κενών θέσεων.
!  δ) Εμφανίζει τον κατάλογο αυτών που θα προσληφθούν κατά σειρά βαθμολογίας
!     από τον καλύτερο στο χειρότερο.
! ============================================================================

ΠΡΟΓΡΑΜΜΑ ΑΣΕΠ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i ,j , Ν
  ΠΡΑΓΜΑΤΙΚΕΣ: Β[500,2] , ΤΒ[500], temp1
  ΧΑΡΑΚΤΗΡΕΣ: name[500] , temp2
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 500
    ΓΡΑΨΕ 'Δώσε το όνομα του ',i
    ΔΙΑΒΑΣΕ name[i]
    ΓΡΑΨΕ 'Δώσε και τους βαθμούς του'
    ΔΙΑΒΑΣΕ Β[i,1][i,2]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 500
    ΤΒ[i] <-- Β[i,1]*70/100 + Β[i,2]*30/100  ! ΤΕΛΙΚΟΣ ΒΑΘΜΟΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 500
    ΓΙΑ j ΑΠΟ 500 ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
      ΑΝ ΤΒ[j-1] < ΤΒ[j] ΤΟΤΕ
        temp1 <-- ΤΒ[j-1]
        ΤΒ[j-1] <-- ΤΒ[j]
        ΤΒ[j] <-- temp1
        temp2 <-- name[j-1]
        name[j-1] <-- name[j]
        name[j] <-- temp2
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Ν <-- 1
  ΟΣΟ ΤΒ[Ν] > 60 ΕΠΑΝΑΛΑΒΕ
    Ν <-- Ν + 1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Ν <-- Ν -1
  ΑΝ Ν <= 150 ΤΟΤΕ
    ΓΡΑΨΕ 'Θα προσληφθούν', Ν,'άτομα και θα μείνουν ',150-Ν,'κενές θέσεις'
  ΑΛΛΙΩΣ
    Ν <-- 150
    ΟΣΟ ΤΒ[Ν+1] = ΤΒ[150] ΕΠΑΝΑΛΑΒΕ
      Ν <-- Ν + 1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Θα προληφθούν',Ν,'άτομα'
    ΓΡΑΨΕ 'ΠΡΟΣΛΑΜΒΑΝΟΝΤΑΙ ΟΙ ΕΞΗΣ'
    ΓΡΑΨΕ '========================'
    ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ Ν
      ΓΡΑΨΕ name[i]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 18 Δεκ 2006 06:08 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 15 Φεβ 2004 09:10 pm
Δημοσιεύσεις: 18
Τοποθεσία: Ενιαίο Λύκειο Χιλιομοδίου Κορινθίας
Πολύ ωραία άσκηση, μπράβο


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters