Τώρα είναι Παρ 25 Σεπ 2020 07:51 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 13 Μαρ 2006 06:32 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 04 Μαρ 2006 03:33 pm
Δημοσιεύσεις: 9
Παράθεση:
ΕΝΑ ΝΟΣΟΚΟΜΕΙΟ ΔΕΧΕΤΑΙ ΜΕΧΡΙ 500 ΑΣΘΕΝΕΙΣ. ΓΙΑ ΚΑΘΕ ΑΣΘΕΝΗ ΝΑ ΚΑΤΑΧΩΡΗΘΟΥΝ ΟΙ ΗΜΕΡΕΣ ΝΟΣΗΛΕΙΑΣ ΤΟΥ, Ο ΚΩΔΙΚΟΣ ΤΟΥ ΑΣΦΑΛΙΣΤΙΚΟΥ ΤΟΥ ΤΑΜΕΙΟΥ (1 ΕΩΣ 10) ΚΑΙ Η ΘΕΣΗ ΝΟΣΗΛΕΙΑΣ (a,b,c ) ΥΣΤΕΡΑ ΑΠΟ ΕΛΕΓΧΟ ΓΙΑ ΤΗΝ ΑΠΟΔΟΧΗ ΤΩΝ ΣΤΟΙΧΕΙΩΝ ΥΠΛΟΛΟΓΙΖΕΤΑΙ Ο ΜΕΣΟΣ ΟΡΟΣ ΠΑΡΑΜΟΝΗΣ ΗΜΕΡΩΝ ΤΩΝ ΑΣΘΕΝΩΝ
ΤΟ ΚΟΣΤΟΣ ΓΙΑ ΤΗΝ ΠΑΡΑΜΟΝΗ ΤΟΥ ΑΣΘΕΝΗ ΣΤΟ ΝΟΣΟΚΟΜΕΙΟ ΑΝΑΛΟΓΑ ΤΗΝ ΘΕΣΗ ( a-->125e/imera b-->90 c-->60) ,ΜΕΤΑ ΥΠΟΛΟΓΖΕΙ ΤΟ ΣΥΝΟΛΙΚΟ ΚΟΣΤΟΣ ΠΟΥ ΟΦΕΙΛΕΙ ΤΟ ΚΑΘΕ ΤΑΜΕΙΟ ΚΑΙ ΤΕΛΟΣ ΤΟ ΑΘΡΟΙΣΜΑ ΤΩΝ ΟΦΕΙΛΩΝ ΟΛΩΝ ΤΩΝ ΤΑΜΕΙΩΝ

Syntax: [ Download ] [ Hide ]

πρόγραμμα panellhnies


μεταβλητές
  ακέραιες:kod[500],i,pl,nos[500],kost[10],synolo,kk
  χαρακτήρες:th[500]
  πραγματικές: mo

αρχή
  αρχή_επανάληψης
    γράψε 'dose plithos asthenon'
    διάβασε pl
  μέχρις_ότου pl<=500
  για i από 1 μέχρι pl
    αρχή_επανάληψης
      γράψε'dose imeres nosileias astheni no  ',i
      διάβασε nos[i]
    μέχρις_ότου nos[i]>=1

    αρχή_επανάληψης
      γράψε 'dose kodiko asfalistikou tameiou astheni no ',i
      διάβασε kod[i]
    μέχρις_ότου (kod[i]>0) και (kod[i]<=10)

    αρχή_επανάληψης
      γράψε 'dose thesi nosileias astheni no  ',i
      διάβασε th[i]
    μέχρις_ότου (th[i]='a') ή (th[i]='b') ή (th[i]='c')
    mo <-- mo+nos[i]/pl

    αν th[i]='a' τότε
      kk <-- nos[i]*90
    αλλιώς_αν th[i]='b' τότε
      kk <-- nos[i]*90
    αλλιώς_αν th[i]='c' τότε
      kk <-- nos[i]*60
    τέλος_αν
    γράψε 'o ',i,'os asthenhs plhrose ',kk,'  euro'
    kost[kod[i]] <-- kost[kod[i]]+kk
    γράψε'------------------------------------------'
  τέλος_επανάληψης
  kk <-- 0
  για i από 1 μέχρι 10
    γράψε  'to kostos gia to tameio no ',i,' itan ',kost[i]
    synolo <-- kost[i]+synolo
  τέλος_επανάληψης

  γράψε ' mesos oros imeron paramonis ton asthenon  ',mo
  γράψε 'oi sinolikes ofeiles einai', synolo
τέλος_προγράμματος


 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters