Τώρα είναι Τρί 15 Οκτ 2019 09:57 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Αναζήτηση τέλειων αριθμών
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 02 Ιαν 2011 02:17 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 02 Ιαν 2011 02:13 pm
Δημοσιεύσεις: 2
ΓΙΑ ΟΣΟΥΣ ΨΑΧΝΟΥΝ ΣΕ ΕΝΑ ΕΥΡΟΣ ΑΡΙΘΜΩΝ ΠΟΙΟΙ ΕΙΝΑΙ ΟΙ ΤΕΛΕΙΟΙ

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ αναζήτηση_τέλειων_αριθμών
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: arith,ι,athr,metr2,metr,apotel,mo, range
ΑΡΧΗ
  metr <-- 1
  arith <-- 1
  metr2 <-- 1
  apotel <-- 0
  mo <-- 0                                                                            
  ΓΡΑΨΕ 'ΔΩΣΤΕ ΜΟΥ ΤΟ ΕΥΡΟΣ ΑΝΑΖΗΤΗΣΗΣ ΤΕΛΕΙΩΝ ΑΡΙΘΜΩΝ'
  ΔΙΑΒΑΣΕ range
  ΟΣΟ range > 1000 ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΜΟΥ ΕΝΑΝ ΑΡΙΘΜΟ ΑΠΟ ΤΟ 1 ΕΩΣ ΤΟ 1000'
    ΔΙΑΒΑΣΕ range
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΟΣΟ metr <= range ΕΠΑΝΑΛΑΒΕ
    athr <-- 0
    ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ arith DIV 2
      ΑΝ arith MOD ι = 0 ΤΟΤΕ
        athr <-- athr + ι
        ΑΝ athr = arith ΚΑΙ ι=arith DIV 2 ΤΟΤΕ
          ΓΡΑΨΕ 'Ο ΑΡΙΘΜΟΣ', arith, 'ΕΙΝΑΙ ΤΕΛΕΙΩΣ'
          apotel <-- apotel + arith
          mo <-- apotel DIV metr2
          metr2 <-- metr2 + 1
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    arith <-- arith + 1
    metr <-- metr + 1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ mo > 0 ΤΟΤΕ
    ΓΡΑΨΕ  ' Ο ΜΕΣΟΣ ΟΡΟΣ ΕΙΝΑΙ', mo
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'ΔΕΝ ΕΙΠΑΡΧΕΙ ΤΕΛΕΙΩΣ ΑΡΙΘΜΟΣ'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters