Τώρα είναι Τρί 02 Ιουν 2020 10:19 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Παρ 30 Μάιος 2003 11:05 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 01 Μάιος 2003 10:25 pm
Δημοσιεύσεις: 38
Τοποθεσία: Καλλιθέα Αττικής
Να και ένας μεταφραστής ΠΡΟΚΑΤ με 66 γραμμές για πρόγραμμα δέκα γραμμών!
Εκτελεί συγκεκριμένο πρόγραμμα, δείχνει μεταβλητές, το σκεπτικό της δομής ΓΙΑ, τον μετρητή προγράμματος, και έχει εκτέλεση κανονικής αλλά και βηματικής ροής!
Μόνο καφέ δεν ψήνει!

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΒΗΜΑΤΙΚΟΣ_ΜΕΤΑΦΡΑΣΤΗΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΜΕΤΡΗΤΗΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ, Χ, Κ, Ι
  ΧΑΡΑΚΤΗΡΕΣ: Α[10], Π
ΑΡΧΗ
  Α[1] <-- 'ΠΡΟΓΡΑΜΜΑ ΕΠΙΔΕΙΞΗ'
  Α[2] <-- 'ΜΕΤΑΒΛΗΤΕΣ'
  Α[3] <-- '  ΑΚΕΡΑΙΕΣ: Χ, Κ, Ι'
  Α[4] <-- 'ΑΡΧΗ'
  Α[5] <-- '  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10'
  Α[6] <-- '    ΔΙΑΒΑΣΕ Χ'
  Α[7] <-- '    Κ<--Χ*Χ'
  Α[8] <-- '    ΓΡΑΨΕ Κ'
  Α[9] <-- '  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ'
  Α[10] <-- 'ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ'
  ΓΡΑΨΕ 'ΘΑ ΤΡΕΞΟΥΜΕ ΤΟ ΠΡΟΓΡΑΜΜΑ ΠΑΡΑΚΑΤΩ'
  ΓΡΑΨΕ '-------------------------------------------------------------'
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ '   '[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ '-------------------------------------------------------------'
  ΓΡΑΨΕ 'ΕΚΚΙΝΗΣΗ (ΠΑΤΑ enter), ΒΗΜΑΤΙΚΗ ΕΚΤΕΛΕΣΗ (ΠΑΤΑ * enter)'
  ΔΙΑΒΑΣΕ Π
  ΜΕΤΡΗΤΗΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ <-- 1
  ΟΣΟ ΜΕΤΡΗΤΗΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ<>0 ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'ΓΡΑΜΜΗ=', ΜΕΤΡΗΤΗΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ,': ', Α[ΜΕΤΡΗΤΗΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ]
    ΕΠΙΛΕΞΕ   ΜΕΤΡΗΤΗΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
      ΠΕΡΙΠΤΩΣΗ 1,2,4
        ΓΡΑΨΕ 'ΤΥΠΙΚΟ ΣΗΜΑΔΙ'
      ΠΕΡΙΠΤΩΣΗ 10
        ΓΡΑΨΕ 'ΤΕΡΜΑΤΙΣΜΟΣ'
        ΜΕΤΡΗΤΗΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ <-- -1
      ΠΕΡΙΠΤΩΣΗ 3
        ΓΡΑΨΕ 'ΔΗΜΙΟΥΡΓΙΑ Χ, Κ ΚΑΙ Ι ΑΚΕΡΑΙΩΝ ΜΕΤΑΒΛΗΤΩΝ'
      ΠΕΡΙΠΤΩΣΗ 5
        ΓΡΑΨΕ 'ΕΚΚΙΝΗΣΗ ΔΟΜΗΣ *ΓΙΑ* ΜΕ ΜΕΤΑΒΛΗΤΗ ΕΛΕΓΧΟΥ Ι'
        ΓΡΑΨΕ 'Ι<--0'
        Ι <-- 0
      ΠΕΡΙΠΤΩΣΗ 6
        ΓΡΑΨΕ 'ΕΝΤΟΛΗ ΔΙΑΒΑΣΕ, ΘΑ ΠΑΡΕΙ ΑΚΕΡΑΙΑ ΤΙΜΗ ΓΙΑ ΤΗΝ Χ'
        ΓΡΑΨΕ 'ΠΡΟΣΟΧΗ!!! ΟΧΙ * ΓΙΑΤΙ ΘΑ ΒΓΕΙ ΛΑΘΟΣ'
        ΔΙΑΒΑΣΕ Χ
        ΓΡΑΨΕ 'Χ<--'
      ΠΕΡΙΠΤΩΣΗ 7
        ΓΡΑΨΕ 'ΘΑ ΥΠΟΛΟΓΙΣΟΥΜΕ ΤΟ ΤΕΤΡΑΓΩΝΟ ΤΟΥ Χ, ΤΟ Χ*Χ'
        Κ <-- Χ*Χ
        ΓΡΑΨΕ 'Κ<--'
      ΠΕΡΙΠΤΩΣΗ 8
        ΓΡΑΨΕ 'ΘΑ ΤΥΠΩΣΟΥΜΕ ΤΟ Κ'
        ΓΡΑΨΕ Κ
      ΠΕΡΙΠΤΩΣΗ 9
        ΓΡΑΨΕ 'ΑΥΞΗΣΗ ΤΟΥ Ι ΚΑΤΑ 1'
        Ι <-- Ι+1
        ΓΡΑΨΕ 'Ι<--'
        ΓΡΑΨΕ 'ΑΝ Ι>10 ΤΟΤΕ ΤΕΛΟΣ ΕΠΑΝΑΛΗΨΗΣ ΑΛΛΙΩΣ ΠΑΜΕ ΑΛΛΗ ΜΙΑ!'
        ΑΝ  Ι<=10 ΤΟΤΕ
          ΜΕΤΡΗΤΗΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ <-- 5
        ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ
    ΜΕΤΡΗΤΗΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ <-- ΜΕΤΡΗΤΗΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ+1
    ΑΝ Π='*' ΤΟΤΕ
      ΓΡΑΨΕ 'ΝΕΟ ΒΗΜΑ (ΔΩΣΕ * enter) ή μόνο enter για κανονική εκτέλεση'
      ΔΙΑΒΑΣΕ Π
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 

_________________
Γλώσσα προγραμματισμού M2000


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters