Τώρα είναι Τρί 28 Ιαν 2020 10:59 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Τρίλιζα
ΔημοσίευσηΔημοσιεύτηκε: Παρ 11 Σεπ 2009 05:55 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 11 Σεπ 2009 05:31 pm
Δημοσιεύσεις: 4
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Τρίλιζα
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: Τριλ[3,3]
  ΑΚΕΡΑΙΕΣ: Κ, Λ, Σειρά, Γρ, Στ, Νικ1, Νικ2, Ισοπ, Ελευθ
  ΛΟΓΙΚΕΣ: Εντάξει, ΥπΝικ
ΑΡΧΗ
  Σειρά <-- 0
  Νικ1 <-- 0
  Νικ2 <-- 0
  Ισοπ <-- 0
  ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 3 ! Θα παιχτούν συνολικά 3 παρτίδες τρίλιζας
    ΓΡΑΨΕ 'Κύκλος παιχνιδιού Νο:', Κ
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 3
      ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 3
        Τριλ[Κ,Λ] <-- ''
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    Ελευθ <-- 9
    ΥπΝικ <-- Ψευδής
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      Εντάξει <-- Ψευδής
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΡΑΨΕ 'Δώσε τις συντεταγμένες της κίνησης του', Σειρά+1,'ου παίκτη:'
        ΔΙΑΒΑΣΕ Γρ, Στ
        ΑΝ (Γρ<1) Ή (Γρ>3) Ή (Στ<1) Ή (Στ>3) ΤΟΤΕ
          ΓΡΑΨΕ 'Λανθασμένες συντεταγμένες θέσης...'
        ΑΛΛΙΩΣ_ΑΝ Τριλ[Γρ,Στ] <> '' ΤΟΤΕ
          ΓΡΑΨΕ 'Η θέση είναι κατηλειμένη! Ξαναπροσπάθησε...'
        ΑΛΛΙΩΣ
          Εντάξει <-- Αληθής
        ΤΕΛΟΣ_ΑΝ
      ΜΕΧΡΙΣ_ΟΤΟΥ Εντάξει = Αληθής
      ΑΝ Σειρά = 0 ΤΟΤΕ
        Τριλ[Γρ,Στ] <-- 'Κ'
      ΑΛΛΙΩΣ
        Τριλ[Γρ,Στ] <-- 'Λ'
      ΤΕΛΟΣ_ΑΝ
      Ελευθ <-- Ελευθ-1
      ΑΝ (Γρ=1) ΚΑΙ (Στ=1) ΤΟΤΕ
        ΑΝ ((Τριλ[1,2]=Τριλ[1,3]) ΚΑΙ (Τριλ[1,1]=Τριλ[1,2])) Ή ((Τριλ[2,1]=Τριλ[3,1]) ΚΑΙ (Τριλ[1,1]=Τριλ[2,1])) Ή ((Τριλ[1,1]=Τριλ[2,2]) ΚΑΙ (Τριλ[2,2]=Τριλ[3,3])) ΤΟΤΕ
          ΥπΝικ <-- Αληθής
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ_ΑΝ (Γρ=1) ΚΑΙ (Στ=2) ΤΟΤΕ
        ΑΝ ((Τριλ[1,2]=Τριλ[1,1]) ΚΑΙ (Τριλ[1,2]=Τριλ[1,3]))Ή((Τριλ[1,2]=Τριλ[2,2]) ΚΑΙ (Τριλ[1,2]=Τριλ[3,2])) ΤΟΤΕ
          ΥπΝικ <-- Αληθής
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ_ΑΝ (Γρ=1) ΚΑΙ (Στ=3) ΤΟΤΕ
        ΑΝ ((Τριλ[1,2]=Τριλ[1,3]) ΚΑΙ (Τριλ[1,1]=Τριλ[1,3]))Ή((Τριλ[1,3]=Τριλ[2,2]) ΚΑΙ (Τριλ[2,2]=Τριλ[3,1])) Ή((Τριλ[1,3]=Τριλ[2,3]) ΚΑΙ (Τριλ[2,3]=Τριλ[3,3])) ΤΟΤΕ
          ΥπΝικ <-- Αληθής
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ_ΑΝ (Γρ=2) ΚΑΙ (Στ=1) ΤΟΤΕ
        ΑΝ ((Τριλ[2,1]=Τριλ[2,2]) ΚΑΙ (Τριλ[2,2]=Τριλ[2,3]))Ή((Τριλ[1,1]=Τριλ[2,1]) ΚΑΙ (Τριλ[2,1]=Τριλ[3,1])) ΤΟΤΕ
          ΥπΝικ <-- Αληθής
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ_ΑΝ (Γρ=2) ΚΑΙ (Στ=2) ΤΟΤΕ
        ΑΝ ((Τριλ[2,2]=Τριλ[1,2]) ΚΑΙ (Τριλ[2,2]=Τριλ[3,2]))Ή((Τριλ[2,1]=Τριλ[2,2]) ΚΑΙ (Τριλ[2,2]=Τριλ[2,3])) ΤΟΤΕ
          ΥπΝικ <-- Αληθής
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ_ΑΝ (Γρ=2) ΚΑΙ (Στ=3) ΤΟΤΕ
        ΑΝ ((Τριλ[2,2]=Τριλ[2,1]) ΚΑΙ (Τριλ[2,2]=Τριλ[2,3]))Ή((Τριλ[1,3]=Τριλ[2,3]) ΚΑΙ (Τριλ[2,3]=Τριλ[3,3])) ΤΟΤΕ
          ΥπΝικ <-- Αληθής
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ_ΑΝ (Γρ=3) ΚΑΙ (Στ=1) ΤΟΤΕ
        ΑΝ ((Τριλ[3,1]=Τριλ[3,2]) ΚΑΙ (Τριλ[3,2]=Τριλ[3,3]))Ή((Τριλ[3,1]=Τριλ[2,2]) ΚΑΙ (Τριλ[2,2]=Τριλ[1,3])) Ή((Τριλ[3,1]=Τριλ[2,1]) ΚΑΙ (Τριλ[2,1]=Τριλ[1,1])) ΤΟΤΕ
          ΥπΝικ <-- Αληθής
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ_ΑΝ (Γρ=3) ΚΑΙ (Στ=2) ΤΟΤΕ
        ΑΝ ((Τριλ[3,2]=Τριλ[3,1]) ΚΑΙ (Τριλ[3,2]=Τριλ[3,3]))Ή((Τριλ[3,2]=Τριλ[2,2]) ΚΑΙ (Τριλ[2,2]=Τριλ[1,2])) ΤΟΤΕ
          ΥπΝικ <-- Αληθής
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ ! Γρ=3 και Στ=3
        ΑΝ ((Τριλ[1,3]=Τριλ[3,3]) ΚΑΙ (Τριλ[3,3]=Τριλ[2,3]))Ή((Τριλ[3,3]=Τριλ[3,2]) ΚΑΙ (Τριλ[3,2]=Τριλ[3,1])) Ή((Τριλ[3,3]=Τριλ[2,2]) ΚΑΙ (Τριλ[2,2]=Τριλ[1,1])) ΤΟΤΕ
          ΥπΝικ <-- Αληθής
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
      Σειρά <-- (Σειρά+1) MOD 2
    ΜΕΧΡΙΣ_ΟΤΟΥ (ΥπΝικ=Αληθής) Ή (Ελευθ=0)
    ΑΝ ΥπΝικ=Αληθής ΤΟΤΕ
      ΑΝ Σειρά=0 ΤΟΤΕ
        Νικ1 <-- Νικ1+1
      ΑΛΛΙΩΣ
        Νικ2 <-- Νικ2+1
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ
      Ισοπ <-- Ισοπ+1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Νίκες πρώτου παίκτη=', Νικ1
  ΓΡΑΨΕ 'Νίκες δεύτερου παίκτη=', Νικ2
  ΓΡΑΨΕ 'Ισοπαλίες=', Ισοπ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Τρίλιζα




 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters