Τώρα είναι Τρί 02 Ιουν 2020 10:27 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 6 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Προπαίδεια
ΔημοσίευσηΔημοσιεύτηκε: Τρί 03 Φεβ 2009 06:12 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 03 Φεβ 2009 06:01 pm
Δημοσιεύσεις: 2
Γεια σας,
Πηγαινω τριτη γυμνασιου και ειμαι τελειως αρχαριος, απλα θα ηθελα να ασχοληθω λιγο παραπανω και στο σπιτι εκτος απο αυτα που κανουμε στο σχολειο. Γι'αυτο οταν μου δωσετε μια απαντηση παρακαλω να ειναι ο κωδικας οσο πιο απλοποιημενος γινεται, ωστε να μπορω να τον καταλαβω κι εγω.
Καναμε μες στην ταξη την ασκηση να βρουμε την προπαιδεια ενος αριθμου. Μεχρι στιγμης ολα οκ και ο αλγοριθμος ηταν ο εξης.

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ  Προπαίδεια
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α,ν
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε τον αριθμό του οποίου'
  ΓΡΑΨΕ_'την προπαίδεια θέλεις να δεις :'
  ΔΙΑΒΑΣΕ α
  ΓΙΑ ν  ΑΠΟ  1  ΜΕΧΡΙ  10
    ΓΡΑΨΕ '  ',ν,'χ',α,' = '*α
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ  Προπαίδεια


Οταν το τελειωσαμε μας ζητησε οταν τελειωνει η προπαιδεια να επαναλαμβανεται και να την σταματαω πληκτρολογωντας κατι. Ομως χτυπησε κουδουνι και δεν προλαβαμε να το τελειωσουμε και την επομενη φορα δεν βλεπω να το κανουμε. Παρακαλω βοηθηστε με για την συνεχεια.

Ευχαριστω εκ των προτερων :D


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Προπαίδεια
ΔημοσίευσηΔημοσιεύτηκε: Τρί 03 Φεβ 2009 09:23 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 22 Οκτ 2008 12:08 pm
Δημοσιεύσεις: 31
Τοποθεσία: Αθήνα
ΩΡΑΙΟΣ , ΣΥΓΧΑΡΗΤΗΡΙΑ ΠΟΥ ΑΣΧΟΛΕΙΣΑΙ !!!! ΜΙΑΣ ΚΑΙ ΔΕΝ ΕΧΩ ΠΟΛΥ ΧΡΟΝΟ Η ΑΠΑΝΤΗΣΗ ΜΠΟΡΕΙ ΝΑ ΜΗΝ ΕΙΝΑΙ ΚΑΙ ΤΕΛΕΙΑ...... ΠΑΝΤΩΣ ΘΑ ΧΑΡΩ ΝΑ ΒΟΗΘΗΣΩ.

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ  Προπαίδεια
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α,ν
  ΛΟΓΙΚΕΣ : ΣΥΝΘΗΚΗ !
  ΧΑΡΑΚΤΗΡΕΣ : ΑΠΑΝΤΗΣΗ !
ΑΡΧΗ
  ΣΥΝΘΗΚΗ <-- ΑΛΗΘΗΣ!
  ΟΣΟ ΣΥΝΘΗΚΗ = ΑΛΗΘΗΣ ΕΠΑΝΑΛΑΒΕ!
  ΓΡΑΨΕ 'Δώσε τον αριθμό του οποίου'
  ΓΡΑΨΕ_'την προπαίδεια θέλεις να δεις :'
  ΔΙΑΒΑΣΕ α
  ΓΙΑ ν  ΑΠΟ  1  ΜΕΧΡΙ  10
    ΓΡΑΨΕ '  ',ν,'χ',α,' = '*α
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'ΘΕΣ ΝΑ ΕΠΑΝΑΛΑΒΕΙΣ ΤΗΝ ΠΡΟΠΑΙΔΕΙΑ???' !
  ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΑΠΑΝΤΗΣΤΕ ΜΕ ΕΝΑ ΝΑΙ Ή ΕΝΑ ΟΧΙ' !ΤΟ ΓΡΑΦΩ ΑΥΤΟ ΓΙΑ ΝΑ ΜΗΝ ΚΑΝΕΙ ΕΛΕΓΧΟ  
  ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΑΠΑΝΤΗΣΤΕ ΣΕ ΚΕΦΑΛΑΙΑ ΕΛΛΗΝΙΚΑ' !ΕΓΚΥΡΟΤΗΤΑΣ ΚΑΤΙ ΠΟΥ ΘΑ ΜΑΘΕΙΣ ΑΡΓΟΤΕΡΑ
  ΔΙΑΒΑΣΕ ΑΠΑΝΤΗΣΗ !
  ΑΝ ΑΠΑΝΤΗΣΗ = 'ΝΑΙ' ΤΟΤΕ
  ΣΥΝΘΗΚΗ <-- ΑΛΗΘΗΣ
  ΑΛΛΙΩΣ
  ΣΥΝΘΗΚΗ <-- ΨΕΥΔΗΣ
  ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ  Προπαίδεια

ΠΙΣΤΕΥΩ ΝΑ ΒΟΗΘΗΣΑ :mrgreen:


ΤΩΡΑ ΤΟ ΕΙΔΑ !!!!! ΕΙΧΑ ΞΕΧΑΣΕΙ ΝΑ ΒΑΛΩ ΤΟ ΝΑΙ ΣΕ ΕΙΣΑΓΩΓΙΚΑ , ΕΥΤΥΧΩΣ ΤΟ ΔΙΟΡΘΩΣΑ , ΤΩΡΑ ΛΕΙΤΟΥΡΓΕΙ ΣΩΣΤΑ!

_________________
"The ultimate measure of a man is not where he stands in moments of comfort and convenience, but where he stands at times of challenge and controversy."
- Martin Luther King Jr. -


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Προπαίδεια
ΔημοσίευσηΔημοσιεύτηκε: Τρί 03 Φεβ 2009 09:33 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 03 Φεβ 2009 06:01 pm
Δημοσιεύσεις: 2
Syntax: [ Download ] [ Hide ]
ΑΝ ΑΠΑΝΤΗΣΗ = 'ΝΑΙ' ΤΟΤΕ
 


Μου λεει πως το "ΝΑΙ" ειναι αγνωστο ονομα και δεν εχει προαναφερθει. Μηπως πρεπει να το γραψω στις μεταβλητες;


Problem Fixed :DΔουλευει μια χαρα. Ευχαριστω πολυ (τελικα ηταν ευκολο :wink: )

Ομως θα ηθελα να ρωτησω κατι: τα θαυμαστικα που δινεις μετα απο τις μεταβλητες 'ΣΥΝΘΗΚΗ' και 'ΑΠΑΝΤΗΣΗ' τα οποια χρησιμοποιεις και μετα στο τελος της εντολης ΓΡΑΨΕ ειναι απαραιτητα για κατι;


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Προπαίδεια
ΔημοσίευσηΔημοσιεύτηκε: Τετ 04 Φεβ 2009 01:57 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 22 Οκτ 2008 12:08 pm
Δημοσιεύσεις: 31
Τοποθεσία: Αθήνα
ΞΕΧΑΣΑ ΝΑ ΣΤΟ ΑΝΑΦΕΡΩ ΦΙΛΕ , ΤΑ ΘΑΥΜΑΣΤΙΚΑ ΤΑ ΕΒΑΛΑ ΔΙΟΤΙ ΗΘΕΛΑ ΝΑ ΤΟΝΙΣΩ ΠΟΙΕΣ ΣΕΙΡΕΣ ΠΡΟΣΘΕΣΑ ΣΤΟ ΠΡΟΓΡΑΜΜΑ . ΣΤΗΝ ΠΡΑΓΜΑΤΙΚΟΤΗΤΑ ΤΑ ΘΑΜΑΥΣΤΙΚΑ ΧΡΗΣΙΜΕΥΟΥΝ ΓΙΑ ΝΑ ΠΑΡΑΘΕΤΕΙΣ ΣΧΟΛΙΑ . ΠΡΟΣΟΧΗ ΣΧΟΛΙΟ ΕΙΝΑΙ ΟΤΙ ΓΡΑΦΕΙΣ ΜΕΤΑ ΤΟ ΘΑΥΜΑΣΤΙΚΟ . Π.Χ.
Syntax: [ Download ] [ Hide ]
 Υ<-- 5*Π ! ΥΠΟΛΟΓΙΖΩ ΠΟΣΟ ΚΑΝΕΙ ΠΕΝΤΕ ΦΟΡΕΣ ΤΟ Π

ΤΟ ΣΧΟΛΙΟ ΕΙΝΑΙ ΤΟ ΥΠΟΛΟΓΙΖΩ.....
ΕΛΠΙΖΩ ΝΑ ΣΕ ΒΟΗΘΗΣΑ 8)

_________________
"The ultimate measure of a man is not where he stands in moments of comfort and convenience, but where he stands at times of challenge and controversy."
- Martin Luther King Jr. -


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Προπαίδεια
ΔημοσίευσηΔημοσιεύτηκε: Παρ 03 Απρ 2009 04:08 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 03 Απρ 2009 04:01 pm
Δημοσιεύσεις: 3
to x den exei arxikh timh :shock:


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Προπαίδεια
ΔημοσίευσηΔημοσιεύτηκε: Παρ 03 Απρ 2009 04:09 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 03 Απρ 2009 04:01 pm
Δημοσιεύσεις: 3
sorry den proseksa oti htan keimeno :?


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 6 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters