Τώρα είναι Δευτ 01 Ιουν 2020 04:32 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Thermokrasies 50 polewn.
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 15 Νοέμ 2008 07:58 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 15 Νοέμ 2008 07:40 pm
Δημοσιεύσεις: 2
Na grafei ALGORITHMOS pou :
a) Na diavazei to onoma kai tis thermokrasies 50 polewn
b) Na kanei elegxo orthotitas oti oi thermokrasies einai apo -40 ews 45
c) Na vriskei se poia polh exei shmeiwthei megalyterh thermokrasia
d) Na ypologizei ton meso oro twn thermokrasiwn olwn twn polewn
e) Na vriskei to pososto ton polewn pou exoun thermokrasia panw apo 20 bathmous.

Exw aythn thn askhsh gia thn trith kai thn xreiazomai shmera h avrio kai exw kolhsei sto erwtima c ola ta alla xerw pws na ta vrw . Ekei pou mperdeyomai einai mporw na brw thn megalyterh thermokrasia (max) alla den mporw na pw se poia polh antistoixei. Kai prepei na lythei xwris Pinakes.

Koitaxte ti exw kanei kai diwrthwste me an exw lathos.

Αλγοριθμος Θερμοκρασίες
μ <- 0 sum <- 0
Για i απο 1 μεχρι 50
Διαβασε Π ! Π=Πόλη
Αρχη_Επανάληψης
Διάβασε Θ ! Θ= Θερμοκρασία
Μέχρις_ότου Θ>= -40 και Θ<= 45
Αν Θ>max τότε
max <- Θ
Τέλος_αν
Αν Θ>20 τότε
μ <- μ + 1
Τέλος_αν
sum <- sum + Θ
Τέλος_Επανάληψης
μο <- sum / 50 ! μο= μέσος ορος
ποσ <- μ/50*100 ! ποσ= ποσοστό
Τέλος Θερμοκρασίες


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Thermokrasies 50 polewn.
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 17 Νοέμ 2008 12:57 am 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
Ελπίζω να βοηθήσει και να μην είναι άσκηση που έπρεπε να κάνεις χωρίς βοήθεια… :?
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΘΕΡΜΟΚΡΑΣΙΕΣ
ΣΤΑΘΕΡΕΣ
  Ν = 50
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι, ΜΕΤΡΗΤΗΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΘΕΡΜ, ΜΕΓΘ, ΑΘΡΟΙΣΜΑ, ΜΟ, ΠΟΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΠΟΛ, ΜΕΓΠ
ΑΡΧΗ
  ΜΕΤΡΗΤΗΣ <-- 0
  ΜΕΓΘ <-- -50
  ΑΘΡΟΙΣΜΑ <-- 0
  ΜΕΓΠ <-- ' '
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΤΟ ΟΝΟΜΑ ΤΗΣ ΠΟΛΗΣ:'
    ΔΙΑΒΑΣΕ ΠΟΛ
    ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΤΗΝ ΘΕΡΜΟΚΡΑΣΙΑ ΤΗΣ ΠΟΛΗΣ:'
    ΔΙΑΒΑΣΕ ΘΕΡΜ
    ΑΝ ΘΕΡΜ< -40 Ή ΘΕΡΜ > 45 ΤΟΤΕ
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΡΑΨΕ 'Η ΘΕΡΜΟΚΡΑΣΙΑ ΠΡΕΠΕΙ ΝΑ ΕΙΝΑΙ ΜΕΤΑΞΥ -40 ΚΑΙ 45'
        ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΞΑΝΑ ΔΩΣΤΕ ΤΗΝ ΘΕΡΜΟΚΡΑΣΙΑ:'
        ΔΙΑΒΑΣΕ ΘΕΡΜ
      ΜΕΧΡΙΣ_ΟΤΟΥ ΘΕΡΜ >=-40 ΚΑΙ ΘΕΡΜ <=45
    ΤΕΛΟΣ_ΑΝ
    ΑΝ ΘΕΡΜ > ΜΕΓΘ ΤΟΤΕ
      ΜΕΓΘ <-- ΘΕΡΜ
      ΜΕΓΠ <-- ΠΟΛ
    ΑΛΛΙΩΣ_ΑΝ ΘΕΡΜ=ΜΕΓΘ ΤΟΤΕ
      ΜΕΓΘ <-- ΘΕΡΜ
      ΜΕΓΠ <-- ΜΕΓΠ + ' & ' + ΠΟΛ
    ΤΕΛΟΣ_ΑΝ
    ΑΘΡΟΙΣΜΑ <-- ΑΘΡΟΙΣΜΑ+ΘΕΡΜ
    ΑΝ ΘΕΡΜ > 20 ΤΟΤΕ
      ΜΕΤΡΗΤΗΣ <-- ΜΕΤΡΗΤΗΣ+1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΜΟ <-- ΑΘΡΟΙΣΜΑ / Ν
  ΠΟΣ <-- (ΜΕΤΡΗΤΗΣ*100)/Ν
  ΓΡΑΨΕ 'ΜΕΓΑΛΗΤΕΡΗ ΗΤΑΝ Η ΘΕΡΜΟΚΡΑΣΙΑ ΣΕ :', ΜΕΓΠ
  ΓΡΑΨΕ 'Ο ΜΕΣΟΣ ΟΡΟΣ ΤΩΝ ΘΕΡΜΟΚΡΑΣΙΩΝ ΕΙΝΑΙ:', ΜΟ
  ΓΡΑΨΕ 'ΤΟ ΠΟΣΟΣΤΟ ΤΩΝ ΠΟΛΕΩΝ ΠΟΥ ΕΙΧΑΝ ΘΕΡΜΟΚΡΑΣΙΑ ΠΑΝΩ ΑΠΟ 20 ΒΑΘΜΟΥΣ ΗΤΑΝ', ΠΟΣ, '%'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 

Υ.Γ. ΜΕΓΘ <-- -50 : Μπορεί να είναι 1 οποιαδήποτε τιμή αρκεί να είναι μικρότερη του -40

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters