Τώρα είναι Τρί 02 Ιουν 2020 11:50 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 5 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ειδος τριγωνου
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 05 Οκτ 2008 03:18 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 21 Σεπ 2008 05:49 pm
Δημοσιεύσεις: 5
Syntax: [ Download ] [ Hide ]
!Να αναπτυχθεί αλγοριθμος που να διαβαζει       !
!το μηκος τριων πλευρων  και                    !
!αφου ελεγξει αν οριζουν τριγωνο να βρισκει     !
!το ειδος του τριγωνου που οριζουν να εμφανιζει !
!αναλογο μηνυμα                                 !

ΠΡΟΓΡΑΜΜΑ  ειδος_τριγωνου
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: α, β, γ, max, κ1, κ2, θ, δ, π

ΑΡΧΗ
  ΓΡΑΨΕ 'Δωσε την πλευρα α:'
  ΔΙΑΒΑΣΕ α
  ΓΡΑΨΕ 'Δωσε την πλευρα β:'
  ΔΙΑΒΑΣΕ β
  ΓΡΑΨΕ 'Δωσε την πλευρα γ:'
  ΔΙΑΒΑΣΕ γ

  π <-- β+γ
  δ <-- Α_Τ(β-γ)
 
 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
   
    ΑΝ α<δ η α>π ΤΟΤΕ
      ΓΡΑΨΕ 'Δεν ορίζεται τριγωνο'
      ΓΡΑΨΕ 'Δωσε ξανά την πλευρα α:'
      ΔΙΑΒΑΣΕ α
      ΓΡΑΨΕ 'Δωσε ξανά την πλευρα β:'
      ΔΙΑΒΑΣΕ β
      ΓΡΑΨΕ 'Δωσε ξανά την πλευρα γ:'
      ΔΙΑΒΑΣΕ γ
    ΤΕΛΟΣ_ΑΝ
   
  π <-- β+γ
  δ <-- Α_Τ(β-γ)
  ΜΕΧΡΙΣ_ΟΤΟΥ α<π και α>δ

  ΑΝ α=β και α=γ ΤΟΤΕ
    ΓΡΑΨΕ 'Το τριγωνο ειναι ισοπλευρο'
  ΑΛΛΙΩΣ_ΑΝ α=β η α=γ η β=γ ΤΟΤΕ
    ΓΡΑΨΕ 'Το τριγωνο ειναι ισοσκελες'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Το τριγωνο ειναι σκαληνο'
  ΤΕΛΟΣ_ΑΝ

  ΓΡΑΨΕ '            και'

  max <-- α
  ΑΝ β>max ΤΟΤΕ
    max <-- β
  ΤΕΛΟΣ_ΑΝ
  ΑΝ γ>max ΤΟΤΕ
    max <-- γ
  ΤΕΛΟΣ_ΑΝ

  ΑΝ α=max  ΤΟΤΕ
    κ1 <-- β
    κ2 <-- γ
  ΤΕΛΟΣ_ΑΝ
  ΑΝ β=max ΤΟΤΕ
    κ1 <-- α
    κ2 <-- γ
  ΤΕΛΟΣ_ΑΝ
  ΑΝ γ=max ΤΟΤΕ
    κ1 <-- β
    κ2 <-- α
  ΤΕΛΟΣ_ΑΝ

  max <-- max^2
  θ <-- κ1^2+κ2^2

  ΑΝ max>θ  ΤΟΤΕ
    ΓΡΑΨΕ '                 αμβλυγωνιο'
  ΤΕΛΟΣ_ΑΝ
  ΑΝ max<θ  ΤΟΤΕ
    ΓΡΑΨΕ '                 οξυγωνιο'
  ΤΕΛΟΣ_ΑΝ
  ΑΝ max=θ ΤΟΤΕ
    ΓΡΑΨΕ '                 ορθογωνιο'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ειδος_τριγωνου

 

Περιμενω σχολια!


Τελευταία επεξεργασία από TELIS και Δευτ 10 Νοέμ 2008 03:47 pm, έχει επεξεργασθεί 2 φορά/ες συνολικά

Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Ειδος τριγωνου
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 05 Οκτ 2008 11:46 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
Συγχαρητήρια για την ιδέα, μου άρεσε πολύ.
Όσο για τα σχόλια που περιμένεις έχω 2 διορθώσεις να προτείνω.
1) Νομίζω ότι πρέπει να προστεθεί έλεγχος για τα μήκη των πλευρών των τριγώνων. (Τρίγωνο με αρνητικά μήκη πλευρών δεν ορίζετε, σκέψου και την περίπτωση του μήκους 0)
2)
Syntax: [ Download ] [ Hide ]
ΑΝ α<δ η α<δ ΤΟΤΕ
μήπως ήθελες να πεις
Syntax: [ Download ] [ Hide ]
αν α<δ ή α > π τοτε
ή κάτι παρόμοιο αντί για α<δ ή α<δ;
επίσης σε όλη αυτήν την επανάληψη
Syntax: [ Download ] [ Hide ]
π <-- β+γ
  δ <-- Α_Τ(β-γ)

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ α<δ η α<δ ΤΟΤΕ
      ΓΡΑΨΕ 'Δεν ορίζεται τριγωνο'
      ΓΡΑΨΕ 'Δωσε ξανά την πλευρα α:'
      ΔΙΑΒΑΣΕ α
      ΓΡΑΨΕ 'Δωσε ξανά την πλευρα β:'
      ΔΙΑΒΑΣΕ β
      ΓΡΑΨΕ 'Δωσε ξανά την πλευρα γ:'
      ΔΙΑΒΑΣΕ γ
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ α<π και α>δ

Νομίζω ότι πρέπει να γίνει :

Syntax: [ Download ] [ Hide ]
 π<-- β+γ
  δ <-- Α_Τ(β-γ)
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
       ΑΝ α<δ η α>π ΤΟΤΕ                                
          ΓΡΑΨΕ 'Δεν ορίζεται τριγωνο'
     ΓΡΑΨΕ 'Δωσε ξανά την πλευρα α:'
     ΔΙΑΒΑΣΕ α
      ΓΡΑΨΕ 'Δωσε ξανά την πλευρα β:'
     ΔΙΑΒΑΣΕ β
     ΓΡΑΨΕ 'Δωσε ξανά την πλευρα γ:'
     ΔΙΑΒΑΣΕ γ
   ΤΕΛΟΣ_ΑΝ
 π<-- β+γ
  δ <-- Α_Τ(β-γ)
 ΜΕΧΡΙΣ_ΟΤΟΥ α<π και α>δ

Μαζί με την διόρθωση που είπα πιο πάνω.
Επίσης να σκεφτείς την περίπτωση της πλευράς = 0 και της περίπτωσης α=δ ή α=π


Φιλικά,
periklis93

Υ.Γ. Άμα κάνω κάποιο λάθος συγγνώμη και σας παρακαλώ να με διορθώσετε γιατί νομίζω ότι δεν ξέρω τον κανόνα της γεωμετρίας στο οποίο αναφέρετε.

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Ειδος τριγωνου
ΔημοσίευσηΔημοσιεύτηκε: Τρί 07 Οκτ 2008 11:21 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 21 Σεπ 2008 05:49 pm
Δημοσιεύσεις: 5
Φιλε Περικλή και συναδελφε προγραμματιστη,
Σε ευχαριστω πολυ για τα καλα λογια καθως και για τις διορθωσεις.
Ειμαι εντυπωσιασμενος που εισαι μολις 15 και εισαι τοσο εξοικιομενος με τον προγραμματισμό.
Στην ηλικια σου εβλεπα το PC σαν παιχνιδομηχανη.
Επιπλεον, σε δικαιολογω απολυτα που δεν ξερεις το θεωρημα που χρησιμοποιησα.
Υπαρχει στην υλη της β' λυκειου (νομιζω..) .
Για το προγραμμα εχω να αντιπροτεινω τα εξης:

1. Για να ελεγξω αν υπαρχει τριγωνο χρησιμοποιησα την τριγωνικη ανισοτητα που περιλαμβανει
και τις περιπτωσεις που ειπες. Δηλαδη αν μια πλευρα ειναι μηδεν ή αν δοθει αρνητικο μηκος πλευρας.
Αυτο μπορεις ευκολα να το διαπιστωσεις με παραδειγματα.

2. Εχεις δικαιο για τον ελεγχο. Επρεπε να γραψω:
ΑΝ α<δ Ή α>π ΤΟΤΕ κλπ..
Λαθος απροσεξιας καταλαβαινεις...

3. Πιστευω ομως οτι δεν χρειζονται οι εντολες |π<--β+γ | στο τελος της επαναληψης.
|δ<--Α_Τ(β-γ) |

4. Επισης ειναι λαθος που εβαλα το τμημα του αλγοριθμου που ελεγχει το ειδος τριγωνου ως προς το μηκος των πλευρων
πριν να ελεγθει αν οριζεται τριγωνο.

Σε ευχαριστω και παλι για τα σχολια και ευχομαι να συνεχισεις ετσι. Εκανα τις αλλαγες στο αρχικο προγραμμα.


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Ειδος τριγωνου
ΔημοσίευσηΔημοσιεύτηκε: Τρί 07 Οκτ 2008 05:00 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
Έχω την άποψη ότι και όμως οι 2 γραμμές :
Syntax: [ Download ] [ Hide ]
π <-- β+γ
  δ <-- Α_Τ(β-γ)
 

Χρειάζονται στην επανάληψη. Για να το διαπιστώσεις μπορείς να δοκιμάσεις το εξής παράδειγμα: την πρώτη φορά να δώσεις ως α το 6, ως β το 0 και ως γ το 3. Μετά βγάζει ότι δεν ορίζετε τρίγωνο. Οπότε δίνουμε ως α το 6, ως β το 3 και ως γ το 4. Τρίγωνο με αυτές τις πλευρές υπάρχει και είναι ένα αμβλυγώνιο αλλά μπορείς και να το ελέγξεις αν υπάρχει(κάτι που είναι και το σωστό). Θα παρατηρήσεις αν χρησιμοποιείς την καινούρια έκδοση ότι το π και το δ δεν έχουν αλλάξει τιμές και ότι συνεχίζει να θεωρεί ότι δεν υπάρχει τέτοιο τρίγωνο.
‘’ Επίσης να σκεφτείς την περίπτωση της πλευράς = 0 και της περίπτωσης α = δ ή α = π ‘’ αυτό το είπα γιατί στην επανάληψη αν υπάρξει η περίπτωση όπου το α = δ ή/και α = π η επανάληψη συνεχίζετε για πάντα και δεν λέει ούτε ότι το τρίγωνο δεν ορίζετε δηλαδή ούτε σταματάει την επανάληψη μέσω της μεχρις_οτου αφού δεν είναι α < π και α > δ ούτε είναι αληθής η συνθήκη της αν που βρίσκετε μέσα στην επανάληψη αφού ούτε το α < δ ή α > π ισχύει. Και ένα παράδειγμα : αν δώσεις ως α το 3, ως β το 0 και ως γ το 3 τότε το πρόγραμμα δεν σταματάει την επανάληψη και δεν δίνει την δυνατότητα να αλλάξουμε τις τιμές αφού δεν εκτελείτε το περιεχόμενο της αν. (για αυτό είπα και το να σκεφτείς τις περιπτώσεις για πλευρά = 0)

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Ειδος τριγωνου
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 10 Νοέμ 2008 03:44 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 21 Σεπ 2008 05:49 pm
Δημοσιεύσεις: 5
periklis93 οι διορθωσεις που προτεινεις ειναι σωστες.
Τις προσθεσα στο αρχικο προγραμμα.
Ευχαριστω.


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 5 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 3 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters