Τώρα είναι Τρί 02 Ιουν 2020 12:13 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Υπολογισμός S=α+α^2+...+α^ν
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 20 Δεκ 2007 05:33 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 20 Δεκ 2007 05:29 pm
Δημοσιεύσεις: 13
Syntax: [ Download ] [ Hide ]
! -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
! Θέμα 3ο (20 μονάδες)
! Δοθέντος πραγματικού αριθμού α και θετικού ν, να αναπτυχθεί αλγόριθμος
! που να υπολογίζει την σειρά: S=α+α^2+...+α^ν, για οποιοδήποτε πλήθος
! αριθμών ν>0 δοθεί από τον χρήστη και να εμφανίζει το αποτέλεσμα
! (Υπόδειξη: Να γίνει έλεγχος για τον θετικό ν).
! -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-


ΠΡΟΓΡΑΜΜΑ Θέμα_3
!Τμήμα δηλώσεων
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: α,S
  ΑΚΕΡΑΙΕΣ: ν,i
ΑΡΧΗ
  ΓΡΑΨΕ 'Το πρόγραμμα υπολογίζει το S=α+α^2+...+α^ν'
  ΓΡΑΨΕ_ 'Δώσε το α='
  ΔΙΑΒΑΣΕ α
  ΓΡΑΨΕ_ 'Δώσε το ν='
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ ν
  ΜΕΧΡΙΣ_ΟΤΟΥ (ν>0)
  S <-- 0
  i <-- 1
  ΟΣΟ (i<=ν) ΕΠΑΝΑΛΑΒΕ
    S <-- S+α^i
    i <-- i+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Το αθροισμά τους είναι S=',S
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters