Τώρα είναι Τρί 02 Ιουν 2020 11:20 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Δωσε μοιρες παρε ΗΜ, ΣΥΝ, ΕΦ
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 28 Δεκ 2006 01:10 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 04 Νοέμ 2006 01:07 am
Δημοσιεύσεις: 20
Ενα προγραμμα το οποιο διαβαζει μοιρες και οχι rad και υπολογιζει το ΗΜ, ΣΥΝ και ΕΦ :wink:

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ μοιρες
ΣΤΑΘΕΡΕΣ
  π=3.14
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: επιλογη
  ΠΡΑΓΜΑΤΙΚΕΣ: φ,rad
ΑΡΧΗ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    φ <-- 0
    rad <-- 0
    επιλογη <-- 0

    ΓΡΑΨΕ 'Τι θελεις να υπολογισω?'
    ΓΡΑΨΕ '1. ΗΜ'
    ΓΡΑΨΕ '2. ΣΥΝ'
    ΓΡΑΨΕ '3. ΕΦ'
    ΓΡΑΨΕ '4. Τιποτα'
    ΟΣΟ επιλογη>4 Η επιλογη<1 ΕΠΑΝΑΛΑΒΕ
      ΔΙΑΒΑΣΕ επιλογη
      ΑΝ  επιλογη>4 Η επιλογη<1 ΤΟΤΕ
        ΓΡΑΨΕ 'Λαθος επιλογη!'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΕΠΙΛΕΞΕ επιλογη
      ΠΕΡΙΠΤΩΣΗ 1
        ΓΡΑΨΕ 'Δωσε τις μοιρες'
        ΔΙΑΒΑΣΕ φ
        rad <-- φ*(π/180)
        ΓΡΑΨΕ 'Το ημιτονο της γωνιας',φ,'ειναι', ΗΜ(rad)
      ΠΕΡΙΠΤΩΣΗ 2
        ΓΡΑΨΕ 'Δωσε τις μοιρες'
        ΔΙΑΒΑΣΕ φ
        rad <-- φ*(π/180)
        ΓΡΑΨΕ 'Το συνημιτονο της γωνιας',φ,'ειναι', ΣΥΝ(rad)
      ΠΕΡΙΠΤΩΣΗ 3
        ΓΡΑΨΕ 'Δωσε τις μοιρες'
        ΔΙΑΒΑΣΕ φ
        ΑΝ (Α_Μ(φ)-90) MOD  180  = 0 ΤΟΤΕ
          ΓΡΑΨΕ 'Λαθος μοιρες'
        ΑΛΛΙΩΣ
          rad <-- φ*(π/180)
          ΓΡΑΨΕ 'Η εφαπτομενη της γωνιας',φ,'ειναι', ΕΦ(rad)
        ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ
    ΓΡΑΨΕ
  ΜΕΧΡΙΣ_ΟΤΟΥ επιλογη=4
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ μοιρες
 


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Παρ 17 Οκτ 2008 12:16 pm 
Χωρίς σύνδεση

Εγγραφή: Δευτ 29 Σεπ 2008 12:34 am
Δημοσιεύσεις: 5
Πρόσθεσα υπολογισμό συνεφαπτωμένης και διόθωσα κάποιους πλεονασμούς
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ μοιρες
ΣΤΑΘΕΡΕΣ
  π=3.14
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: επιλογη
  ΠΡΑΓΜΑΤΙΚΕΣ: φ,rad
ΑΡΧΗ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Τι θελεις να υπολογισω?'
    ΓΡΑΨΕ '1. ΗΜ'
    ΓΡΑΨΕ '2. ΣΥΝ'
    ΓΡΑΨΕ '3. ΕΦ'
    ΓΡΑΨΕ '4. ΣΦ'
    ΓΡΑΨΕ '5. Τιποτα'
    ΔΙΑΒΑΣΕ επιλογη
    ΟΣΟ επιλογη>5 Η επιλογη<1 ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'Λαθος επιλογη!'
      ΔΙΑΒΑΣΕ επιλογη
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΕΠΙΛΕΞΕ επιλογη
      ΠΕΡΙΠΤΩΣΗ 1
        ΓΡΑΨΕ 'Δωσε τις μοιρες'
        ΔΙΑΒΑΣΕ φ
        rad <-- φ*(π/180)
        ΓΡΑΨΕ 'Το ημιτονο της γωνιας',φ,'ειναι', ΗΜ(rad)
      ΠΕΡΙΠΤΩΣΗ 2
        ΓΡΑΨΕ 'Δωσε τις μοιρες'
        ΔΙΑΒΑΣΕ φ
        rad <-- φ*(π/180)
        ΓΡΑΨΕ 'Το συνημιτονο της γωνιας',φ,'ειναι', ΣΥΝ(rad)
      ΠΕΡΙΠΤΩΣΗ 3
        ΓΡΑΨΕ 'Δωσε τις μοιρες'
        ΔΙΑΒΑΣΕ φ
        ΑΝ (Α_Μ(φ-90)) MOD  180  = 0 ΤΟΤΕ
          ΓΡΑΨΕ 'Λαθος μοιρες'
        ΑΛΛΙΩΣ
          rad <-- φ*(π/180)
          ΓΡΑΨΕ 'Η εφαπτομενη της γωνιας',φ,'ειναι', ΕΦ(rad)
        ΤΕΛΟΣ_ΑΝ
      ΠΕΡΙΠΤΩΣΗ 4
        ΓΡΑΨΕ 'Δωσε τις μοίρες'
        ΔΙΑΒΑΣΕ φ
        ΑΝ Α_Μ(φ)  MOD  180 = 0 ΤΟΤΕ
          ΓΡΑΨΕ 'Λαθος μοιρες'
        ΑΛΛΙΩΣ
          rad <-- φ*(π/180)
          ΓΡΑΨΕ 'Η εφαπτομενη της γωνιας',φ,'ειναι',1/ΕΦ(rad)
        ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ
    ΓΡΑΨΕ
  ΜΕΧΡΙΣ_ΟΤΟΥ επιλογη=5
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ μοιρες

_________________
gameswonderer@hotmail.com


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters