Τώρα είναι Δευτ 01 Ιουν 2020 04:24 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Γεροντότερος και νεότερος
ΔημοσίευσηΔημοσιεύτηκε: Τρί 26 Δεκ 2006 03:59 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! Να γραφεί πρόγραμμα το οποίο :
! · να δέχεται το όνομα, το επώνυμο και την ηλικία ενός πλήθους ανθρώπων
! · να υπολογίζει και εμφανίζει το μέσο όρο των ηλικιών
! · να βρίσκει και να εμφανίζει το ονοματεπώνυμο και την ηλικία του νεώτερου
!   και του γεροντότερου από αυτούς.
! Το πρόγραμμα τερματίζεται αν δοθεί ως ηλικία αριθμός αρνητικός ή μηδέν και
! δε δέχεται ηλικία μεγαλύτερη των 115 ετών.
! Να μη χρησιμοποιηθεί πίνακας.

ΠΡΟΓΡΑΜΜΑ ΕΠ_1_17
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i, Ν
  ΠΡΑΓΜΑΤΙΚΕΣ: ηλικια ,s , max , min , mo
  ΧΑΡΑΚΤΗΡΕΣ: ονομα , γερος , νεος
ΑΡΧΗ
  Ν <-- 0
  s <-- 0
  min <-- 200
  max <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    Ν <-- Ν +1
    ΓΡΑΨΕ 'Δώσε επώνυμο του/της ', Ν
    ΔΙΑΒΑΣΕ ονομα
    ΓΡΑΨΕ 'Δώσε και την ηλικία του/της'
    ΔΙΑΒΑΣΕ ηλικια
    ΟΣΟ ηλικια < 0 ή ηλικια > 115 ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'Λάθος. Ξαναδώσε.'
      ΔΙΑΒΑΣΕ ηλικια
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ηλικία > 0 ΤΟΤΕ
      ΑΝ ηλικία > max ΤΟΤΕ
        max <-- ηλικια
        γερος <-- ονομα              
      ΤΕΛΟΣ_ΑΝ
      ΑΝ ηλικία < min ΤΟΤΕ
        min <-- ηλικια
        νεος <-- ονομα
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    s <-- s + ηλικια
  ΜΕΧΡΙΣ_ΟΤΟΥ ηλικια <= 0
  mo <-- s /(Ν-1)
  ΓΡΑΨΕ 'Μέσος όρος ηλικιών =' , mo
  ΓΡΑΨΕ 'Νεώτερος ο/η',νεος,'με ηλικία',min,'έτη.'
  ΓΡΑΨΕ 'Γεροντότερος ο/η',γερος,'με ηλικία',max,'έτη.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Τετ 27 Δεκ 2006 02:22 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 26 Ιαν 2006 07:53 pm
Δημοσιεύσεις: 2
Το πρόγραμμα αυτό δεν έχει σωστή συνθήκη τερματισμού και επιπλέον υπολογίζει και τις αρνητικές τιμές ηλικιών στο Μ.Ο.
Παραθέτω μια διορθωμένη εκδοχή του.

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΕΠ_1_17
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i, Ν
  ΠΡΑΓΜΑΤΙΚΕΣ: ηλικια ,s , max , min , mo
  ΧΑΡΑΚΤΗΡΕΣ: ονομα , γερος , νεος
ΑΡΧΗ
  Ν <-- 0
  s <-- 0
  min <-- 200
  max <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    Ν <-- Ν + 1
    ΓΡΑΨΕ 'Δώσε το ονοματεπώνυμο Νο', Ν
    ΔΙΑΒΑΣΕ ονομα
    ΓΡΑΨΕ 'Δώσε την ηλικία:'
    ΔΙΑΒΑΣΕ ηλικια
    ΟΣΟ ηλικια > 115 ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'Λάθος. Ξαναδώσε:'
      ΔΙΑΒΑΣΕ ηλικια
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ηλικία > 0 ΤΟΤΕ
      ΑΝ ηλικία > max ΤΟΤΕ
        max <-- ηλικια
        γερος <-- ονομα
      ΤΕΛΟΣ_ΑΝ
      ΑΝ ηλικία < min ΤΟΤΕ
        min <-- ηλικια
        νεος <-- ονομα
      ΤΕΛΟΣ_ΑΝ
      s <-- s + ηλικια
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ ηλικια <= 0
  mo <-- s /(Ν-1)
  ΓΡΑΨΕ 'Μέσος όρος ηλικιών =' , mo
  ΓΡΑΨΕ 'Νεώτερος ο/η',νεος,'με ηλικία',min,'έτη.'
  ΓΡΑΨΕ 'Γεροντότερος ο/η',γερος,'με ηλικία',max,'έτη.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters