Τώρα είναι Δευτ 01 Ιουν 2020 04:53 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Παλινδρομικοί Αριθμοί *
ΔημοσίευσηΔημοσιεύτηκε: Τετ 13 Σεπ 2006 07:09 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 22 Απρ 2004 11:16 am
Δημοσιεύσεις: 60
Τοποθεσία: Θεσσαλονίκη
Παλινδρομικός καλείται ένας αριθμός ο οποίος όταν τα ψηφία του διαβάζονται από το τελευταίο προς το πρώτο προκύπτει πάλι ο ίδιος αριθμός με αυτόν πχ. 12321. Πρώτος παλιδρομικός θεωρείται ένας αριθμός που είναι ταυτόχρονα πρώτος και παλιδρομικός. Να γραφεί πρόγραμμα που να εμφανίζει όλους τους πρώτους παλινδρομικούς αριθμούς μεταξύ δοθέντων ακεραίων α και β με 1<=α,β<=16000.
ΠΑΡΑΔΕΙΓΜΑ
Εάν α=5 και β=600 τότε πρέπει να εμφανιστούν οι επόμενοι αριθμοι:
5
7
11
101
131
151
181
191
313
353
373
383

(Απο τον Πανελλήνιο Διαγωνισμό Πληροφορικής 1999, Γ Γυμνασίου Α΄ φαση)

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Παλινδρομικοι
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:α,β,i,j,Ν,ψ,Κ
  ΛΟΓΙΚΕΣ: πρωτος
ΑΡΧΗ
  ΓΡΑΨΕ 'Δωσε α'
  ΔΙΑΒΑΣΕ α
  ΓΡΑΨΕ 'Δωσε β'
  ΔΙΑΒΑΣΕ β

  ΓΙΑ i ΑΠΟ α ΜΕΧΡΙ β
    πρωτος <-- αληθής
    j <-- 2
    ΟΣΟ (j<=i-1) ΚΑΙ (πρωτος=αληθής) ΕΠΑΝΑΛΑΒΕ
      ΑΝ i MOD j = 0 ΤΟΤΕ
        πρωτος <-- ψευδής
      ΤΕΛΟΣ_ΑΝ
      j <-- j+1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    ΑΝ πρωτος = αληθής ΤΟΤΕ
      ψ <-- 0
      Κ <-- i
      ΟΣΟ  Κ<>0 ΕΠΑΝΑΛΑΒΕ
        Κ <-- Κ DIV 10
        ψ <-- ψ+1
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      Ν <-- 0
      Κ <-- i
      ΟΣΟ  Κ<>0 ΕΠΑΝΑΛΑΒΕ
        ψ <-- ψ-1
        Ν <-- Ν+(Κ MOD 10)* Α_Μ(10^ψ)
        Κ <-- Κ DIV 10
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΝ Ν=i ΤΟΤΕ
        ΓΡΑΨΕ i
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 

_________________
Φρειδερίκος Κώστας
FreiderikosK@hotmail.com


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters