Τώρα είναι Τρί 02 Ιουν 2020 09:53 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 03 Απρ 2006 10:08 am 
Χωρίς σύνδεση

Εγγραφή: Πέμ 21 Ιούλ 2005 10:34 am
Δημοσιεύσεις: 11
Τοποθεσία: ΚΑΣΤΟΡΙΑ
Να υλοποιηθεί αλγόριθμος ο οποίος εμφανίζει τα ψηφία ενός οκταψήφιου αριθμού Ν που δίνεται από το πληκτρολόγιο, με αντίστροφή σειρά.
Αν δηλαδή δοθεί ο αριθμός 83042641, να εμφανιστούν με σειρά τα ψηφία 1 4 6 2 4 0 3 8.

Syntax: [ Download ] [ Hide ]
! Να υλοποιηθεί αλγόριθμος ο οποίος εμφανίζει τα ψηφία ενός οκταψήφιου αριθμού Ν
! που δίνεται από το πληκτρολόγιο, με αντίστροφή σειρά. Αν δηλαδή δοθεί ο αριθμός
! 83042641, να εμφανιστούν με σειρά τα ψηφία 1 4 6 2 4 0 3 8.

ΠΡΟΓΡΑΜΜΑ Αντιστροφή_ψηφίων
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:α,ι
ΑΡΧΗ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ                            
    ΓΡΑΨΕ 'Δώσε έναν οκταψήφιο αριθμό'
    ΔΙΑΒΑΣΕ α
  ΜΕΧΡΙΣ_ΟΤΟΥ α>9999999 ΚΑΙ α<100000000

  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 7
    ΑΝ α>99 ΤΟΤΕ
      ΓΡΑΨΕ_ α MOD 10
      α <-- α DIV 10
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ_ α MOD 10
      ΓΡΑΨΕ_ α DIV 10
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ                              



 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 4 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters