Τώρα είναι Δευτ 01 Ιουν 2020 04:13 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΤΕΤΡΑΔΥΜΟΙ
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 04 Φεβ 2006 11:09 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 04 Φεβ 2006 01:44 pm
Δημοσιεύσεις: 2
Το παρακάτω θέμα απότελεσε θέμα σε εξεταστική των Ηλεκτρολόγων Μηχανικών και Μηχανικών Η/Υ του Ε.Μ.Π. :

Τέσσερις πρώτοι αριθμοί που ανληκου στην ίδια δεκάδα και λήγουν λέγονται τετράδυμοι αντίστοιχα σε 1,3,7 και 9 ονομάζονται τετράδυμοι. Παράδειγμα τετραδύμων πρώτων αριθμών είναι οι 11,13,17,19.Ένας αριθμός ονομάζεται τετραγινόμενο αν είναι το γινόμενο τεσσα΄ρων τετραδύμων αριθμών.
Παράδειγμα τετραγινομένου είναι ο 46189 = 11 x 13 x 17 x 19.
Να γραψεται ένα κομψό και αποδοτικό πρόγραμμα που:
α)ρωτάει τον χρήστη για το n
β)τυπώνει στην οθόνη το μεγαλύτερο τετραγινόμενο που είναι μικρότερο από το n.
γ)επαναλλαμβάνει τη διαδικασία αν ο χρήστης το επιθυμεί.


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΤΕΤΡΑΔΥΜΟΙ
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 20 Οκτ 2008 09:00 pm 
Χωρίς σύνδεση

Εγγραφή: Δευτ 29 Σεπ 2008 12:34 am
Δημοσιεύσεις: 5
Μια αργή και όχι τόσο κομψή λύση αλλά τουλάχιστον 100% λειτουργική (άμα έχεις την υπομονή που απαιτείτε)
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ τετράδυμοι
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: n,ρ,θ,κ5,κ6,κ7,κ8,κ
  ΧΑΡΑΚΤΗΡΕΣ: ξανα
  ΛΟΓΙΚΕΣ: πρωτος
ΑΡΧΗ
  κ5 <-- 0
  ξανα <-- 'ν'
  ΟΣΟ ξανα='ν' ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'Δώσε μέγιστο όριο τετραγινόμενου'
    ΔΙΑΒΑΣΕ n
    ΑΝ n >= 46189 ΤΟΤΕ
      ρ <-- Α_Μ(Τ_Ρ(Τ_Ρ(n)))
      ρ <-- ρ DIV 10
      ρ <-- ρ*10
      κ5 <-- ρ+11
      κ6 <-- ρ+13
      κ7 <-- ρ+17
      κ8 <-- ρ+19
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          κ5 <-- κ5-10
          κ6 <-- κ6-10
          κ7 <-- κ7-10
          κ8 <-- κ8-10
          θ <-- κ5*κ6*κ7*κ8
        ΜΕΧΡΙΣ_ΟΤΟΥ θ<=n ΚΑΙ κ5 MOD 3 <>0 ΚΑΙ κ5 MOD 7 <>0 ΚΑΙ κ6 MOD 3 <>0 ΚΑΙ κ6 MOD 7 <>0 ΚΑΙ κ7 MOD 3 <>0 ΚΑΙ κ7 MOD 7 <>0 ΚΑΙ κ8 MOD 3 <>0 ΚΑΙ κ8 MOD 7 <>0 Η κ5<0
        κ <-- 3
        ΟΣΟ κ <= Α_Μ(Τ_Ρ(κ5)) ΕΠΑΝΑΛΑΒΕ
          ΑΝ κ5 MOD κ <> 0 ΤΟΤΕ
            πρωτος <-- ΑΛΗΘΗΣ
            κ <-- κ+2
          ΑΛΛΙΩΣ
            κ <-- κ5
            πρωτος <-- ΨΕΥΔΗΣ
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΑΝ πρωτος ΤΟΤΕ
          κ <-- 5
          ΟΣΟ κ <= Α_Μ(Τ_Ρ(κ6)) ΕΠΑΝΑΛΑΒΕ
            ΑΝ κ6 MOD κ <> 0 ΤΟΤΕ
              πρωτος <-- ΑΛΗΘΗΣ
              κ <-- κ+2
            ΑΛΛΙΩΣ
              κ <-- κ6
              πρωτος <-- ΨΕΥΔΗΣ
            ΤΕΛΟΣ_ΑΝ
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          ΑΝ πρωτος ΤΟΤΕ
            κ <-- 5
            ΟΣΟ κ <= Α_Μ(Τ_Ρ(κ7)) ΕΠΑΝΑΛΑΒΕ
              ΑΝ κ7 MOD κ <> 0 ΤΟΤΕ
                πρωτος <-- ΑΛΗΘΗΣ
                κ <-- κ+2
              ΑΛΛΙΩΣ
                κ <-- κ7
                πρωτος <-- ΨΕΥΔΗΣ
              ΤΕΛΟΣ_ΑΝ
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΑΝ πρωτος ΤΟΤΕ
              κ <-- 5
              ΟΣΟ κ <= Α_Μ(Τ_Ρ(κ8)) ΕΠΑΝΑΛΑΒΕ
                ΑΝ κ8 MOD κ <> 0 ΤΟΤΕ
                  πρωτος <-- ΑΛΗΘΗΣ
                  κ <-- κ+2
                ΑΛΛΙΩΣ
                  κ <-- κ8
                  πρωτος <-- ΨΕΥΔΗΣ
                ΤΕΛΟΣ_ΑΝ
              ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΤΕΛΟΣ_ΑΝ
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΑΝ
      ΜΕΧΡΙΣ_ΟΤΟΥ πρωτος
      ΑΝ κ5>0 ΤΟΤΕ
        ΓΡΑΨΕ 'Ο μέγιστος τετράδυμος είναι ο',θ,'που προκύπτει από τους εξής πρώτους:',κ5,κ6,κ7,κ8
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'Δεν υπάρχει μικρότερος τετράδυμος'
      ΤΕΛΟΣ_ΑΝ
      ΓΡΑΨΕ 'Θέλετε να συνεχίσετε; Πληκτρολογίστε ν για ναι ή ο για όχι'
      ΔΙΑΒΑΣΕ ξανα
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Δεν υπάρχει μικρότερος τετράδυμος'
      ΓΡΑΨΕ 'Θέλετε να συνεχίσετε; Πληκτρολογίστε ν για ναι ή ο για όχι'
      ΔΙΑΒΑΣΕ ξανα
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ  τετράδυμοι
 

_________________
gameswonderer@hotmail.com


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΤΕΤΡΑΔΥΜΟΙ
ΔημοσίευσηΔημοσιεύτηκε: Τρί 21 Οκτ 2008 01:23 am 
Χωρίς σύνδεση

Εγγραφή: Δευτ 29 Σεπ 2008 12:34 am
Δημοσιεύσεις: 5
Kαι εδώ μια πιο κομψή και μαθηματική λύση που σκέφτηκα μετά από πολύ σκέψη οφείλω να ομολογήσω (σχετικά αργό ακόμα αλλά μακράν καλύτερο απο τη προηγούμενη έκδοση)
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ τετράδυμοι
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: n,ρ,κ
  ΧΑΡΑΚΤΗΡΕΣ: ξανα
  ΛΟΓΙΚΕΣ: πρωτος
ΑΡΧΗ
  ξανα <-- 'ν'
  πρωτος <-- ΑΛΗΘΗΣ
  ΟΣΟ ξανα='ν' ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'Δώσε μέγιστο όριο τετραγινόμενου'
    ΔΙΑΒΑΣΕ n
    ΑΝ n >= 46189 ΤΟΤΕ
      ρ <-- (((Α_Μ(Τ_Ρ(Τ_Ρ(n))) DIV 10 -1)DIV 3)*3+1)*10+31
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ρ <-- ρ-30
        ΜΕΧΡΙΣ_ΟΤΟΥ ρ MOD 3<>0 ΚΑΙ ρ MOD 7<>0 ΚΑΙ (ρ+2) MOD 3<>0 ΚΑΙ (ρ+2) MOD 7<>0 ΚΑΙ (ρ+6) MOD 3<>0 ΚΑΙ (ρ+6) MOD 7<>0 ΚΑΙ (ρ+8) MOD 3<>0 ΚΑΙ (ρ+8) MOD 7<>0 Η ρ<0
        κ <-- 11
        ΟΣΟ κ <= Α_Μ(Τ_Ρ(ρ+8)) ΕΠΑΝΑΛΑΒΕ
          ΑΝ ρ MOD κ <> 0 ΚΑΙ (ΟΧΙ(κ=(ρ MOD κ)+2)) ΚΑΙ (ΟΧΙ(κ=(ρ MOD κ)+6)) ΚΑΙ (ΟΧΙ(κ=(ρ MOD κ)+8)) ΤΟΤΕ
            πρωτος <-- ΑΛΗΘΗΣ
            κ <-- κ+2
          ΑΛΛΙΩΣ
            κ <-- ρ
            πρωτος <-- ΨΕΥΔΗΣ
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΜΕΧΡΙΣ_ΟΤΟΥ πρωτος
      ΓΡΑΨΕ 'Ο μέγιστος τετράδυμος είναι ο'*(ρ+2)*(ρ+6)*(ρ+8),'που προκύπτει από τους εξής πρώτους:',ρ,ρ+2,ρ+6,ρ+8
      ΓΡΑΨΕ 'Θέλετε να συνεχίσετε; Πληκτρολογίστε ν για ναι ή ο για όχι'
      ΔΙΑΒΑΣΕ ξανα
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Δεν υπάρχει μικρότερος τετράδυμος'
      ΓΡΑΨΕ 'Θέλετε να συνεχίσετε; Πληκτρολογίστε ν για ναι ή ο για όχι'
      ΔΙΑΒΑΣΕ ξανα
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ  τετράδυμοι

_________________
gameswonderer@hotmail.com


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters