Τώρα είναι Τρί 15 Οκτ 2019 10:01 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: TETRATION
ΔημοσίευσηΔημοσιεύτηκε: Τρί 17 Σεπ 2019 02:21 am 
Χωρίς σύνδεση

Εγγραφή: Τρί 17 Σεπ 2019 01:07 am
Δημοσιεύσεις: 3
Syntax: [ Download ] [ Hide ]
! ΤΟ ΚΑΤΩΘΙ ΠΡΟΓΡΑΜΜΑ ΥΠΟΛΟΓΙΖΕΙ ΤΟ ΑΠΟΤΕΛΕΣΜΑ ΤΗΣ ΜΑΘΗΜΑΤΙΚΗΣ ΣΥΝΑΡΤΗΣΗΣ TETRATION.
! F(Χ, 0) = 1
! F(Χ, Ψ) = Χ ^ F(Χ, Ψ - 1)
! Ο Χ ΕΙΝΑΙ ΑΥΣΤΗΡΑ ΘΕΤΙΚΟΣ ΑΚΕΡΑΙΟΣ.
! Ο Ψ ΕΙΝΑΙ ΜΗ ΑΡΝΗΤΙΚΟΣ ΑΚΕΡΑΙΟΣ.
! ΠΡΟΣΟΧΗ!!!  
! ΓΙΑ Χ = 2, ΔΙΝΕΤΕ Ψ <= 4.
! ΓΙΑ 3 <= Χ <= 4, ΔΙΝΕΤΕ Ψ <= 3.
! ΓΙΑ 5 <= Χ <= 143, ΔΙΝΕΤΕ Ψ <= 2.
! ΓΙΑ Χ >= 144, ΔΙΝΕΤΕ Ψ <= 1.                            
! ΓΙΑ ΩΡΑΙΟΤΕΡΗ ΕΜΦΑΝΙΣΗ ΤΗΣ ΕΞΟΔΟΥ ΑΠΕΝΕΡΓΟΠΟΙΗΣΤΕ ΤΟΝ ΔΙΑΧΩΡΙΣΜΟ ΠΑΡΑΜΕΤΡΩΝ ΤΗΣ ΓΡΑΨΕ (ΠΑΤΗΣΤΕ F9).

ΠΡΟΓΡΑΜΜΑ TETRATION
ΜΕΤΑΒΛΗΤΕΣ      
  ΑΚΕΡΑΙΕΣ: Χ, Ψ, Α, Ι
ΑΡΧΗ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΔΩΣΕ Χ'
    ΔΙΑΒΑΣΕ Χ
  ΜΕΧΡΙΣ_ΟΤΟΥ Χ > 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΔΩΣΕ Ψ'
    ΔΙΑΒΑΣΕ Ψ
  ΜΕΧΡΙΣ_ΟΤΟΥ Ψ >= 0
  Α <-- 1
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ψ
    Α <-- Χ ^ Α
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'F(', Χ, ', ', Ψ, ') = ', Α
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Διαβάστε περισσότερα.


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters