Τώρα είναι Τρί 02 Ιουν 2020 12:11 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 16 Φεβ 2004 02:34 am 
Χωρίς σύνδεση

Εγγραφή: Παρ 14 Μαρ 2003 06:19 pm
Δημοσιεύσεις: 13
Πιστεύω ότι όσοι μελετήσουν την άσκηση θα πάρουν μια πρώτη γεύση για τις διαφορές αλλά και τις ομοιότητες μεταξύ των τριών δομών επανάληψης. Σύντομα θα επανέλθω με περισσότερο υλικό και με τρόπους μετατροπής της μίας δομής στην άλλη.
Syntax: [ Download ] [ Hide ]
!============================================================
! Να γραφεί πρόγραμμα το οποίο θα υπολογίζει το άθροισμα και
! το γινόμενο των ζυγών αριθμών από 11 μέχρι 31 και με τις
! τρεις δομές επανάληψης.
!============================================================
! (panos giannakopoulos)                                                  
!============================================================
ΠΡΟΓΡΑΜΜΑ  Υπολογισμός_Αθροίσματος_και_Γινομένου_ζυγών_αριθμών

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i, sum, product

ΑΡΧΗ
  sum       <-- 0
  product   <-- 1

  ΓΡΑΨΕ 'Υπολογισμός με Eπανάληψη της μορφής: ΓΙΑ..ΑΠΟ..ΜΕΧΡΙ..'
  ΓΡΑΨΕ '====================================================================='
  ΓΙΑ i ΑΠΟ 11 ΜΕΧΡΙ 31
    ΑΝ i MOD 2 = 0 ΤΟΤΕ
      sum       <-- sum + i
      product   <-- product * i
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Το άθροισμα των ζυγών αριθμών από 11 μέχρι 31 είναι: ', sum
  ΓΡΑΨΕ 'Το γινόμενο των ζυγών αριθμών από 11 μέχρι 31 είναι: ', product

  ΓΡΑΨΕ 'Υπολογισμός με Eπανάληψη της μορφής: ΑΡΧΗ ΕΠΑΝΑΛΗΨΗΣ..ΜΕΧΡΙΣ ΟΤΟΥ..'
  ΓΡΑΨΕ '====================================================================='
  sum       <-- 0
  product   <-- 1
  i <-- 11
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ i MOD 2 = 0 ΤΟΤΕ
      sum       <-- sum + i
      product   <-- product * i
    ΤΕΛΟΣ_ΑΝ
    i <-- i + 1
  ΜΕΧΡΙΣ_ΟΤΟΥ (i>31)
  ΓΡΑΨΕ'Το άθροισμα των ζυγών αριθμών από 11 μέχρι 31 είναι: ', sum
  ΓΡΑΨΕ'Το γινόμενο των ζυγών αριθμών από 11 μέχρι 31 είναι: ', product

  ΓΡΑΨΕ 'Υπολογισμός με Eπανάληψη της μορφής: ΟΣΟ..ΕΠΑΝΑΛΑΒΕ..ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ'
  ΓΡΑΨΕ '====================================================================='
  sum       <-- 0
  product   <-- 1
  i <-- 11
  ΟΣΟ i<=31 ΕΠΑΝΑΛΑΒΕ
    ΑΝ i MOD 2 = 0 ΤΟΤΕ
      sum       <-- sum + i
      product   <-- product * i
    ΤΕΛΟΣ_ΑΝ
    i <-- i + 1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ'Το άθροισμα των ζυγών αριθμών από 11 μέχρι 31 είναι: ', sum
  ΓΡΑΨΕ'Το γινόμενο των ζυγών αριθμών από 11 μέχρι 31 είναι: ', product

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Υπολογισμός_Αθροίσματος_και_Γινομένου_ζυγών_αριθμών
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters