Τώρα είναι Τρί 23 Ιούλ 2019 06:43 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Παρ 27 Δεκ 2013 11:05 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 26 Δεκ 2013 12:46 pm
Δημοσιεύσεις: 8
    ΓΙΑ ΤΟ ΚΕΦΑΛΑΙΟ ΤΗΣ ΣΥΜΒΟΛΗΣ :wink: :wink:


Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ  Υπερβολες_ενισχυσης_και_αποσβεσης
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:απ,λ,dmax,dmin,dmax1,dmax2,dmin1,dmin2
  ΑΚΕΡΑΙΕΣ:εν,απβ,απαν,κ2,κ1
  ΧΑΡΑΚΤΗΡΕΣ:ξ
ΑΡΧΗ
  ΓΡΑΨΕ 'Το πρόγραμμα αυτο εχει δυο δυνατοτητες'
  ΓΡΑΨΕ '1.)Το πρόγραμμα διαβαζει την αποσταση μεταξυ δυο συγχρονων πηγων που βρισκονται σε ιδια ευθεια,'
  ΓΡΑΨΕ 'και υπολογιζει πόσες υπερβολες ενισχυσης και αποσβεσης  υπαρχουν'
  ΓΡΑΨΕ '2.Το πρόγραμμα διαβαζει ποσες υπερβολες ενισχυσης και αποσβεσης υπαρχουν'
  ΓΡΑΨΕ 'και βρισκει ποση πρεπει να ειναι η αποσταση μεταξυ των πηγων'
  ΓΡΑΨΕ 'ΠΡΟΣΟΧΗ!!!η αποσταση και το μηκος κυματος να δοθουν σε ιδιες μοναδες(π.χ και τα δυο σε m η και τα δυο σε cm)'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'Ποια λειτουργια του προγραμματος θες να χρησιμοποιησεις?(1 η 2)'
      ΔΙΑΒΑΣΕ απαν
    ΜΕΧΡΙΣ_ΟΤΟΥ απαν=1 η απαν=2
    ΑΝ απαν=1 τοτε
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΡΑΨΕ 'δωσε την αποσταση μεταξυ των πηγων'
        ΔΙΑΒΑΣΕ απ
      ΜΕΧΡΙΣ_ΟΤΟΥ απ>0
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΡΑΨΕ 'Δωσε μηκος κυματος'
        ΔΙΑΒΑΣΕ λ
      ΜΕΧΡΙΣ_ΟΤΟΥ λ>0
      ΑΝ Α_Μ(απ/λ)-απ/λ<>0 τοτε
        κ1 <-- Α_Μ(-απ/λ)
      ΑΛΛΙΩΣ
        κ1 <-- Α_Μ(-απ/λ+1)
      ΤΕΛΟΣ_ΑΝ
      εν <-- 0
      ΟΣΟ κ1<απ/λ επανάλαβε
        εν <-- εν+1
        κ1 <-- κ1+1
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'οι υπερβολες ενισχυσης ειναι:',εν
      ΑΝ Α_Μ(απ/λ+1/2)-(απ/λ+1/2)<>0 τοτε
        κ2 <-- Α_Μ(-απ/λ-1/2)
      ΑΛΛΙΩΣ
        κ2 <-- Α_Μ(-απ/λ+1/2)
      ΤΕΛΟΣ_ΑΝ
      απβ <-- 0
      ΟΣΟ κ2<(απ/λ-1/2) επανάλαβε
        απβ <-- απβ+1
        κ2 <-- κ2+1
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'οι υπερβολες αποσβεσης ειναι:',απβ
    ΑΛΛΙΩΣ
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΡΑΨΕ 'δωσε αριθμο υπερβολων ενισχυσης(περιττος αριθμος)'
        ΔΙΑΒΑΣΕ κ1
      ΜΕΧΡΙΣ_ΟΤΟΥ κ1 MOD 2<>0 και κ1>0
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΡΑΨΕ 'δωσε αριθμο υπερβολων αποσβεσης(αρτιος αριθμος)'
        ΔΙΑΒΑΣΕ κ2
      ΜΕΧΡΙΣ_ΟΤΟΥ κ2 MOD 2=0 και κ2>0
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΡΑΨΕ 'δωσε μηκος κυματος λ'
        ΔΙΑΒΑΣΕ λ
      ΜΕΧΡΙΣ_ΟΤΟΥ λ>0
      dmin1 <-- (κ1-1)*λ/2
      dmax1 <-- (κ1+1)*λ/2
      dmin2 <-- (κ2-1)*λ/2
      dmax2 <-- (κ2+1)*λ/2
      ΑΝ κ1>κ2 τότε
        dmax <-- dmax2
        dmin <-- dmin1
      ΑΛΛΙΩΣ
        dmax <-- dmax1
        dmin <-- dmin2
      ΤΕΛΟΣ_ΑΝ
      ΓΡΑΨΕ 'πρέπει',dmin,'<= d <=',dmax
    ΤΕΛΟΣ_ΑΝ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'ΞΑΝΑ?(ναι η οχι)'
      ΔΙΑΒΑΣΕ ξ
    ΜΕΧΡΙΣ_ΟΤΟΥ ξ='ναι' η ξ='οχι'
  ΜΕΧΡΙΣ_ΟΤΟΥ ξ='οχι'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ







 

_________________
paul


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters