Τώρα είναι Δευτ 16 Σεπ 2019 11:17 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ακολουθίες fibonacci
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 13 Οκτ 2012 11:24 am 
Χωρίς σύνδεση

Εγγραφή: Τετ 10 Οκτ 2012 04:00 am
Δημοσιεύσεις: 7
Στις ακολουθίες fibonacci (Φιμπονάτσι) κάθε αριθμός είναι το άθροισμα των 2 προηγούμενων. Έχουν τη ιδιότητα ο λόγος κάθε αριθμού προς τον προηγούμενο να πλησιάζει τη "χρυσή τομή" ή "χρυσή αναλογία", φ=(1+ρίζα(5))/2 που είναι περίπου 1,618.

Ορίστε ένα πρόγραμμα που ζητά τους 2 πρώτους όρους, έχει έλεγχο στην είσοδο καθώς και έλεγχο υπερχείλισης, στην περίπτωση που ξεφύγουμε λίγο και τα νούμερα γίνουν πολύ μεγάλα.

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΑΚΟΛΟΥΘΙΕΣ_FIBONACCI
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α[2],Β,Ν,Ι
ΑΡΧΗ
  ΓΡΑΨΕ 'Θέστε τους δύο πρώτους όρους της ακολουθίας:'
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 2
    ΓΡΑΨΕ 'Όρος',Ι,':'
    ΔΙΑΒΑΣΕ Α[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Πόσους όρους της ακολουθίας θέλετε;'
  Ν <-- 1
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ Ν<=0 ΤΟΤΕ
      ΓΡΑΨΕ 'Λάθος δεδομένα προσπαθήστε ξανά'
    ΤΕΛΟΣ_ΑΝ
    ΔΙΑΒΑΣΕ Ν
  ΜΕΧΡΙΣ_ΟΤΟΥ Ν>0
  ΓΡΑΨΕ ''
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν
    Β <-- Α[1]+Α[2]
    ΑΝ A[2]*Β<0 ΤΟΤΕ
      ΓΡΑΨΕ 'Σφάλμα υπερχείλισης'
      Ι <-- Ν+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ Β
      Α[1] <-- Α[2]
      Α[2] <-- Β
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

_________________
"Peace to everyone, and - who knows ? - maybe one day ... civilization !!!" - Pat Condell


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters