Τώρα είναι Τρί 18 Ιουν 2019 11:58 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Έλλειψη
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 13 Οκτ 2012 10:50 am 
Χωρίς σύνδεση

Εγγραφή: Τετ 10 Οκτ 2012 04:00 am
Δημοσιεύσεις: 7
Υπολογισμός στοιχείων έλλειψης. Το πρόγραμμα θέλει την έλλειψη σε κανονική μορφή και όχι σε γενική μορφή κωνικής τομής. Δηλαδή οι παράμετροι α και β είναι για την εξίσωση: x^2/a^2 + y^2/b^2 = 1 και ΟΧΙ για την εξίσωση: ax^2 + bxy + cy^2 + ex + zy = 1.

1. Το πρόγραμμα ζητά ο μικρός άξονας να ΜΗΝ είναι μεγαλύτερος από τον μεγάλο άξονα !!!

2. Υπάρχουν 2 διευθετούσες, αλλά στο πρόγραμμά μου δίνω ΜΟΝΟ τη μια. Βάζετε ένα ''μείον" στην εξισωση και έχετε και τη 2η διευθετούσα.

3. Ζητάει από το χρήστη να δώσει έναν αριθμό για να υπολογίσει το μήκος. Όσο μεγαλύτερο το νούμερο, τόσο μεγαλύτερη ακρίβεια στους υπολογισμούς. Για περίπου 10 δείγματα το (%) σφάλμα είναι ήδη πολύ μικρό.

Κώδικας:
ΠΡΟΓΡΑΜΜΑ Έλλειψη
ΣΤΑΘΕΡΕΣ
  Π=3.14159265
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι
  ΠΡΑΓΜΑΤΙΚΕΣ: Α,Β,ΜΗΚ,ΕΚ,ΕΜΒ,Κ,Σ
ΑΡΧΗ
  ΓΡΑΨΕ 'Ο μεγάλος άξονας ίσος ή μεγαλύτερος του μικρού'
  ΓΡΑΨΕ ''
  Ι <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ Ι>0 ΤΟΤΕ
      ΓΡΑΨΕ 'Λάθος δεδομένα προσπαθήστε ξανά'
      ΓΡΑΨΕ ''
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ 'Θέστε τον μεγάλο άξονα:'
    ΔΙΑΒΑΣΕ Α
    ΓΡΑΨΕ ''
    ΓΡΑΨΕ 'Θέστε τον μικρό άξονα:'
    ΔΙΑΒΑΣΕ Β
    ΓΡΑΨΕ ''
    Ι <-- Ι+1
  ΜΕΧΡΙΣ_ΟΤΟΥ Α>=Β ΚΑΙ Α>0 ΚΑΙ Β>0
  ΑΝ Α=Β ΤΟΤΕ
    ΓΡΑΨΕ 'Κύκλος'
    ΓΡΑΨΕ ' Μήκος:',2*Π*Α
    ΓΡΑΨΕ ' Εμβαδό',Π*Α^2
  ΑΛΛΙΩΣ
    ΜΗΚ <-- 0
    ΕΜΒ <-- Π*Α*Β
    ΕΚ <-- Τ_Ρ(Α^2-Β^2)/Α
    ΓΡΑΨΕ 'Εκκεντρότητα:',ΕΚ
    ΓΡΑΨΕ 'Διευθετούσα: Χ=',Α/ΕΚ
    ΓΡΑΨΕ 'Εμβαδό:',ΕΜΒ
    ΓΡΑΨΕ ''
    ΓΡΑΨΕ 'Θέστε πλήθος δειγμάτων'
    ΕΜΒ <-- 0
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΝ ΕΜΒ=1 ΤΟΤΕ
        ΓΡΑΨΕ ''
        ΓΡΑΨΕ 'Λάθος δεδομένα προσπαθήστε ξανά'
      ΤΕΛΟΣ_ΑΝ
      ΔΙΑΒΑΣΕ Β                     
      ΕΜΒ <-- 1
    ΜΕΧΡΙΣ_ΟΤΟΥ Β>0
    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Β
      ΜΗΚ <-- ΜΗΚ+Τ_Ρ(1-ΕΚ^2*(ΣΥΝ(Π/(2*Β)*(Ι-1/2)))^2)*Π/(2*Β)
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ ''
    ΓΡΑΨΕ 'Μήκος:',4*Α*ΜΗΚ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

_________________
"Peace to everyone, and - who knows ? - maybe one day ... civilization !!!" - Pat Condell


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters