Τώρα είναι Τρί 02 Ιουν 2020 10:43 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΠΡΩΤΟΙ ΑΡΙΘΜΟΙ
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 22 Ιαν 2004 07:35 am 
Χωρίς σύνδεση

Εγγραφή: Τετ 21 Ιαν 2004 03:43 am
Δημοσιεύσεις: 3
Syntax: [ Download ] [ Hide ]
!=======================================================================
! ΤΟ ΠΑΡΑΚΑΤΩ ΠΡΟΓΡΑΜΜΑ ΔΕΧΕΤΑΙ ΣΑΝ ΕΙΣΟΔΟ ΕΝΑΝ ΑΚΕΡΑΙΟ ΚΑΙ ΕΜΦΑΝΙΖΕΙ
! ΟΛΟΥΣ ΤΟΥΣ ΠΡΩΤΟΥΣ ΑΡΙΘΜΟΥΣ ΜΕΧΡΙ ΤΟΝ ΑΚΕΡΑΙΟ ΠΟΥ ΔΟΘΗΚΕ.
!=======================================================================
ΠΡΟΓΡΑΜΜΑ ΠΡΩΤΟΙ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: N,I,J,P,Q
  ΛΟΓΙΚΕΣ: F

ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΤΕ ΕΝΑΝ ΑΚΕΡΑΙΟ'
  ΔΙΑΒΑΣΕ N
  ΓΙΑ P ΑΠΟ 1 ΜΕΧΡΙ N
    F <-- ΑΛΗΘΗΣ
    Q <-- P DIV 2
    I <-- 2
    ΟΣΟ (I<=Q) ΚΑΙ (F=ΑΛΗΘΗΣ) ΕΠΑΝΑΛΑΒΕ
      ΑΝ P MOD I =0 ΤΟΤΕ
        F <-- ΨΕΥΔΗΣ
      ΑΛΛΙΩΣ
        I <-- I+1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ F=ΑΛΗΘΗΣ ΤΟΤΕ
      ΓΡΑΨΕ 'Ο  ',P,'  ΕΙΝΑΙ ΠΡΩΤΟΣ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 26 Νοέμ 2005 08:47 pm 
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Πρωτοι


ΜΕΤΑΒΛΗΤΕΣ

  ΑΚΕΡΑΙΕΣ: Ι,Ν,Π,Ρ
  ΛΟΓΙΚΕΣ: ΣΗΜΑΙΑ

ΑΡΧΗ

  Π <-- 0
  Ν <-- 2
  Ρ <-- 0
  ΣΗΜΑΙΑ <-- ΑΛΗΘΗΣ


  ΟΣΟ Ρ <= 100 ΕΠΑΝΑΛΑΒΕ

    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν
      ΑΝ (Ν MOD Ι) = 0 ΤΟΤΕ
        Π <-- Π + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ Π = 2 ΤΟΤΕ ! Ειναι πρωτος
      ΓΡΑΨΕ Ν
    ΤΕΛΟΣ_ΑΝ
    Ν <-- Ν + 1
    Π <-- 0
    Ρ <-- Ρ + 1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Πρωτοι
 


Κορυφή
  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters