Τώρα είναι Πέμ 20 Φεβ 2020 05:34 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΘΕΡΜΟΣΤΑΤΗΣ
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 08 Δεκ 2003 01:53 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 08 Οκτ 2003 03:30 pm
Δημοσιεύσεις: 1
Τοποθεσία: ΑΛΕΞΑΝΔΡΟΥΠΟΛΗ
Το πρόγραμμα "θερμοστάτης" προσομειώνει τη λειτουργία ενός θερμοστάτη. Συγκεκριμένα, δίνεται η επιθυμητή θερμοκρασία (ΤΕ), δηλαδή αυτή στην οποία ο χρήστης θέλει να σταματήσει ή λειτουργεια του καλοριφέρ και η στιγιμαία θερμοκρασία (ΤΣ), που είναι η θερμοκρασία του ώρου μια συγεκριμένη στιγμή. Αν ΤΣ<ΤΕ, τότε ζητάται νέα στιγμιαία θερμοκρασία. Αν ΤΣ>ΤΕ, τότε εμφανίζεται κατάλληλο μήνυμα που λέει όι η θεμροκρασία του χώρου έχει υπερβεί την επιθυμητή θερμοκρασία και ΤΣΕΚ <-- 1. Αυτό γίνεται, αν και δεν ισχύει στην πράξη, διότι δεν υπάρχει αισθητήρας και ο χρήστης είναι ελεύθερος να δώσει ό,τι θερμοκρασία θέλει. Αν ΤΣ>=ΤΕ, το πρόγραμμα βγαίνει από τη δομή επανάληψης, τυπώνοντας κατάλληλο μήνυμα.


Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΘΕΡΜΟΣΤΑΤΗΣ

ΜΕΤΑΒΛΗΤΕΣ
   ΑΚΕΡΑΙΕΣ: ΤΣ, ΤΕ, ΤΣΕΚ

ΑΡΧΗ
   ΤΣΕΚ <-- 0
   ΓΡΑΨΕ_ 'ΔΩΣΕ ΤΗΝ ΕΠΙΘΥΜΗΤΗ ΘΕΡΜΟΚΡΑΣΙΑ'
   ΔΙΑΒΑΣΕ ΤΕ
   
   ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
       ΓΡΑΨΕ_ 'ΔΩΣΕ ΤΗ ΣΤΙΓΜΙΑΙΑ ΘΕΡΜΟΚΡΑΣΙΑ'
       ΔΙΑΒΑΣΕ ΤΣ

       ΑΝ ΤΣ>ΤΕ ΤΟΤΕ
          ΓΡΑΨΕ 'Ο ΧΩΡΟΣ ΔΕΝ ΧΡΕΙΑΖΕΤΑΙ ΝΑ ΖΕΣΤΑΘΕΙ'
          ΤΣΕΚ <-- 1
       ΤΕΛΟΣ_ΑΝ
       
   ΜΕΧΡΙΣ_ΟΤΟΥ ΤΣ>=ΤΕ
     
      ΑΝ ΤΣΕΚ=0 ΤΟΤΕ
          ΓΡΑΨΕ 'Η ΘΕΡΜΟΚΡΑΣΙΑ ΤΟΥ ΧΩΡΟΥ ΕΙΝΑΙ ΙΣΗ ΜΕ ΤΗΝ ΕΠΙΘΥΜΗΤΗ  ΘΕΡΜΟΚΡΑΣΙΑ'
      ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΘΕΡΜΟΣΤΑΤΗΣ
 

_________________
Δ Μ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters