Τώρα είναι Πέμ 20 Φεβ 2020 05:50 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Κλιμακωτή χρέωση...
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 02 Νοέμ 2003 03:25 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 26 Οκτ 2003 02:28 pm
Δημοσιεύσεις: 3
Syntax: [ Download ] [ Hide ]
!====================================================
! Ένα μαγαζί που πουλάει φιλμ χρεώνει κλιμακωτά τους πελάτες του ως εξής:
!------------------------------------------------------------------------------------
! >> Για τα πρώτα 10 φιλμ προς 3.50 Ευρώ το ένα
! >> Για τα επόμενα 20 φιλμ προς 3.10 Ευρώ το ένα
! >> Για τα επόμενα 40 φιλμ προς 2.70 Ευρώ το ένα
! >> Για τα υπόλοιπα φιλμ προς 2.20 το ένα
!------------------------------------------------------------------------------------
! Να γραφεί αλγόριθμος που να υπολογίζει
! τι πρέπει να πληρώσει κάποιος που θέλει να αγοράσει φιλμ.
!------------------------------------------------------------------------------------
! Επίσης, να διαβάζεται η μάρκα του φιλμ:
! Αν είναι KODAK να προστίθεται 0.40 Ευρώ στην τιμή του ενός φιλμ.
! Αν είναι AGFA να προστίθεται 0.30 Ευρώ στην τιμή του ενός φιλμ.
! Αν είναι FUJIFILM να προστίθεται 0.20 Ευρώ στην τιμή του ενός φιλμ.
! Ειδάλλως, να μην προστίθεται τίποτα.
!------------------------------------------------------------------------------------
! Τέλος, αν συνολικό κόστος πάνω από 900 τότε 15% έκπτωση.
!====================================================

ΠΡΟΓΡΑΜΜΑ Κλιμακωτή_Χρέωση
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: Κόστος1, Κόστος2, Κόστος3, Σ_Κόστος, Τελικό_Κόστος
  ΑΚΕΡΑΙΕΣ: Φιλμ_Κ, Φιλμ_Α, Φιλμ_Φ, Φιλμ_Χ, Sum, Απάντηση
  ΧΑΡΑΚΤΗΡΕΣ: ΕΠΙΛΟΓΗ, χ

ΑΡΧΗ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Πόσα φιλμ KODAK θέλετε να αγοράσετε;'
    ΔΙΑΒΑΣΕ Φιλμ_Κ
    ΓΡΑΨΕ 'Πόσα φιλμ AGFA θέλετε να αγοράσετε;'
    ΔΙΑΒΑΣΕ Φιλμ_Α
    ΓΡΑΨΕ 'Πόσα φιλμ FUJIFILM θέλετε να αγοράσετε;'
    ΔΙΑΒΑΣΕ Φιλμ_Φ
    ΓΡΑΨΕ 'Πόσα φιλμ άλλης μάρκας θέλετε να αγοράσετε;'
    ΔΙΑΒΑΣΕ Φιλμ_Χ
    Κόστος1 <-- Φιλμ_Κ*0.4
    Κόστος2 <-- Φιλμ_Α*0.3
    Κόστος3 <-- Φιλμ_Φ*0.2
    Sum <-- Φιλμ_Κ+Φιλμ_Α+Φιλμ_Φ+Φιλμ_Χ

    ΑΝ (Sum<=10) ΤΟΤΕ
      Σ_Κόστος <-- Sum*3.5
    ΑΛΛΙΩΣ_ΑΝ (Sum<=30) ΤΟΤΕ
      Σ_Κόστος <-- 10*3.5 + (Sum-10)*3.1
    ΑΛΛΙΩΣ_ΑΝ (Sum<=70) ΤΟΤΕ
      Σ_Κόστος <-- 10*3.5 + 20*3.1 + (Sum-30)*2.7
    ΑΛΛΙΩΣ
      Σ_Κόστος <-- 10*3.5 + 20*3.1 + 30*2.7 + (Sum-70)*2.2
    ΤΕΛΟΣ_ΑΝ
    Τελικό_Κόστος <-- Σ_Κόστος + Κόστος1 + Κόστος2 + Κόστος3
    ΑΝ (Σ_Κόστος > 900) ΤΟΤΕ
      Σ_Κόστος <-- Σ_Κόστος*0.85
    ΤΕΛΟΣ_ΑΝ

    ΓΡΑΨΕ 'Η συνολική αξία είναι:', Σ_Κόστος, 'Ευρώ'
      !-------------
    ΓΡΑΨΕ 'Θέλετε να δείτε αναλυτικό λογαριασμό;'
    ΓΡΑΨΕ 'Αν ΝΑΙ, πατήστε 1'
    ΔΙΑΒΑΣΕ Απάντηση
    ΑΝ (Απάντηση=1) ΤΟΤΕ
      ΓΡΑΨΕ 'Το κόστος των φιλμ είναι:', Σ_Κόστος
      ΓΡΑΨΕ 'Το Πρόσθετο κόστος για KODAK είναι___: ', Κόστος1
      ΓΡΑΨΕ 'Το Πρόσθετο κόστος για AGFA είναι____: ', Κόστος2
      ΓΡΑΨΕ 'Το Πρόσθετο κόστος για FUJIFILM είναι: ', Κόστος3
    ΤΕΛΟΣ_ΑΝ
      !-------------
    ΓΡΑΨΕ 'Αν επιθυμείτε να επαναλάβετε το πρόγραμμα πατήστε οποιδήποτε πλήκτρο'
    ΓΡΑΨΕ 'Ειδάλλως, πατήστε 1'
    ΔΙΑΒΑΣΕ ΕΠΙΛΟΓΗ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΕΠΙΛΟΓΗ = '1'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Κλιμακωτή_Χρέωση
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters