Τώρα είναι Πέμ 27 Ιουν 2019 03:53 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΠΡΩΤΟΙ ΑΡΙΘΜΟΙ
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 28 Φεβ 2011 01:50 am 
Χωρίς σύνδεση

Εγγραφή: Δευτ 28 Φεβ 2011 12:51 am
Δημοσιεύσεις: 2
! Στο παρακάτω πρόγραμμα δίνουμε έναν θετικό ακέραιο και αυτό
! μας απαντά αν είναι πρώτος ή όχι
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ  ΠΡΩΤΟΙ_ΑΡΙΘΜΟΙ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α,Ι
  ΠΡΑΓΜΑΤΙΚΕΣ: Μ
  ΛΟΓΙΚΕΣ: ΕΙΝΑΙ_ΠΡΩΤΟΣ

ΑΡΧΗ
  ΓΡΑΨΕ 'ΕΙΣΑΓΕΤΕ ΕΝΑΝ ΘΕΤΙΚΟ ΑΚΕΡΑΙΟ ΑΡΙΘΜΟ...'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ Α
    ΑΝ Α<1 ΤΟΤΕ
      ΓΡΑΨΕ 'Ο ΑΡΙΘΜΟΣ ΠΡΕΠΕΙ ΝΑ ΕΙΝΑΙ ΘΕΤΙΚΟΣ ΑΚΕΡΑΙΟΣ!'
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ Α>0
  ΕΙΝΑΙ_ΠΡΩΤΟΣ <-- ΑΛΗΘΗΣ
  ΑΝ Α>3 ΤΟΤΕ  ! Οι 1, 2, 3 είναι πρώτοι...
    ΑΝ Α MOD 2 =0 ΤΟΤΕ
      ΕΙΝΑΙ_ΠΡΩΤΟΣ <-- ΨΕΥΔΗΣ ! Όλοι οι άρτιοι πάνω από 2 διαιρούνται τουλάχιστον με το 2...
    ΑΛΛΙΩΣ
      Μ <-- (Α-1)/2
      Ι <-- 3
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΑΝ Α MOD Ι =0 ΤΟΤΕ
          ΕΙΝΑΙ_ΠΡΩΤΟΣ <-- ΨΕΥΔΗΣ
        ΤΕΛΟΣ_ΑΝ
        Ι <-- Ι+1
      ΜΕΧΡΙΣ_ΟΤΟΥ (ΕΙΝΑΙ_ΠΡΩΤΟΣ) Η (Ι-1>Μ)  ! Η επανάληψη σταματάει είτε αν βρεθεί διαιρέτης
                                            ! είτε αν οι υποψήφιοι διαιρέτες έχουν φθάσει στο μισό του Α
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΕΙΝΑΙ_ΠΡΩΤΟΣ ΤΟΤΕ
    ΓΡΑΨΕ 'Ο ΑΡΙΘΜΟΣ ',Α,' ΕΙΝΑΙ ΠΡΩΤΟΣ'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Ο ΑΡΙΘΜΟΣ ',Α,' ΔΕΝ ΕΙΝΑΙ ΠΡΩΤΟΣ'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters