Τώρα είναι Τετ 30 Σεπ 2020 12:21 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Μπλόκο τροχαίας
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 02 Ιουν 2003 12:54 am 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! =================================================
! Σε ένα μπλόκο της τροχαίας ακολουθείται το εξής
! σύστημα: Κάθε οδηγός υπόκειται σε αλκοτέστ, ο
! μετρητής του οποίου έχει ενδείξεις από 0 μέχρι 5
! (0 = νηφάλιος). Αν η μέτρηση κάποιου οδηγού είναι
! μεγαλύτερη από 0, τότε το διπλάσιό της
! προστίθεται στο σύστημα πόντων (point system) του
! οδηγού. Αν αυτός συγκεντρώσει:
!   1 έως 3 μονάδες, δεν υπάρχει πρόβλημα.
!   4 έως 6 μονάδες, του γίνεται σύσταση,
!   7 έως 9 μονάδες, πληρώνει πρόστιμο,
!   περισσότερες από 9 μονάδες, του αφαιρείται το
!     δίπλωμα. Αν του έχει αφαιρεθεί και άλλη
!     φορά, κινείται δικαστική διαδικασία.
! Να γίνει πρόγραμμα το οποίο:
!   α) Να ζητάει τους πόντους που είχε συγκεντρώσει
!      ο οδηγός.
!   β) Να ζητάει τη μέτρηση του αλκοτέστ και να
!      αυξάνει όπως προβλέπεται τους πόντους του
!      οδηγού.
!   γ) Ανάλογα με τους πόντους που έφτασε τώρα ο
!      οδηγός, να εμφανίζει ένα από τα μηνύματα
!      "ΚΑΝΕΝΑ ΠΡΟΒΛΗΜΑ", "ΣΥΣΤΑΣΗ", "ΠΡΟΣΤΙΜΟ",
!      "ΑΦΑΙΡΕΣΗ ΔΙΠΛΩΜΑΤΟΣ".
!   δ) Σε περίπτωση που πρέπει να του αφαιρεθεί το
!      δίπλωμα, το πρόγραμμα πρέπει να ρωτάει αν
!      του έχει αφαιρεθεί και άλλη φορά. Αν η
!      απάντηση είναι "ΝΑΙ" τότε να εμφανίζεται το
!      μήνυμα "ΔΙΚΑΣΤΙΚΑ ΜΕΤΡΑ". Σε περίπτωση που η
!      απάντηση δεν είναι ούτε "ΝΑΙ" ούτε "ΟΧΙ", θα
!      πρέπει να επαναλαμβάνεται η ερώτηση.
! =================================================


ΠΡΟΓΡΑΜΜΑ Μπλόκο_τροχαίας

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: πόντοι, μέτρηση
  ΧΑΡΑΚΤΗΡΕΣ: απάντηση

ΑΡΧΗ

  ΓΡΑΨΕ 'Δώσε τους πόντους που έχει ο οδηγός:'
  ΔΙΑΒΑΣΕ πόντοι
  ΓΡΑΨΕ 'Δώσε τη μέτρηση του αλκοτέστ:'
  ΔΙΑΒΑΣΕ μέτρηση

  πόντοι <-- πόντοι + 2*μέτρηση

  ΑΝ πόντοι<=3 ΤΟΤΕ
    ΓΡΑΨΕ 'ΚΑΝΕΝΑ ΠΡΟΒΛΗΜΑ'
  ΑΛΛΙΩΣ_ΑΝ πόντοι<=6 ΤΟΤΕ
    ΓΡΑΨΕ 'ΣΥΣΤΑΣΗ'
  ΑΛΛΙΩΣ_ΑΝ πόντοι<=9 ΤΟΤΕ
    ΓΡΑΨΕ 'ΠΡΟΣΤΙΜΟ'
  ΑΛΛΙΩΣ

    ΓΡΑΨΕ 'ΑΦΑΙΡΕΣΗ ΔΙΠΛΩΜΑΤΟΣ'

    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'Του έχει αφαιρεθεί άλλη φορά;'
      ΔΙΑΒΑΣΕ απάντηση
    ΜΕΧΡΙΣ_ΟΤΟΥ (απάντηση='ΝΑΙ') Ή (απάντηση='ΟΧΙ')

    ΑΝ απάντηση='ΝΑΙ' ΤΟΤΕ
      ΓΡΑΨΕ 'ΔΙΚΑΣΤΙΚΑ ΜΕΤΡΑ'
    ΤΕΛΟΣ_ΑΝ

  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Μπλόκο_τροχαίας

 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters