Τώρα είναι Τρί 29 Σεπ 2020 10:04 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Αλγοριθμος μαθητης
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 22 Νοέμ 2008 04:42 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 23 Οκτ 2008 06:58 pm
Δημοσιεύσεις: 1
Θεωρουμε οτι αν καποιος μαθητης εχει βαθμο μικροτερο απο 9.5 σε περισσοτερα απο 4 μαθηματα απο τα 14 στα οποια εξεταζεται πρεπει να επαναλαβει την ταξη.Να γραφει αλγοριθμος ο οποιος να διαβαζει τους βαθμους του μαθητη οσο ο αριθμος των μαθηματων που απετυχε δεν ειναι πανω απο 4 και να εμφανιζει τελικα μηνυματα σχετικα με την προαγωγη ή οχι του μαθητη


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Αλγοριθμος μαθητης
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 23 Νοέμ 2008 12:01 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
Στο παρακάτω έχω υποθέσει ότι η βαθμολογία είναι στα 20.
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Αλγοριθμος_μαθητης
ΣΤΑΘΕΡΕΣ
  Ν=14
  Α=4
  Β=20
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΒΑΘΜΟΣ
  ΑΚΕΡΑΙΕΣ: ΜΕΤΡΗΤΗΣ, ΜΕΤΡΗΤΗΣ2
ΑΡΧΗ
  ΜΕΤΡΗΤΗΣ <-- 1
  ΜΕΤΡΗΤΗΣ2 <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΔΩΣΤΕ ΤΟΝ ΒΑΘΜΟ ΠΟΥ ΠΗΡΕ ΣΤΟ', ΜΕΤΡΗΤΗΣ, 'ΜΑΘΗΜΑ'
    ΔΙΑΒΑΣΕ ΒΑΘΜΟΣ
    ΑΝ ΒΑΘΜΟΣ < 0 Ή ΒΑΘΜΟΣ > Β ΤΟΤΕ
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΡΑΨΕ 'Ο ΒΑΘΜΟΣ ΠΡΕΠΕΙ ΝΑ ΕΙΝΑΙ ΜΕΤΑΞΥ ΤΟΥ 0 ΚΑΙ ΤΟΥ', Β
        ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΞΑΝΑΔΩΣΤΕ ΤΟΝ ΒΑΘΜΟ ΤΟΥ ΜΑΘΗΤΗ ΣΤΟ', ΜΕΤΡΗΤΗΣ, 'ΜΑΘΗΜΑ'
        ΔΙΑΒΑΣΕ ΒΑΘΜΟΣ
      ΜΕΧΡΙΣ_ΟΤΟΥ ΒΑΘΜΟΣ <= Β ΚΑΙ ΒΑΘΜΟΣ >= 0
    ΤΕΛΟΣ_ΑΝ
    ΑΝ ΒΑΘΜΟΣ < 9.5 ΤΟΤΕ
      ΜΕΤΡΗΤΗΣ2 <-- ΜΕΤΡΗΤΗΣ2 + 1
    ΤΕΛΟΣ_ΑΝ
    ΜΕΤΡΗΤΗΣ <-- ΜΕΤΡΗΤΗΣ + 1
  ΜΕΧΡΙΣ_ΟΤΟΥ ΜΕΤΡΗΤΗΣ2 > Α Ή ΜΕΤΡΗΤΗΣ = Ν+1
  ΑΝ ΜΕΤΡΗΤΗΣ2 > Α ΤΟΤΕ
    ΓΡΑΨΕ 'Ο ΜΑΘΗΤΗΣ ΠΡΕΠΕΙ ΝΑ ΕΠΑΝΑΛΑΒΕΙ ΤΗΝ ΤΑΞΗ'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Ο ΜΑΘΗΤΗΣ ΔΕΝ ΘΑ ΕΠΑΝΑΛΑΒΕΙ ΤΗΝ ΤΑΞΗ'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters