Τώρα είναι Τρί 29 Σεπ 2020 10:48 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Παίξε Πετρα_Ψαλίδι_Χαρτί!!!!
ΔημοσίευσηΔημοσιεύτηκε: Παρ 21 Δεκ 2007 07:11 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 20 Δεκ 2007 05:29 pm
Δημοσιεύσεις: 13
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ  Πετρα_Ψαλίδι_Χαρτί
! Τμήμα δηλώσεων
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: t
  ΧΑΡΑΚΤΗΡΕΣ: flag2
  ΑΚΕΡΑΙΕΣ: f,Π,Υ
ΑΡΧΗ
  Π <-- 0 ! Το σκορ του παίχτη
  Υ <-- 0 ! Το σκορ του Υπολογιστή
  ΓΡΑΨΕ '                                             '
  ΓΡΑΨΕ '  Ν Ι Κ Ο Σ  Γ Ε Ω Ρ Γ Ι Τ Σ Ο Π Ο Υ Λ Ο Σ   '
  ΓΡΑΨΕ '          2 0 0 7- 2 0 0 8                   '
  ΓΡΑΨΕ '  Α΄ Γ Ε Ν.  Λ Υ Κ Ε Ι Ο   Σ Ι Ν Δ Ο Υ       '
  γράψε ''
  ΓΡΑΨΕ ' Α Ν Α Π Τ Υ Ξ Η   Ε Φ Α Ρ Μ Ο Γ Ω Ν   Σ Ε   '
  ΓΡΑΨΕ '     Π Ρ Ο Γ Ρ Α Μ Α Τ Ι Σ Τ Ι Κ Ο            '
  γραψε '         Π Ε Ρ Ι Β Α Λ Λ Ο Ν                '
  ΓΡΑΨΕ ''
  ΓΡΑΨΕ 'Τώρα θα παίξουμε Πέτρα-Ψαλίδι-Χαρτί!'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ ''
    ΓΡΑΨΕ 'Πες μου τι έβγαλες;'
    ΓΡΑΨΕ '1. Πέτρα'
    ΓΡΑΨΕ '2. Ψαλίδι'
    ΓΡΑΨΕ '3. Χαρτί'

    ΓΡΑΨΕ_ 'Γράψε τον αριθμό μπροστά από την επιλογή σου:'
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΔΙΑΒΑΣΕ f
      ΑΝ f<>1 και f<>2 και f<>3 ΤΟΤΕ
        ΓΡΑΨΕ 'Λάθοςτιμή.'
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ f=1 η f=2 η f=3

    ΓΡΑΨΕ 'Δώσε έναν αριθμό από το 1 μέχρι το 3.'
    ΓΡΑΨΕ_ 'Η επιλογή σου είναι:'
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΔΙΑΒΑΣΕ t
      ΑΝ t<>1 και t<>2 και t<>3 και f<>4 τότε
        ΓΡΑΨΕ 'Λάθος τιμή. Πρέπει από 1 εως 3!'
      ΤΕΛΟΣ_ΑΝ

    ΜΕΧΡΙΣ_ΟΤΟΥ t=1 Η t=2 η t=3

    ΑΝ f=1 ΚΑΙ t=1 ΤΟΤΕ
      ΓΡΑΨΕ 'Έχασα. Εγώ έχω ψαλίδι.'
      Π <-- Π+1
    ΑΛΛΙΩΣ_ΑΝ f=2 ΚΑΙ t=1 ΤΟΤΕ
      ΓΡΑΨΕ 'Εγώ έχω ψαλίδι. Άρα ήμαστε ισοπαλία.'
    ΑΛΛΙΩΣ_ΑΝ f=3 ΚΑΙ t=1 ΤΟΤΕ
      ΓΡΑΨΕ 'Ευτυχώς. Έβγαλα ψαλίδι. Νίκησα.'
      Υ <-- Υ+1
    ΑΛΛΙΩΣ_ΑΝ f=1 ΚΑΙ t=2 ΤΟΤΕ
      ΓΡΑΨΕ 'Έχασες. Έβγαλα χαρτί.'
      Υ <-- Υ+1
    ΑΛΛΙΩΣ_ΑΝ f=2 ΚΑΙ t=2 ΤΟΤΕ
      ΓΡΑΨΕ 'Νίκησες. Έχω χαρτί.'
      Π <-- Π+1
    ΑΛΛΙΩΣ_ΑΝ f=3 ΚΑΙ t=2 ΤΟΤΕ
      ΓΡΑΨΕ 'Έχω χαρτί. Ισοπαλία.'
    ΑΛΛΙΩΣ_ΑΝ f=1 ΚΑΙ t=3 ΤΟΤΕ
      ΓΡΑΨΕ 'Ισοπαλία. Κι εγώ πέτρα έχω!'
    ΑΛΛΙΩΣ_ΑΝ f=2 ΚΑΙ t=3 ΤΟΤΕ
      ΓΡΑΨΕ 'Νίκησα. Εγώ εχώ πέτρα.'
      Υ <-- Υ+1
    ΑΛΛΙΩΣ_ΑΝ f=3 ΚΑΙ t=3 ΤΟΤΕ
      ΓΡΑΨΕ 'Νίκη για εσένα. Πέτρα έχω.'
      Π <-- Π+1
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ 'Το ΣΚΟΡ είναι ΠΑΙΧΤΗΣ-Η/Υ:',Π,'-'
    ΑΝ Π>Υ ΤΟΤΕ
      ΓΡΑΨΕ 'ΜΠΡΑΒΟ Νικάς!!!'
    ΑΛΛΙΩΣ_ΑΝ Π=Υ ΤΟΤΕ
      ΓΡΑΨΕ 'Είμαστε ΙΣΟΠΑΛΙΑ!!!'
    ΑΛΛΙΩΣ_ΑΝ Π<Υ ΤΟΤΕ
      ΓΡΑΨΕ 'ΧΑΝΕΙΣ! προσπάθησε περρισότερο!!'

    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ ''
    ΓΡΑΨΕ 'Θέλεις κι άλλη παρτίδα;'
    ΓΡΑΨΕ '1. ΝΑΙ'
    ΓΡΑΨΕ '2. ΟΧΙ'
    ΓΡΑΨΕ_ 'Γράψε τον αριθμό της επιλογής σου:'
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

      ΔΙΑΒΑΣΕ flag2
      ΑΝ (flag2<>'1') Και (flag2<>'2')  ΤΟΤΕ
        ΓΡΑΨΕ 'Λάθος τιμή πρέπει 1 ή 2'
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ (flag2='1') Ή (flag2='2')
  ΜΕΧΡΙΣ_ΟΤΟΥ (flag2='2')

  ΑΝ (flag2='2') Ή (flag2='2') ΤΟΤΕ
    ΓΡΑΨΕ ''
    ΓΡΑΨΕ '       Ελπίζω να διασκέδασες!!!        '
    ΓΡΑΨΕ '         ΤΕΛΟΣ ΠΡΟΓΡΑΜΜΑΤΟΣ            '
  ΤΕΛΟΣ_ΑΝ

  ΓΡΑΨΕ '|','*******************************','|'
  ΓΡΑΨΕ '|','                               ','|'
  ΓΡΑΨΕ '|','                               ','|'
  ΓΡΑΨΕ '|','-------------------------------','|'
  ΓΡΑΨΕ '|','  Made By "ProskoposEthnoy$"   ','|'
  ΓΡΑΨΕ '|','Email:proskoposethnoys@yahoo.gr','|'
  ΓΡΑΨΕ '|','-------------------------------','|'


ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Τετ 26 Νοέμ 2008 11:41 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 22 Νοέμ 2008 12:31 pm
Δημοσιεύσεις: 1
to tsekara ala gia des mipos an ginetai (pali me Mexris_otou) na krataei to score. Gt pada 1-0(/0-1) leei :roll: . Padws exei plaka :D


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters