Τώρα είναι Τετ 30 Σεπ 2020 12:10 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 4 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Υπολογισμός ηλικίας
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 20 Δεκ 2007 05:35 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 20 Δεκ 2007 05:29 pm
Δημοσιεύσεις: 13
Syntax: [ Download ] [ Hide ]
! ------------------------------------------------------------
! Στο πρόγραμμα εισάγεις τα τρέχοντα χρονολογικά
! στοιχεία και σου υπολογίζει σύμφωνα με την ημερομηνία
! γέννησης σου την ηλικία σου ακριβώς. Το πρόγραμμα
! υστερεί όταν για παράδειγμα σου βγάζει αρνητικούς μήνες
! ή ημέρες γι' αυτό ζητώ την βοήθεια σας για να γίνει καλύτερο.
! Σας ευχαριστώ proskoposethnoys@yahoo.gr
! ------------------------------------------------------------


ΠΡΟΓΡΑΜΜΑ Ypologismos_Hlikias
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:ETOS1,MINA1,IMERA1,ETOS2,MINA2,IMERA2,ETOS3,MINA3,IMERA3
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε το τρέχον ετός:'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ ETOS1
  ΜΕΧΡΙΣ_ΟΤΟΥ (ETOS1>0)
  ΓΡΑΨΕ 'Δώσε το τρέχοντα μήνα(π.χ. 1-12):'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ MINA1
  ΜΕΧΡΙΣ_ΟΤΟΥ (MINA1>=1) και (MINA1<=12)
  ΓΡΑΨΕ 'Δώσε τηντρέχουσα ημέρα (π.χ. 1-31):'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ IMERA1
  ΜΕΧΡΙΣ_ΟΤΟΥ IMERA1>=1 και IMERA1<=31
  ΓΡΑΨΕ 'Δώσε την χρονολογία γέννησης σου:'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ ETOS2
  ΜΕΧΡΙΣ_ΟΤΟΥ (ETOS2>0)
  ΓΡΑΨΕ'Δώσε το μήνα γεννήσεως σου (π.χ. 1-12):'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ MINA2
  ΜΕΧΡΙΣ_ΟΤΟΥ MINA2>=1 και MINA2<=12
  ΓΡΑΨΕ 'Δώσε την ημέρα γεννήσεως σου (π.χ. 1-31):'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ IMERA2
  ΜΕΧΡΙΣ_ΟΤΟΥ IMERA2>=1 και IMERA2<=31
  ETOS3 <-- ETOS1-ETOS2
  MINA3 <-- MINA1-MINA2
  ΑΝ MINA3<0 ΤΟΤΕ
    MINA3 <-- MINA3*(-1)
  ΤΕΛΟΣ_ΑΝ
  IMERA3 <-- IMERA1-IMERA2
  ΑΝ IMERA3<0 ΤΟΤΕ
    IMERA3 <-- IMERA3*(-1)
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'Είσαι',ETOS3,'χρονών',MINA3,'μηνών και',IMERA3,'ημερών.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Υπολογισμός ηλικίας
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 17 Ιαν 2008 01:56 am 
Χωρίς σύνδεση

Εγγραφή: Δευτ 22 Οκτ 2007 12:46 pm
Δημοσιεύσεις: 15

Syntax: [ Download ] [ Hide ]
! ------------------------------------------------------------
! Στο πρόγραμμα εισάγεις τα τρέχοντα χρονολογικά
! στοιχεία και σου υπολογίζει σύμφωνα με την ημερομηνία
! γέννησης σου την ηλικία σου ακριβώς. Το πρόγραμμα
! υστερεί όταν για παράδειγμα σου βγάζει αρνητικούς μήνες
! ή ημέρες γι' αυτό ζητώ την βοήθεια σας για να γίνει καλύτερο.
! Σας ευχαριστώ proskoposethnoys@yahoo.gr
! Μικρές αλλαγές στο πρόγραμμα σου για να δουλεύει σωστά.
! ****periptero at gmail dot com****
! ------------------------------------------------------------


ΠΡΟΓΡΑΜΜΑ Ypologismos_Hlikias
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:ETOS1,MINA1,IMERA1,ETOS2,MINA2,IMERA2,ETOS3,MINA3,IMERA3
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε το τρέχον ετός:'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ ETOS1
  ΜΕΧΡΙΣ_ΟΤΟΥ (ETOS1>0)
  ΓΡΑΨΕ 'Δώσε το τρέχοντα μήνα(π.χ. 1-12):'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ MINA1                              
  ΜΕΧΡΙΣ_ΟΤΟΥ (MINA1>=1) και (MINA1<=12)
  ΓΡΑΨΕ 'Δώσε τηντρέχουσα ημέρα (π.χ. 1-31):'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ IMERA1
  ΜΕΧΡΙΣ_ΟΤΟΥ IMERA1>=1 και IMERA1<=31
  ΓΡΑΨΕ 'Δώσε την χρονολογία γέννησης σου:'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ ETOS2
  ΜΕΧΡΙΣ_ΟΤΟΥ (ETOS2>0)
  ΓΡΑΨΕ'Δώσε το μήνα γεννήσεως σου (π.χ. 1-12):'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ MINA2
  ΜΕΧΡΙΣ_ΟΤΟΥ MINA2>=1 και MINA2<=12
  ΓΡΑΨΕ 'Δώσε την ημέρα γεννήσεως σου (π.χ. 1-31):'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ IMERA2
  ΜΕΧΡΙΣ_ΟΤΟΥ IMERA2>=1 και IMERA2<=31
  IMERA3 <-- IMERA1-IMERA2
  ΑΝ IMERA3<0 ΤΟΤΕ
    IMERA3 <-- IMERA3+30
    MINA2 <-- MINA2 + 1
  ΤΕΛΟΣ_ΑΝ
  MINA3 <-- MINA1-MINA2
  ΑΝ MINA3<0 ΤΟΤΕ
    MINA3 <-- MINA3 + 12
    ETOS2 <-- ETOS2 +1
  ΤΕΛΟΣ_ΑΝ
  ETOS3 <-- ETOS1-ETOS2
  ΓΡΑΨΕ 'Είσαι',ETOS3,'χρονών',MINA3,'μηνών και',IMERA3,'ημερών.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


 

Μικρές αλλαγές χρειαζόταν το πρόγραμμά σου τελικά...


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Υπολογισμός ηλικίας
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 17 Ιαν 2008 05:37 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 20 Δεκ 2007 05:29 pm
Δημοσιεύσεις: 13
Thanks periptero!!!
proskoposethnoys


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Υπολογισμός ηλικίας
ΔημοσίευσηΔημοσιεύτηκε: Παρ 03 Απρ 2009 05:01 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 03 Απρ 2009 04:01 pm
Δημοσιεύσεις: 3
WRAIO .POLY EKSYPNO :idea: :idea:


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 4 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters