Τώρα είναι Τρί 29 Σεπ 2020 11:05 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Farenheit_Celcius
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 20 Δεκ 2007 05:34 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 20 Δεκ 2007 05:29 pm
Δημοσιεύσεις: 13
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Farenheit_Celcius
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: F,C
  ΑΚΕΡΑΙΕΣ: επιλογη
  ΧΑΡΑΚΤΗΡΕΣ: flag2

ΑΡΧΗ
  ΓΡΑΨΕ '                                             '
  ΓΡΑΨΕ '  Ν Ι Κ Ο Σ  Γ Ε Ω Ρ Γ Ι Τ Σ Ο Π Ο Υ Λ Ο Σ   '
  ΓΡΑΨΕ '          2 0 0 7- 2 0 0 8                   '
  ΓΡΑΨΕ '  Α΄ Γ Ε Ν.  Λ Υ Κ Ε Ι Ο   Σ Ι Ν Δ Ο Υ       '
  ΓΡΑΨΕ '                                             '
  ΓΡΑΨΕ '                                             '
  ΓΡΑΨΕ 'Το πρόγραμμα μετετρέπει την θερμοκρασία από Celcius σε Farnheit και αντίστροφα.'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ ''
    ΓΡΑΨΕ 'Τι θέλεις να υπολογίσω;'
    ΓΡΑΨΕ '1. Farenheit --> Celcius'
    ΓΡΑΨΕ '2. Celcius --> Farenheit'
    ΓΡΑΨΕ 'ΕΠΕΛΕΞΕ ΤΟΝ ΑΡΙΘΜΟ ΜΠΡΟΣΤΑ ΑΠΟ ΤΗΝ ΕΠΙΛΟΓΗ ΣΟΥ.'
    ΓΡΑΨΕ_ 'Η ΕΠΙΛΟΓΗ ΣΟΥ ΕΙΝΑΙ:'
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΔΙΑΒΑΣΕ επιλογη
      ΑΝ  επιλογη>2 Η επιλογη<1 ΤΟΤΕ
        ΓΡΑΨΕ 'Λαθος επιλογη! Επέλεξε ανάμεσα σε 1 και 2.'
        ΓΡΑΨΕ_ 'Η ΕΠΙΛΟΓΗ ΣΟΥ ΕΙΝΑΙ:'
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ επιλογη=2 Η επιλογη=1

    ΕΠΙΛΕΞΕ επιλογη
      ΠΕΡΙΠΤΩΣΗ 1
        ΓΡΑΨΕ_ 'Δώσε τους Βαθμούς της Θερμοκρασίας σε FARENHEIT:'
        ΔΙΑΒΑΣΕ F
        C <-- (F-32)*5/9
        ΓΡΑΨΕ 'Οι',F,'βάθ. Farenheit ανντιστοιχούν σε',C,'βάθ. Κελσίου.'
      ΠΕΡΙΠΤΩΣΗ 2
        ΓΡΑΨΕ_ 'Δώσε τους Βαθμούς της Θερμοκρασίας σε CELCIUS:'
        ΔΙΑΒΑΣΕ C
        F <-- ((9*C)/5)+32
        ΓΡΑΨΕ 'Οι',C,'βάθ. Κελσίου ανντιστοιχούν σε',F,'βάθ. Farenheit.'
    ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ
    ΓΡΑΨΕ ''
    ΓΡΑΨΕ 'ΘΕΛΕΙΣ ΝΑ ΞΑΝΑΥΠΟΛΟΓΙΣΩ;'
    ΓΡΑΨΕ 'ΕΠΕΛΕΞΕ (Α) ΝΑΙ Ή (Β) ΟΧΙ'
    ΓΡΑΨΕ 'Παρακαλώ τα γράμματα να είναι ΚΕΦΑΛΑΙΑ!'
    ΓΡΑΨΕ_ 'Η ΕΠΙΛΟΓΗ ΣΟΥ ΕΙΝΑΙ:'
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΔΙΑΒΑΣΕ flag2
      ΑΝ (flag2<>'Α') Και (flag2<>'Β') και (flag2<>'B') και (flag2<>'A') ΤΟΤΕ
        ΓΡΑΨΕ 'Λάθος τιμή πρέπει Α ή Β ή τα γράμματα να είναι ΚΕΦΑΛΑΙΑ (Έλενξε το Caps Lock)!'
        ΓΡΑΨΕ_ 'Η ΕΠΙΛΟΓΗ ΣΟΥ ΕΙΝΑΙ:'
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ (flag2='Α') Ή (flag2='Β') Ή (flag2='B') Ή (flag2='A')
  ΜΕΧΡΙΣ_ΟΤΟΥ (flag2='Β') Ή (flag2='B')
  ΑΝ (flag2='Β') Ή (flag2='B') ΤΟΤΕ
    ΓΡΑΨΕ '         ΤΕΛΟΣ ΠΡΟΓΡΑΜΜΑΤΟΣ            '
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ ''
  ΓΡΑΨΕ '|','*******************************','|'
  ΓΡΑΨΕ '|','                               ','|'
  ΓΡΑΨΕ '|','                               ','|'
  ΓΡΑΨΕ '|','-------------------------------','|'
  ΓΡΑΨΕ '|','  Made By "ProskoposEthnoy$"   ','|'
  ΓΡΑΨΕ '|','Email:proskoposethnoys@yahoo.gr','|'
  ΓΡΑΨΕ '|','-------------------------------','|'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters