Τώρα είναι Τρί 29 Σεπ 2020 11:48 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΠΛΗΘΟΣ ΨΗΦΙΩΝ ΑΚΕΡΑΙΩΝ
ΔημοσίευσηΔημοσιεύτηκε: Τετ 07 Νοέμ 2007 01:23 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 07 Νοέμ 2007 01:21 pm
Δημοσιεύσεις: 1
Syntax: [ Download ] [ Hide ]
! ΤΟ ΠΡΟΓΡΑΜΜΑ ΥΠΟΛΟΓΙΖΕΙ ΤΟ ΠΛΗΘΟΣ ΤΩΝ ΨΗΦΙΩΝ ΕΝΟΣ ΑΚΕΡΑΙΟΥ ΑΡΙΘΜΟΥ
! Π_ΚΑΡ ΜΑΘΗΜΑΤΙΚΟΣ

ΠΡΟΓΡΑΜΜΑ ΠΛΗΘΟΣ_ΨΗΦΙΩΝ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι,Χ,Χ1
ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΕ ΜΟΥ ΕΝΑΝ ΑΚΕΡΑΙΟ ΑΡΙΘΜΟ: '
  ΔΙΑΒΑΣΕ Χ
  Ι <-- 1
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    Χ1 <-- Χ DIV (10^Ι)
    ΑΝ Χ1<>0 ΤΟΤΕ
      Ι <-- Ι+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ ' Ο ΑΡΙΘΜΟΣ ΕΧΕΙ ',Ι,' ΨΗΦΙΑ'
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ Χ1=0
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 

_________________
ΠΚΑΡ


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 29 Νοέμ 2007 03:43 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 29 Νοέμ 2007 03:16 pm
Δημοσιεύσεις: 2
Κάτι τέτοιο δεν θα ήταν πιο απλό????
Το Ι μετρά ψηφία (αρχικά 0)
Με το Χ <-- Χ DIV 10 "Κόβω" το τελευταίο ψηφίο και κρατώ τα υπόλοιπα
Με την αύξηση του Ι καταμετρώ αυτό που μόλις "έκοψα"
Αυτό θα συμβαίνει μέχρι το Χ να γίνει 0

Syntax: [ Download ] [ Hide ]
! ΤΟ ΠΡΟΓΡΑΜΜΑ ΥΠΟΛΟΓΙΖΕΙ ΤΟ ΠΛΗΘΟΣ ΤΩΝ ΨΗΦΙΩΝ ΕΝΟΣ
!ΑΚΕΡΑΙΟΥ ΑΡΙΘΜΟΥ

ΠΡΟΓΡΑΜΜΑ ΠΛΗΘΟΣ_ΨΗΦΙΩΝ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι,Χ
ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΕ ΜΟΥ ΕΝΑΝ ΑΚΕΡΑΙΟ ΑΡΙΘΜΟ: '
  ΔΙΑΒΑΣΕ Χ
  Ι <-- 0                        
 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    Χ <-- Χ DIV 10            
    Ι <-- Ι+1                    
  ΜΕΧΡΙΣ_ΟΤΟΥ Χ=0
  ΓΡΑΨΕ ' Ο ΑΡΙΘΜΟΣ ΕΧΕΙ ',Ι,' ΨΗΦΙΑ'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters