Τώρα είναι Πέμ 20 Φεβ 2020 05:37 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 05 Μαρ 2006 01:26 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 04 Μαρ 2006 03:33 pm
Δημοσιεύσεις: 9
Syntax: [ Download ] [ Hide ]
! Ο ΧΡΗΣΤΗΣ ΔΙΑΛΕΓΕΙ ΔΥΟ ΜΠΙΛΙΕΣ ΠΡΑΣΙΝΟΥ ΚΟΚΚΙΝΟΥ Η ΚΙΤΡΙΝΟΥ
! ΧΡΩΜΑΤΟΣ .ΤΟ ΠΡΟΓΡΑΜΜΑ ΕΛΕΓΧΕΙ ΤΑ ΧΡΩΜΑΤΑ ΑΝ ΕΙΝΑΙ
! ΔΙΑΦΟΡΕΤΙΚΑ ΜΕΤΑΞΥ ΤΟΥΣ ΤΟΤΕ ΑΥΤΕΣ ΟΙ ΜΠΙΛΙΕΣ ΦΕΥΓΟΥΝ ΑΠΟ ΤΟ
! ΠΑΙΧΝΙΔΙ . ΤΟ ΠΑΙΧΝΙΔΙ ΣΥΝΕΧΙΖΕΤΑΙ ΜΕΧΡΙ ΝΑ ΜΗΔΕΝΙΣΤΟΥΝ ΔΥΟ
! ΑΠΟ ΤΙΣ ΟΜΑΔΕΣ ... ΤΑ ΧΡΩΜΑΤΑ ΑΝΑΓΝΩΡΙΖΟΝΤΑΙ ΑΠΟ ΤΟ ΠΡΟΓΡΑΜΜΑ ΩΣ:
! kok (ΚΟΚΚΙΝΕΣ)
! kit (ΚΙΤΡΙΝΕΣ)
! pr (ΠΡΑΣΙΝΕΣ)

ΠΡΟΓΡΑΜΜΑ mpales
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:k
  ΧΑΡΑΚΤΗΡΕΣ: m1,m2
  ΑΚΕΡΑΙΕΣ: kok,kit,pr ,b

αρχή
  αρχή_επανάληψης
    γράψε 'dose to noumero ton mpalon  (apodekta mono ta polaplasia tou 3)  '
    διάβασε b
  μέχρις_ότου b MOD 3=0
  k <-- b
  kok <-- b DIV  3
  kit <-- b DIV 3
  pr <-- b DIV  3
  αρχή_επανάληψης
    αρχή_επανάληψης
      γράψε 'dose 1o xroma'
      διάβασε m1
      γράψε 'dose 2o xroma'
      διάβασε m2
    μέχρις_ότου (( m1='kok') ή (m1='kit') ή (m1='pr')) και ((m2='kok' ) ή (m2='pr') ή (m2='kit'))
    αν (m1 <> m2)   τότε
      αν m1='kok'     τότε
        kok <-- kok - 1
      αλλιώς_αν m1='kit' τότε
        kit <-- kit-1
      αλλιώς_αν m1='pr' τότε
        pr <-- pr - 1
      τέλος_αν
      αν m2='kok' τότε
        kok <-- kok-1
      αλλιώς_αν m2='kit' τότε
        kit <-- kit - 1
      αλλιώς_αν m2='pr' τότε
        pr <-- pr - 1
      τέλος_αν
      k <-- k-2
      γράψε 'emeinan  ',k,'  bales'



    τέλος_αν
    γράψε 'emeinan   '
    γράψε 'prasines  ', pr ,'     '
    γράψε 'kokkines  ' ,kok  ,'    '
    γράψε 'kitrines  ' ,kit  ,'      '


  μέχρις_ότου ( k = 0 )  ή ( ( (kok = 0 ) και ( kit = 0 )) ή ((kok = 0) και (pr = 0 ) ) ή ((pr = 0) και (kit = 0 )))
  γράψε_ 'emeinan   '
  γράψε_ 'prasines  ', pr ,'     '
  γράψε_ 'kokkines  ' ,kok  ,'    '
  γράψε 'kitrines  ' ,kit  ,'      '
τέλος_προγράμματος


Τελευταία επεξεργασία από format_man και Κυρ 05 Μαρ 2006 01:33 pm, έχει επεξεργασθεί 1 φορά/ες συνολικά

Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters