Τώρα είναι Πέμ 20 Φεβ 2020 05:37 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: αριθμοί πλησιέστεροι στο 50
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 22 Ιαν 2006 12:07 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 15 Φεβ 2004 09:10 pm
Δημοσιεύσεις: 18
Τοποθεσία: Ενιαίο Λύκειο Χιλιομοδίου Κορινθίας
Syntax: [ Download ] [ Hide ]
! Να αναπτυχθεί πρόγραμμα που θα διαβάζει μια ομάδα διψήφιων αριθμών και
! θα εκτυπώνει ποιος αριθμός ήταν πιο κοντά στο 50 καθώς επίσης και το
! πλήθος των αριθμών που εισήχθησαν. Η επανάληψη πρέπει να τερματίζεται
! όταν εισαχθεί ο αριθμός 0. Σημείωση: στην περίπτωση που υπάρχουν δυο
! αριθμοί πλησιέστεροι στο 50 (ο ένας μεγαλύτερος και ο άλλος μικρότερος),
! πρέπει να εκτυπώνεται ο μικρότερος.


ΠΡΟΓΡΑΜΜΑ Αριθμοί
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: πλήθος, αριθμός, αριθμός_πιο_κοντά
ΑΡΧΗ
  αριθμός_πιο_κοντά <-- 100  ! μια αρχική τιμή που θα αλλάξει στη συνέχεια
  πλήθος <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΔΙΑΒΑΣΕ αριθμός
    ΜΕΧΡΙΣ_ΟΤΟΥ (αριθμός = 0) Η (αριθμός >= 10 ΚΑΙ αριθμός <= 99)
    ΑΝ (αριθμός >= 10 ΚΑΙ αριθμός <= 99) ΤΟΤΕ  ! αριθμός <> 0
      ΑΝ  Α_Τ (αριθμός - 50) < Α_Τ (αριθμός_πιο_κοντά - 50) ΤΟΤΕ
        αριθμός_πιο_κοντά <-- αριθμός
      ΑΛΛΙΩΣ_ΑΝ  Α_Τ (αριθμός - 50) = Α_Τ (αριθμός_πιο_κοντά - 50) ΤΟΤΕ
        ΑΝ  (αριθμός < 50) ΤΟΤΕ
          αριθμός_πιο_κοντά <-- αριθμός
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
      πλήθος <-- πλήθος + 1
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ (αριθμός = 0)
  ΑΝ  (πλήθος = 0) ΤΟΤΕ
    ΓΡΑΨΕ 'Δε δόθηκε κανείς αριθμός'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Το πλήθος των αριθμών είναι ', πλήθος
    ΓΡΑΨΕ 'Ο πλησιέστερος στο 50 αριθμός είναι ', αριθμός_πιο_κοντά
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Αριθμοί
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters