Τώρα είναι Κυρ 01 Νοέμ 2020 04:13 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 16 Δεκ 2004 12:44 am 
Χωρίς σύνδεση

Εγγραφή: Τετ 15 Δεκ 2004 04:26 am
Δημοσιεύσεις: 10
Τοποθεσία: Πρέβεζα
Syntax: [ Download ] [ Hide ]
!/////////////////////////////////////////\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
! Να Γράψετε Πρόγραμμα το οποίο διαβάζει εναν ακέραιο θετικό αριθμό
! (εάν δοθεί αρνητικός χρησιμοποιούμαι τον αντίθετό του) και:
! 1) Να εμφανίζει τα ψηφία του αριθμού στην οθόνη (από το τελευταίο προς το πρώτο),
! 2) Να υπολογίζει (και να εμφανίζει) πόσα ψηφία έχει ο αριθμός
! 3) Να υπολογίζει τον αριθμό που έχει τα ίδια ψηφία με τον δεδομένο αριθμό,
!    αλλά με ανάποδη σειρά (ας τον ονομάσουμε "ανάστροφο" αριθμό) και
! 4) Να ελέγχει εάν ο δεδομένος αριθμός είναι "καρκινικός" (= ο αριθμός
!    ο οποίος από όποια μεριά και να διαβασθεί -είτε από δεξιά είτε από αριστερά-
!    είναι ο ίδιος).
!\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\//////////////////////////////////////////
! netnick
!-----------------------------------------------------------------------------------


ΠΡΟΓΡΑΜΜΑ θεωρια_αριθμων_1
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ν,ΝΝ,ΑΝΑΣΤΡ,Υ,πλήθος
ΑΡΧΗ

! Διάβασμα αριθμού
  ΓΡΑΨΕ 'ΔΩΣΕ ΕΝΑΝ ΑΚΕΡΑΙΟ ΑΡΙΘΜΟ'
  ΔΙΑΒΑΣΕ Ν
  ΑΝ Ν<0 ΤΟΤΕ
    Ν <-- -Ν
  ΤΕΛΟΣ_ΑΝ

! Αρχικοποιήσεις
! Πλήθος ψηφίων = πλήθος
  πλήθος <-- 0
  ΑΝΑΣΤΡ <-- 0

! Μην χαλάσεις τον Ν. Δούλεψε με ένα αντίγραφο του Ν, τον ΝΝ (=Ν)
  ΝΝ <-- Ν

! ερωτήματα 1 & 2 & 3
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    Υ <-- ΝΝ MOD 10
    ! εμφάνισε τα ψηφία του αριθμού (ερώτημα 2)
    ΓΡΑΨΕ Υ
    ΝΝ <-- ΝΝ DIV 10
    ΑΝΑΣΤΡ <-- 10 * ΑΝΑΣΤΡ + Υ
    πλήθος <-- πλήθος +1
  ΜΕΧΡΙΣ_ΟΤΟΥ ΝΝ = 0

  ! ΚΕΝΗ ΓΡΑΜΜΗ
  ΓΡΑΨΕ
  ΓΡΑΨΕ 'Ο ΑΡΙΘΜΟΣ ΕΧΕΙ ',πλήθος,' ΨΗΦΙΑ.'
  ΓΡΑΨΕ 'Ο ΑΡΙΘΜΟΣ ΜΕ ΤΑ ΨΗΦΙΑ ΜΕ ΑΝΑΠΟΔΗ ΣΕΙΡΑ ΕΙΝΑΙ Ο ',ΑΝΑΣΤΡ
  ! ΚΕΝΗ ΓΡΑΜΜΗ
  ΓΡΑΨΕ

! ερώτημα 4                                          
  ΑΝ ΑΝΑΣΤΡ = Ν ΤΟΤΕ
    ΓΡΑΨΕ 'Ο ΑΡΙΘΜΟΣ ΕΙΝΑΙ ΚΑΡΚΙΝΙΚΟΣ.!!'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Ο ΑΡΙΘΜΟΣ ΔΕΝ ΕΙΝΑΙ ΚΑΡΚΙΝΙΚΟΣ.!!'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ θεωρια_αριθμων_1
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters