Τώρα είναι Παρ 10 Απρ 2020 11:07 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Απομόνωση ψηφίων
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 10 Μαρ 2003 10:35 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! ===================================================================
! Να γίνει πρόγραμμα που να ζητάει έναν τετραψήφιο ακέραιο αριθμό και
! να αποθηκεύει τα ψηφία του σε 4 διαφορετικές μεταβλητές. Αν ο
! αριθμός που θα δοθεί δεν είναι τετραψήφιος να ξαναζητείται.
! ===================================================================


ΠΡΟΓΡΑΜΜΑ Απομόνωση_ψηφίων

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ, Ψ1, Ψ2, Ψ3, Ψ4, υπόλοιπο

ΑΡΧΗ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Δώσε έναν τετραψήφιο αριθμό:'
    ΔΙΑΒΑΣΕ Χ
    ΑΝ (Χ<1000) Η (Χ>9999) ΤΟΤΕ
      ΓΡΑΨΕ 'Ο αριθμός αυτός δεν είναι τετραψήφιος'
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ (Χ>=1000) ΚΑΙ (Χ<=9999)

  Ψ1 <-- Χ DIV 1000
  υπόλοιπο <-- Χ MOD 1000
  Ψ2 <-- υπόλοιπο DIV 100
  υπόλοιπο <-- υπόλοιπο MOD 100
  Ψ3 <-- υπόλοιπο DIV 10
  Ψ4 <-- υπόλοιπο MOD 10

  ΓΡΑΨΕ 'Τα ψηφία του αριθμού είναι: ', Ψ1, '-', Ψ2, '-', Ψ3, '-', Ψ4

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Απομόνωση_ψηφίων

 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters