Τώρα είναι Τρί 15 Οκτ 2019 10:36 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 25 Ιαν 2014 10:52 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 26 Δεκ 2013 12:46 pm
Δημοσιεύσεις: 8
    Αν το αποτελεσμα δεν ειναι ακεραιος το εμφανιζει ως κλασμα :D


Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ  Αντιπαραγωγηση
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:επ1,α1,α2,α3,ν1,ν2,ν3
  ΠΡΑΓΜΑΤΙΚΕΣ:ν4,αρ1
  ΧΑΡΑΚΤΗΡΕΣ:απ
ΑΡΧΗ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Το πρόγραμμα κανει αντιπαραγωγηση σε ορους της μορφης'
    ΓΡΑΨΕ 'α*x^ν'
    ΓΡΑΨΕ '1.Δωσε κατευθειαν το α,αν ειναι ακεραιος'
    ΓΡΑΨΕ '2.Αν το α ειναι σε μορφη κλασματος δωσε αριθμητη και παρανομαστη'
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'Πατησε 1 η 2'
      ΔΙΑΒΑΣΕ επ1
    ΜΕΧΡΙΣ_ΟΤΟΥ επ1=1 η επ1=2
    ΑΝ επ1=1 τότε
      ΓΡΑΨΕ 'Δωσε το α(ακεραιος)'
      ΔΙΑΒΑΣΕ α1
      ΓΡΑΨΕ '1.Δωσε το ν,κατευθειαν αν ειναι ακεραιος'
      ΓΡΑΨΕ '2.Δωσε αριθμητη και παρανομαστη αν το ν ειναι κλασμα'
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΡΑΨΕ 'πατησε 1 η 2'
        ΔΙΑΒΑΣΕ επ1
      ΜΕΧΡΙΣ_ΟΤΟΥ επ1=1 η επ1=2
      ΑΝ επ1=1 τότε
        ΓΡΑΨΕ 'δωσε το ν(ακεραιος)'
        ΔΙΑΒΑΣΕ ν1
        ν1 <-- ν1+1
        αρ1 <-- α1/ν1
        ΑΝ Α_Μ(αρ1)-αρ1=0 τότε
          ΓΡΑΨΕ 'αντιπαραγωγος:',αρ1,'*x^',ν1
        ΑΛΛΙΩΣ
          ΓΡΑΨΕ 'αντιπαραγωγος:(',α1,'/',ν1,')*x^',ν1
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'Δωσε αριθμητη'
        ΔΙΑΒΑΣΕ ν2
        ΓΡΑΨΕ 'Δωσε παρανομαστη'
        ΔΙΑΒΑΣΕ ν3
        ν4 <-- ν2+ν3
        αρ1 <-- α1*ν3/ν4
        ΑΝ Α_Μ(αρ1)-αρ1=0 τότε
          ΓΡΑΨΕ 'αντιπαραγωγος:',αρ1,'*x^',ν4,'/',ν3
        ΑΛΛΙΩΣ
          ΓΡΑΨΕ 'αντιπαραγωγος:(',α1*ν3,'/',ν4,')*x^',ν4,'/',ν3
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Δωσε αριθμητη(ακεραιος) '
      ΔΙΑΒΑΣΕ α2
      ΓΡΑΨΕ 'Δωσε παρανομαστη(ακεραιος)'
      ΔΙΑΒΑΣΕ  α3
      ΓΡΑΨΕ '1.Δωσε το ν,κατευθειαν αν ειναι ακεραιος'
      ΓΡΑΨΕ '2.Δωσε αριθμητη και παρανομαστη αν το ν ειναι κλασμα'
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΡΑΨΕ 'πατησε 1 η 2'
        ΔΙΑΒΑΣΕ επ1
      ΜΕΧΡΙΣ_ΟΤΟΥ επ1=1 η επ1=2
      ΑΝ επ1=1 τότε
        ΓΡΑΨΕ 'δωσε το ν(ακεραιος)'
        ΔΙΑΒΑΣΕ ν1
        ν1 <-- ν1+1
        αρ1 <-- α2/α3*ν1
        ΑΝ Α_Μ(αρ1)-αρ1=0 τότε
          ΓΡΑΨΕ 'αντιπαραγωγος:',αρ1,'*x^',ν1
        ΑΛΛΙΩΣ
          ΓΡΑΨΕ 'αντιπαραγωγος:(',α2,'/',α3*ν1,')*x^',ν1
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'Δωσε αριθμητη'
        ΔΙΑΒΑΣΕ ν2
        ΓΡΑΨΕ 'Δωσε παρανομαστη'
        ΔΙΑΒΑΣΕ ν3
        ν4 <-- ν2+ν3
        αρ1 <-- (α2*ν3)/(α3*ν4)
        ΑΝ Α_Μ(αρ1)-αρ1=0 τότε
          ΓΡΑΨΕ 'αντιπαραγωγος:',αρ1,'*x^',ν4,'/',ν3
        ΑΛΛΙΩΣ
          ΓΡΑΨΕ 'αντιπαραγωγος:(',α2*ν3,'/',α3*ν4,')*x^',ν4,'/',ν3
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'ΞΑΝΑ?(ναι η οχι)'
      ΔΙΑΒΑΣΕ απ
    ΜΕΧΡΙΣ_ΟΤΟΥ απ='ναι' η απ='οχι'
  ΜΕΧΡΙΣ_ΟΤΟΥ απ='οχι'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ






 

_________________
paul


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Google [Bot] και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters