Τώρα είναι Τρί 18 Ιουν 2019 12:39 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΕΞΙΣΩΣΗ 3ου βαθμου
ΔημοσίευσηΔημοσιεύτηκε: Παρ 27 Δεκ 2013 03:50 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 26 Δεκ 2013 12:46 pm
Δημοσιεύσεις: 8
    Μονο τις ριζες βρισκει δεν κανει παραγοντοποιηση



Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ   εξισωση_3ου_βαθμου
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: α3,α2,α1,αρ,χ,χ1,χ2,ω,Δ,β1,β2,β
  ΑΚΕΡΑΙΕΣ:κ

ΑΡΧΗ
  ΓΡΑΨΕ 'Το πρόγραμμα αυτο λυνει εξισωσεις τριτου βαθμου'
  ΓΡΑΨΕ 'α(3)χ^3+α(2)*χ^2+α(1)*χ+α=0'



  ΓΡΑΨΕ '3ος ορος :α(3)*χ^3'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Δωσε α(3)'
    ΔΙΑΒΑΣΕ α3
  ΜΕΧΡΙΣ_ΟΤΟΥ α3<>0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ '2ος ορος:α(2)*χ^2'
    ΓΡΑΨΕ 'Δωσε το α(2)'
    ΔΙΑΒΑΣΕ α2
    ΓΡΑΨΕ '1ος ορος:α(1)*χ'
    ΔΙΑΒΑΣΕ α1
    ΓΡΑΨΕ '4ος ορος: α'
    ΔΙΑΒΑΣΕ αρ
  ΜΕΧΡΙΣ_ΟΤΟΥ α2<>0 η α1<>0 η αρ<>0
  ΑΝ αρ=0 και α1=0 τότε
    χ <-- -α2/α3
    ΓΡΑΨΕ 'χ=0 η χ='
  ΑΛΛΙΩΣ_ΑΝ αρ=0 και α2=0 τότε
    ΑΝ -α1/α3>0 τότε
      χ <-- Τ_Ρ(-α1/α3)
      ΓΡΑΨΕ 'χ=0 η χ='
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'χ=0'
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ α1=0 και α2=0 τότε
    ΑΝ -αρ/α3>0 τότε
      χ <-- (-αρ/α3)^(1/3)
      ΓΡΑΨΕ 'χ='
    ΑΛΛΙΩΣ
      χ <-- -(αρ/α3)^(1/3)
      ΓΡΑΨΕ 'χ='
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
    κ <-- -10
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      κ <-- κ+1
      ω <-- α3*κ^3+α2*κ^2+α1*κ+αρ
      ΑΝ κ>10 τότε                  !εδω νομιζω οτι μέχρι το 10 αν δε βρει ριζα δε θα βρει ουτε μετα
        ω <-- 0                     !αλλα δεν ειμαι σιγουρος
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ ω=0
    ΑΝ κ>10 τότε
      ΓΡΑΨΕ 'δεν υπαρχουν πιθανες ακέραιες ριζες'
    ΑΛΛΙΩΣ
      β2 <-- α3                !HORNER
      β1 <-- α3*κ+α2
      β <-- β1*κ+α1
      Δ <-- β1^2-4*β2*β
      ΑΝ Δ>0 ΤΟΤΕ
        χ1 <-- (-β1+Τ_Ρ(Δ))/2*β2
        χ2 <-- (-β1-Τ_Ρ(Δ))/2*β2
        ΓΡΑΨΕ 'χ=',κ,'χ=',χ1,'χ=',χ2
      ΑΛΛΙΩΣ_ΑΝ Δ=0 ΤΟΤΕ
        χ <-- -β1/2*β2
        ΓΡΑΨΕ 'χ=',κ,'χ='
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'χ=',κ       !ΔΟΥΛΕΥΕΙ ΜΟΝΟ ΣΤΟ ΣΥΝΟΛΟ R
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ











 

_________________
paul


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters