Τώρα είναι Δευτ 23 Σεπ 2019 08:58 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Κυρτά Κανονικά Πολύγωνα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 11 Οκτ 2012 01:01 am 
Χωρίς σύνδεση

Εγγραφή: Τετ 10 Οκτ 2012 04:00 am
Δημοσιεύσεις: 7
Ο παρακάτω αλγόριθμος ζητά (με έλεγχο στην είσοδο) να δώσετε το πλήθος των πλευρών, (δηλαδή τί ν-γωνο έχουμε) και το μήκος τους. Στη συνέχεια υπολογίζει διάφορα στοιχεία του πολυγώνου όπως εμβαδό, περίμετρο, γωνίες, διαγώνιους, κτλ.

Το έκανα ΜΟΝΟ για κυρτά πολύγωνα γιατί για μη-κυρτά (π.χ. πεντάλφα) θα ήταν δύσκολο !!!

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΚΥΡΤΑ_ΚΑΝΟΝΙΚΑ_ΠΟΛΥΓΩΝΑ
ΣΤΑΘΕΡΕΣ
  ΠΙ=3.14159265
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ν
  ΠΡΑΓΜΑΤΙΚΕΣ: Α,Χ
ΑΡΧΗ
  ΓΡΑΨΕ 'Θέστε αριθμό πλευρών'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ Ν
    ΑΝ Ν<=2 ΤΟΤΕ
      ΓΡΑΨΕ 'Λάθος δεδομένα προσπαθήστε ξανά'
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ Ν>2
  ΓΡΑΨΕ 'Θέστε μήκος πλευράς'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ Α
    ΑΝ Ν<=0 ΤΟΤΕ
      ΓΡΑΨΕ 'Λάθος δεδομένα προσπαθήστε ξανά'
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ Α>0
  ΓΡΑΨΕ ''
  ΓΡΑΨΕ 'Γωνίες:'
  Χ <-- 360/Ν
  ΓΡΑΨΕ ' Κεντρική:',Χ,'μοίρες'
  Χ <-- 180-Χ
  ΓΡΑΨΕ ' Εσωτερική:',Χ,'μοίρες'
  ΓΡΑΨΕ 'Άθροισμα γωνιών:'
  Χ <-- 180*(Ν-2)
  ΓΡΑΨΕ ' Εσωτερικών:',Χ,'μοίρες'
  ΓΡΑΨΕ ' Εξωτερικών: 360 μοίρες'
  ΓΡΑΨΕ 'Διαγώνιες:'
  Χ <-- Ν-3
  ΓΡΑΨΕ ' Ανά κορυφή:'
  Χ <-- Ν*(Ν-3)/2
  ΓΡΑΨΕ ' Συνολικές:'
  Χ <-- Ν*Τ_Ρ(Α^2-(Α/2)^2)/2
  ΓΡΑΨΕ 'Εμβαδό:'
  ΓΡΑΨΕ 'Περίμετρος:'*Α
  ΓΡΑΨΕ 'Ακτίνα κύκλου:'
  Χ <-- Α/(2*ΗΜ(ΠΙ/Ν))
  ΓΡΑΨΕ ' Περιγεγραμμένου:'
  Χ <-- Α/(2*ΕΦ(ΠΙ/Ν))
  ΓΡΑΨΕ ' Εγγεγραμμένου:'
  Χ <-- Ν*(Ν-1)/2
  ΓΡΑΨΕ 'Συνολικές γραμμές:'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

_________________
"Peace to everyone, and - who knows ? - maybe one day ... civilization !!!" - Pat Condell


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters