Τώρα είναι Κυρ 07 Ιουν 2020 12:08 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 17 Ιαν 2009 02:07 am 
Χωρίς σύνδεση

Εγγραφή: Τετ 22 Οκτ 2008 12:08 pm
Δημοσιεύσεις: 31
Τοποθεσία: Αθήνα
ΟΡΙΣΤΕ ΚΑΙ ΕΝΑ ΑΠΛΟ ΠΡΟΓΡΑΜΜΑ ΠΟΥ ΔΕΧΕΤΑΙ ΤΟΥΣ ΣΥΝΤΕΛΕΣΤΕΣ ΜΙΑΣ ΔΕΥΤΕΡΟΒΑΘΜΙΑΣ ΕΞΙΣΩΣΗΣ ΚΑΙ ΕΜΦΑΝΙΖΕΙ ΤΗΝ ΣΥΝΑΡΤΗΣΗ , ΤΗΝ ΠΑΡΑΓΩΓΟ ΤΗΣ , ΤΗΝ ΜΟΝΟΤΟΝΙΑ ΤΗΣ ΚΑΙ ΤΑ ΑΚΡΟΤΑΤΑ ΤΗΣ.
Syntax: [ Download ] [ Hide ]
 
ΠΡΟΓΡΑΜΜΑ ΠΑΡΑΓΩΓΟΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: Α , Β , Γ , Υ , Ζ , Χ , ΕΛ , ΜΕΓ
ΑΡΧΗ
  ΓΡΑΨΕ 'ΠΡΟΓΡΑΜΜΑ ΤΟ ΟΠΟΙΟ ΥΠΟΛΟΓΙΖΕΙ ΤΗΝ ΠΑΡΑΓΩΓΟ'
  ΓΡΑΨΕ 'ΟΠΟΙΑΣΔΗΠΟΤΕ ΔΕΥΤΕΡΟΒΑΘΜΙΑΣ ΣΥΝΑΡΤΗΣΗΣ '
  ΓΡΑΨΕ 'ΔΩΣΕ ΤΟΥΣ ΣΥΝΤΕΛΕΣΤΕΣ ΜΙΑΣ ΔΕΥΤΕΡΟΒΑΘΜΙΑΣ ΣΥΝΑΡΤΗΣΗΣ'
  ΓΡΑΨΕ 'ΓΙΑ ΝΑ ΒΡΕΘΕΙ Η ΠΑΡΑΓΩΓΟΣ ΤΗΣ'
  ΓΡΑΨΕ 'ΔΩΣΕ ΤΟΝ ΣΥΝΤΕΛΕΣΤΗ ΤΟΥ Χ^2'
  ΔΙΑΒΑΣΕ Α
  ΓΡΑΨΕ 'ΔΩΣΕ ΤΟΝ ΣΥΝΤΕΛΕΣΤΗ ΤΟΥ Χ '
  ΔΙΑΒΑΣΕ Β
  ΓΡΑΨΕ 'ΔΩΣΕ ΤΟΝ ΣΤΑΘΕΡΟ ΟΡΟ '
  ΔΙΑΒΑΣΕ Γ
  ΓΡΑΨΕ 'ΑΡΑ Η ΕΞΙΣΩΣΗ ΕΙΝΑΙ Η f(x)=',Α,'Χ^2+',Β,'Χ+'
  ΑΝ Α>0 ΤΟΤΕ
    Υ <-- Β
    Ζ <-- 2*Α
    ΓΡΑΨΕ 'Η ΠΑΡΑΓΩΓΟΣ ΕΙΝΑΙ Η f΄(x)=',Ζ,'Χ+'
    Χ <-- -Υ/Ζ
    ΕΛ <-- Α*(Χ^2)+Β*Χ+Γ
    ΓΡΑΨΕ'Η f(x) ΕΙΝΑΙ ΓΝΗΣΙΩΣ ΦΘΗΝΟΥΣΑ ΣΤΟ [-ΟΟ,',Χ,'] ΚΑΙ ΓΝΗΣΙΩΣ ΑΥΞΟΥΣΑ ΣΤΟ [',Χ,',+ΟΟ]'
    ΓΡΑΨΕ'Η f(x) ΠΑΡΟΥΣΙΑΖΕΙ ΕΛΑΧΙΣΤΟ ΣΤΟ ',Χ,'ΤΟ f(',Χ,')=',ΕΛ
  ΑΛΛΙΩΣ_ΑΝ Α<0 ΤΟΤΕ
    Υ <-- Β
    Ζ <-- 2*Α
    ΓΡΑΨΕ 'Η ΠΑΡΑΓΩΓΟΣ ΕΙΝΑΙ Η f΄(x)=',Ζ,'Χ+'
    Χ <-- -Υ/Ζ
    ΜΕΓ <-- Α*(Χ^2)+Β*Χ+Γ
    ΓΡΑΨΕ'Η f(x) ΕΙΝΑΙ ΓΝΗΣΙΩΣ ΑΥΞΟΥΣΑ ΣΤΟ [-ΟΟ,',Χ,'] ΚΑΙ ΓΝΗΣΙΩΣ ΦΘΗΝΟΥΣΑ ΣΤΟ [',Χ,',+ΟΟ]'
    ΓΡΑΨΕ'Η f(x) ΠΑΡΟΥΣΙΑΖΕΙ ΜΕΓΙΣΤΟ ΣΤΟ ',Χ,'ΤΟ f(',Χ,')=',ΜΕΓ
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ'ΑΦΟΥ Η f(x)=',Β,'Χ+',Γ,'Η f΄(x) ΣΤΑΘΕΡΗ ΚΑΙ ΙΣΗ ΜΕ'
    ΑΝ Β>0 ΤΟΤΕ
      ΓΡΑΨΕ'Η f(x) ΕΙΝΑΙ ΓΝΗΣΙΩΣ ΑΥΞΟΥΣΑ ΣΤΟ IR , ΑΡΑ ΧΩΡΙΣ ΑΚΡΟΤΑΤΑ'
    ΑΛΛΙΩΣ_ΑΝ Β<0 ΤΟΤΕ
      ΓΡΑΨΕ'Η f(x) ΕΙΝΑΙ ΓΝΗΣΙΩΣ ΦΘΗΝΟΥΣΑ ΣΤΟ IR , ΑΡΑ ΧΩΡΙΣ ΑΚΡΟΤΑΤΑ'
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ'Η ΣΥΝΑΡΤΗΣΗ ΣΤΑΘΕΡΗ ΣΤΑΘΕΡΗ ΑΦΟΥ f(x)='
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'ΕΥΧΑΡΙΣΤΩ ΠΟΥ ΧΡΗΣΙΜΟΠΟΙΗΣΑΤΕ ΤΟ ΠΡΟΓΡΑΜΜΑ.'
  ΓΡΑΨΕ '                                  MADE BY YURIS'
  ΓΡΑΨΕ '                                         3η ΛΥΚΕΙΟΥ - 2ο ΛΥΚΕΙΟ ΣΠΑΡΤΗΣ.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 

_________________
"The ultimate measure of a man is not where he stands in moments of comfort and convenience, but where he stands at times of challenge and controversy."
- Martin Luther King Jr. -


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 08 Μαρ 2009 01:47 am 
Χωρίς σύνδεση

Εγγραφή: Πέμ 13 Δεκ 2007 04:15 pm
Δημοσιεύσεις: 21
Καλό, αλλα θα εχεις παρατηρήσει αυτο το απαίσιο +-3 οταν δινεται αρνητικός... Δεν θα σου πω πως να το κάνεις επειδή ξέρω οτι σου αρέσει ο προγραμματισμός, και φαντάζομαι θα ήθελες να το βρείς μονος σου.... Περιμένω να το δω διορθωμένο... :mrgreen:

_________________
--** The Develloper is the God of the programs**--


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters