Τώρα είναι Σάβ 06 Ιουν 2020 11:32 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 4 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Παρ 20 Ιαν 2006 03:35 am 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! ===============================================================
! Η μέθοδος με την οποία μπορούμε να υπολογίσουμε ποια μέρα
! της εβδομάδας πέφτουν τα Χριστούγεννα κάποια συγκεκριμένη
! χρονολογία, έχει ως εξής:
!
! 1. Έστω ΕΤ η χρονολογία που μας ενδιαφέρει.
!    Σπάζουμε το ΕΤ σε δύο μέρη:
! 2. Ονομάζουμε Α τις εκατονταετίες της χρονολογίας, δηλαδή
!    τα 2 αριστερά ψηφία του ΕΤ.
! 3. Ονομάζουμε Β τα υπόλοιπα χρόνια της χρονολογίας, δηλαδή
!    τα 2 δεξιά ψηφία του ΕΤ.
! 4. Διαιρούμε το Α με τον αριθμό 4 και κρατάμε μόνο το ακέραιο
!    μέρος. Αυτό το ονομάζουμε Κ.
! 5. Διαιρούμε το Β με τον αριθμό 4 και κρατάμε μόνο το ακέραιο
!    μέρος. Αυτό το ονομάζουμε Λ.
! 6. Για να βρούμε την ημέρα της εβδομάδας εφαρμόζουμε τον τύπο:
!    Χ = 50 + Β + Κ + Λ - 2Α.
! 7. Διαιρούμε το Χ με το 7 και το υπόλοιπο το ονομάζουμε Μ.
! 8. Αν Μ = 0 σημαίνει ότι τα Χριστούγεννα θα πέσουν Κυριακή,
!    αν Μ = 1 θα πέσουν Δευτέρα, ... κ.ο.κ... , αν Μ = 6 θα
!    πέσουν Σάββατο.
!
! Παράδειγμα:
! Έστω ότι μας ενδιαφέρει τι μέρα έπεσαν τα Χριστούγεννα το 1985.
! Θα είναι:
! ΕΤ = 1985 , Α = 19 , Β = 85 , Κ = 4 , Λ = 21 , Χ = 122 , Μ = 3
! Άρα το 1985 τα Χριστούγεννα έπεσαν Τετάρτη!
!
! ΝΓΠ το οποίο θα ζητάει μια χρονολογία και θα εμφανίζει το όνομα
! της ημέρας της εβδομάδας που πέφτουν τα Χριστούγεννα αυτήν
! τη χρονολογία.
! ===============================================================

 


Τελευταία επεξεργασία από SpiN και Παρ 02 Μαρ 2007 06:06 pm, έχει επεξεργασθεί 1 φορά/ες συνολικά

Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Παρ 27 Ιαν 2006 07:33 pm 
Syntax: [ Download ] [ Hide ]
! ===============================================================
! Η μέθοδος με την οποία μπορούμε να υπολογίσουμε ποια μέρα
! της εβδομάδας πέφτουν τα Χριστούγεννα κάποια συγκεκριμένη
! χρονολογία, έχει ως εξής:
!
! 1. Έστω ΕΤ η χρονολογία που μας ενδιαφέρει.
! Σπάζουμε το ΕΤ σε δύο μέρη:
! 2. Ονομάζουμε Α τις εκατονταετίες της χρονολογίας, δηλαδή
! τα 2 αριστερά ψηφία του ΕΤ.
! 3. Ονομάζουμε Β τα υπόλοιπα χρόνια της χρονολογίας, δηλαδή
! τα 2 δεξιά ψηφία του ΕΤ.
! 4. Διαιρούμε το Α με τον αριθμό 4 και κρατάμε μόνο το ακέραιο
! μέρος. Αυτό το ονομάζουμε Κ.
! 5. Διαιρούμε το Β με τον αριθμό 4 και κρατάμε μόνο το ακέραιο
! μέρος. Αυτό το ονομάζουμε Λ.
! 6. Για να βρούμε την ημέρα της εβδομάδας εφαρμόζουμε τον τύπο:
! Χ = 50 + Β + Κ + Λ - 2Α.
! 7. Διαιρούμε το Χ με το 7 και το υπόλοιπο το ονομάζουμε Μ.
! 8. Αν Μ = 0 σημαίνει ότι τα Χριστούγεννα θα πέσουν Κυριακή,
! αν Μ = 1 θα πέσουν Δευτέρα, ... κ.ο.κ... , αν Μ = 6 θα
! πέσουν Σάββατο.
!
! Παράδειγμα:
! Έστω ότι μας ενδιαφέρει τι μέρα έπεσαν τα Χριστούγεννα το 1985.
! Θα είναι:
! ΕΤ = 1985 , Α = 19 , Β = 85 , Κ = 4 , Λ = 21 , Χ = 122 , Μ = 3
! Άρα το 1985 τα Χριστούγεννα έπεσαν Τετάρτη!
!
! ΝΓΠ το οποίο θα ζητάει μια χρονολογία και θα εμφανίζει το όνομα
! της ημέρας της εβδομάδας που πέφτουν τα Χριστούγεννα αυτήν
! τη χρονολογία.
! ===============================================================

ΠΡΟΓΡΑΜΜΑ Χριστούγεννα

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α, Β, ΕΤ
  ΠΡΑΓΜΑΤΙΚΕΣ: Κ, Λ, Χ, Μ

ΑΡΧΗ

  ΓΡΑΨΕ 'Το πρόγραμμα ζητάει μία χρονολογία και βρισκει'
  ΓΡΑΨΕ 'τι μέρα θα πέσουν τα Χριστούγεννα'
  ΓΡΑΨΕ 'Δώστε χρονολογία'
  ΔΙΑΒΑΣΕ ΕΤ

  Α <-- ΕΤ DIV 100
  Β <-- ΕΤ MOD 100
  Κ <-- Α DIV 4
  Λ <-- Β DIV 4
  Μ <-- 50 + Β + Κ + Λ - 2*Α MOD 7

  ΟΣΟ Μ>6 ΕΠΑΝΑΛΑΒΕ
    Μ <-- Μ - 7
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΑΝ Μ=0 ΤΟΤΕ
    ΓΡΑΨΕ 'Τα Χριστούγεννα θα πέσουν Κυριακή'
  ΑΛΛΙΩΣ_ΑΝ Μ=1 ΤΟΤΕ
    ΓΡΑΨΕ 'Τα Χριστούγεννα θα πέσουν Δευτέρα'
  ΑΛΛΙΩΣ_ΑΝ Μ=2 ΤΟΤΕ
    ΓΡΑΨΕ 'Τα Χριστούγεννα θα πέσουν Τρίτη'
  ΑΛΛΙΩΣ_ΑΝ Μ=3 ΤΟΤΕ
    ΓΡΑΨΕ 'Τα Χριστούγεννα θα πέσουν Τετάρτη'
  ΑΛΛΙΩΣ_ΑΝ Μ=4 ΤΟΤΕ
    ΓΡΑΨΕ 'Τα Χριστούγεννα θα πέσουν Πέμπτη'
  ΑΛΛΙΩΣ_ΑΝ Μ=5 ΤΟΤΕ
    ΓΡΑΨΕ 'Τα Χριστούγεννα θα πέσουν Παρασκευή'
  ΑΛΛΙΩΣ_ΑΝ Μ=6 ΤΟΤΕ
    ΓΡΑΨΕ 'Τα Χριστούγεννα θα πέσουν Σάββατο'

  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Χριστούγεννα
 


Κορυφή
  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Τρί 14 Φεβ 2006 11:02 am 
Syntax: [ Download ] [ Hide ]
! ===============================================================
! Η μέθοδος με την οποία μπορούμε να υπολογίσουμε ποια μέρα
! της εβδομάδας πέφτουν τα Χριστούγεννα κάποια συγκεκριμένη
! χρονολογία, έχει ως εξής:
!
! 1. Έστω ΕΤ η χρονολογία που μας ενδιαφέρει.
! Σπάζουμε το ΕΤ σε δύο μέρη:
! 2. Ονομάζουμε Α τις εκατονταετίες της χρονολογίας, δηλαδή
! τα 2 αριστερά ψηφία του ΕΤ.
! 3. Ονομάζουμε Β τα υπόλοιπα χρόνια της χρονολογίας, δηλαδή
! τα 2 δεξιά ψηφία του ΕΤ.
! 4. Διαιρούμε το Α με τον αριθμό 4 και κρατάμε μόνο το ακέραιο
! μέρος. Αυτό το ονομάζουμε Κ.
! 5. Διαιρούμε το Β με τον αριθμό 4 και κρατάμε μόνο το ακέραιο
! μέρος. Αυτό το ονομάζουμε Λ.
! 6. Για να βρούμε την ημέρα της εβδομάδας εφαρμόζουμε τον τύπο:
! Χ = 50 + Β + Κ + Λ - 2Α.
! 7. Διαιρούμε το Χ με το 7 και το υπόλοιπο το ονομάζουμε Μ.
! 8. Αν Μ = 0 σημαίνει ότι τα Χριστούγεννα θα πέσουν Κυριακή,
! αν Μ = 1 θα πέσουν Δευτέρα, ... κ.ο.κ... , αν Μ = 6 θα
! πέσουν Σάββατο.
!
! Παράδειγμα:
! Έστω ότι μας ενδιαφέρει τι μέρα έπεσαν τα Χριστούγεννα το 1985.
! Θα είναι:
! ΕΤ = 1985 , Α = 19 , Β = 85 , Κ = 4 , Λ = 21 , Χ = 122 , Μ = 3
! Άρα το 1985 τα Χριστούγεννα έπεσαν Τετάρτη!
!
! ΝΓΠ το οποίο θα ζητάει μια χρονολογία και θα εμφανίζει το όνομα
! της ημέρας της εβδομάδας που πέφτουν τα Χριστούγεννα αυτήν
! τη χρονολογία.
! ===============================================================

ΠΡΟΓΡΑΜΜΑ Χριστούγεννα

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α, Β, Κ, Λ, ΕΤ, Χ, Μ

ΑΡΧΗ

  ΓΡΑΨΕ 'Το πρόγραμμα ζητάει μία χρονολογία και βρισκει'
  ΓΡΑΨΕ 'τι μέρα θα πέσουν τα Χριστούγεννα'
  ΓΡΑΨΕ 'Δώστε χρονολογία'
  ΔΙΑΒΑΣΕ ΕΤ

  Α <-- ΕΤ DIV 100
  Β <-- ΕΤ MOD 100
  Κ <-- Α DIV 4
  Λ <-- Β DIV 4
  Χ <-- 50 + Β + Κ + Λ - 2*Α
  Μ <-- Χ MOD 7

  ΑΝ Μ=0 ΤΟΤΕ
    ΓΡΑΨΕ 'Τα Χριστούγεννα θα πέσουν Κυριακή'
  ΑΛΛΙΩΣ_ΑΝ Μ=1 ΤΟΤΕ          
    ΓΡΑΨΕ 'Τα Χριστούγεννα θα πέσουν Δευτέρα'
  ΑΛΛΙΩΣ_ΑΝ Μ=2 ΤΟΤΕ
    ΓΡΑΨΕ 'Τα Χριστούγεννα θα πέσουν Τρίτη'
  ΑΛΛΙΩΣ_ΑΝ Μ=3 ΤΟΤΕ
    ΓΡΑΨΕ 'Τα Χριστούγεννα θα πέσουν Τετάρτη'
  ΑΛΛΙΩΣ_ΑΝ Μ=4 ΤΟΤΕ
    ΓΡΑΨΕ 'Τα Χριστούγεννα θα πέσουν Πέμπτη'
  ΑΛΛΙΩΣ_ΑΝ Μ=5 ΤΟΤΕ
    ΓΡΑΨΕ 'Τα Χριστούγεννα θα πέσουν Παρασκευή'
  ΑΛΛΙΩΣ_ΑΝ Μ=6 ΤΟΤΕ
    ΓΡΑΨΕ 'Τα Χριστούγεννα θα πέσουν Σάββατο'

  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Χριστούγεννα
 


Κορυφή
  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Τρί 14 Φεβ 2006 09:28 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 27 Ιαν 2006 07:40 pm
Δημοσιεύσεις: 6
Syntax: [ Download ] [ Hide ]
!  =============================================================
! Η μέθοδος με την οποία μπορούμε να υπολογίσουμε ποια μέρα
! της εβδομάδας πέφτουν τα Χριστούγεννα κάποια συγκεκριμένη
! χρονολογία, έχει ως εξής:
!
! 1. Έστω ΕΤ η χρονολογία που μας ενδιαφέρει.
!    Σπάζουμε το ΕΤ σε δύο μέρη:
! 2. Ονομάζουμε Α τις εκατονταετίες της χρονολογίας, δηλαδή
!    τα 2 αριστερά ψηφία του ΕΤ.
! 3. Ονομάζουμε Β τα υπόλοιπα χρόνια της χρονολογίας, δηλαδή
!    τα 2 δεξιά ψηφία του ΕΤ.
! 4. Διαιρούμε το Α με τον αριθμό 4 και κρατάμε μόνο το ακέραιο
!    μέρος. Αυτό το ονομάζουμε Κ.
! 5. Διαιρούμε το Β με τον αριθμό 4 και κρατάμε μόνο το ακέραιο
!    μέρος. Αυτό το ονομάζουμε Λ.
! 6. Για να βρούμε την ημέρα της εβδομάδας εφαρμόζουμε τον τύπο:
!    Χ = 50 + Β + Κ + Λ - 2Α.
! 7. Διαιρούμε το Χ με το 7 και το υπόλοιπο το ονομάζουμε Μ.
! 8. Αν Μ = 0 σημαίνει ότι τα Χριστούγεννα θα πέσουν Κυριακή,
!    αν Μ = 1 θα πέσουν Δευτέρα, ... κ.ο.κ... , αν Μ = 6 θα
!    πέσουν Σάββατο.
!
! Παράδειγμα:
! Έστω ότι μας ενδιαφέρει τι μέρα έπεσαν τα Χριστούγεννα το 1985.
! Θα είναι:
! ΕΤ = 1985 , Α = 19 , Β = 85 , Κ = 4 , Λ = 21 , Χ = 122 , Μ = 3
! Άρα το 1985 τα Χριστούγεννα έπεσαν Τετάρτη!
!
! ΝΓΠ το οποίο θα ζητάει μια χρονολογία και θα εμφανίζει το όνομα
! της ημέρας της εβδομάδας που πέφτουν τα Χριστούγεννα αυτήν
! τη χρονολογία.
! ===============================================================

ΠΡΟΓΡΑΜΜΑ Χριστούγεννα

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α, Β, ΕΤ, Κ, Λ, Χ, Μ
  ΧΑΡΑΚΤΗΡΕΣ: Ν

ΑΡΧΗ

  ΓΡΑΨΕ 'Το πρόγραμμα ζητάει μία χρονολογία και βρισκει'
  ΓΡΑΨΕ 'τι μέρα θα πέσουν τα Χριστούγεννα'
  ΓΡΑΨΕ 'Δώστε χρονολογία'
  ΔΙΑΒΑΣΕ ΕΤ

  ΑΝ ΕΤ>2005 ΤΟΤΕ
    Ν <-- 'θα πέσουν'
  ΑΛΛΙΩΣ
    Ν <-- 'έπεσαν'
  ΤΕΛΟΣ_ΑΝ

  Α <-- ΕΤ DIV 100
  Β <-- ΕΤ MOD 100
  Κ <-- Α DIV  4
  Λ <-- Β DIV  4
  Χ <-- 50 + Β + Κ + Λ - 2*Α
  Μ <-- Χ MOD 7

  ΑΝ Μ=0 ΤΟΤΕ
    ΓΡΑΨΕ 'Τα Χριστούγεννα', Ν, 'Κυριακή'
  ΑΛΛΙΩΣ_ΑΝ Μ=1 ΤΟΤΕ
    ΓΡΑΨΕ 'Τα Χριστούγεννα', Ν, 'Δευτέρα'
  ΑΛΛΙΩΣ_ΑΝ Μ=2 ΤΟΤΕ
    ΓΡΑΨΕ 'Τα Χριστούγεννα', Ν, 'Τρίτη'
  ΑΛΛΙΩΣ_ΑΝ Μ=3 ΤΟΤΕ
    ΓΡΑΨΕ 'Τα Χριστούγεννα', Ν, 'Τετάρτη'
  ΑΛΛΙΩΣ_ΑΝ Μ=4 ΤΟΤΕ
    ΓΡΑΨΕ 'Τα Χριστούγεννα', Ν, 'Πέμπτη'
  ΑΛΛΙΩΣ_ΑΝ Μ=5 ΤΟΤΕ
    ΓΡΑΨΕ 'Τα Χριστούγεννα', Ν, 'Παρασκευή'
  ΑΛΛΙΩΣ_ΑΝ Μ=6 ΤΟΤΕ
    ΓΡΑΨΕ 'Τα Χριστούγεννα', Ν, 'Σάββατο'

  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Χριστούγεννα


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 4 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters