Τώρα είναι Πέμ 27 Ιουν 2019 04:13 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Παρ 30 Μάιος 2003 11:13 am 
Χωρίς σύνδεση

Εγγραφή: Πέμ 01 Μάιος 2003 10:25 pm
Δημοσιεύσεις: 38
Τοποθεσία: Πρέβεζα
1. Λαμβάνουμε δυο νούμερα *ακέραια* ΔΙΑΡΕΤΕΟ και ΔΙΑΡΕΤΗ
:shock:
2. Έλεγχος μηδενικής τιμής 8) , εξαγωγή προσήμου, μετατροπή σε θετικούς των παραπάνω τιμών
3. Στο παράδειγμά μας έχουμε δώσει αριθμό δεκαδικών 12, μπορούμε να δώσουμε πολύ περισσότερο, αλλά θα τα χάσουμε :oops: - θα φύγουμε εκτός οθόνης (25 γραμμών)!
4. Στο τέλος θα κάνουμε επαλήθευση (ακόμα και η γλωσσομάθεια δεν λογαριάζει τόσα δεκαδικά :P )!
5. Πάρτε ακριβές μετρήσεις διαμέτρου και περιφέρειας ενός μεγάλου κύκλου :? (με μετροταινία 5 μέτρων) και δώστε αριθμό δεκαδικών 1000 για να βγάλετε το Π (θα πρέπει να φτιάξετε και κάποιο πίνακα να τα μαζεύετε εκεί - να μια χρησιμότητα επιπλέον της μεταβλητής ΘΕΣΗ)
6. Η κύρια χρησιμότητα της ΘΕΣΗ είναι για να τερματίζει το πρόγραμμα διαφορετικά δώστε την διαίρεση 10/3 και βγάλτε τον έλεγχο της ΘΕΣΗ να βλέπετε το 3 για όλη σας την ζωή! (3.3333333333...) :lol:

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ διαιρεση
ΣΤΑΘΕΡΕΣ
  ΑΡΙΘΜΟΣ_ΔΕΚΑΔΙΚΩΝ=12
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α,Β, ΘΕΣΗ
  ΑΚΕΡΑΙΕΣ: ΑΡΧΙΚΟ_Α, ΑΡΧΙΚΟ_Β
  ΧΑΡΑΚΤΗΡΕΣ: Π[3], ΑΠ

ΑΡΧΗ
   ! Πινακας Π μετατροπής προσήμου σε χαρακτήρα
  Π[1] <-- '-'
   ! στο μηδέν λέμε πρόσημο (+) στην εμφάνιση
   ! διότι μας ενδιαφέρει τα +/-, το μηδέν θα φανεί!
  Π[2] <-- '+'
  Π[3] <-- '+'
  ΓΡΑΨΕ '---------------ΕΠΙΔΕΙΞΗ ΔΙΑΙΡΕΣΗΣ-----------'
  ΓΡΑΨΕ 'ΔΩΣΕ ΑΚΕΡΑΙΟ ΩΣ ΔΙΑΙΡΕΤΕΟ'
  ΔΙΑΒΑΣΕ Α
  ΑΡΧΙΚΟ_Α <-- Α

  ΓΡΑΨΕ 'ΔΩΣΕ ΑΚΕΡΑΙΟ ΩΣ ΔΙΑΙΡΕΤΗ'
  ΔΙΑΒΑΣΕ Β
  ΑΡΧΙΚΟ_Β <-- Β
  ΓΡΑΨΕ 'ΠΡΟΣΗΜΟ ΑΠΟΤΕΛΕΣΜΑΤΟΣ=', Π[ΠΡΟΣΗΜΟ(Α)*ΠΡΟΣΗΜΟ(Β)+2]
  Α <-- Α_Τ(Α)
  Β <-- Α_Τ(Β)
   ! Η εξαγωγή της ΠΡΟΣΗΜΟ() μας δίνει τρια πιθανά αποτελέσματα
   ! και εδώ χρησιμοποιούμε το ένα, αν και με ένα Β=0 θα είχαμε το ίδιο αποτέλεσμα

  ΑΝ ΠΡΟΣΗΜΟ(Β)=0 ΤΟΤΕ
    ΓΡΑΨΕ 'ΔΙΑΙΡΕΣΗ ΜΕ ΤΟ ΜΗΔΕΝ - ΛΑΘΟΣ'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'ΔΙΑΙΡΕΣΗ=', (Α DIV Β)
    ΓΡΑΨΕ 'ΥΠΟΛΟΙΠΟ=', (Α MOD Β)
    ΓΡΑΨΕ 'ΥΠΟΛΟΓΙΣΜΟΣ ΔΕΚΑΔΙΚΩΝ'
    ΘΕΣΗ <-- 0
    Α <-- (Α MOD Β)
    ΟΣΟ  (ΘΕΣΗ <  ΑΡΙΘΜΟΣ_ΔΕΚΑΔΙΚΩΝ ) ΚΑΙ (Α>0)  ΕΠΑΝΑΛΑΒΕ
      ΘΕΣΗ <-- ΘΕΣΗ+1
      Α <-- Α*10
      ΓΡΑΨΕ (Α DIV Β)
      Α <-- (Α MOD Β)
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΕΠΑΛΗΘΕΥΣΗ:', ΑΡΧΙΚΟ_Α/ΑΡΧΙΚΟ_Β
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

   ! Στην BASIC υπάρχει η SGN() που δουλεύει ακριβώς όπως η ΠΡΟΣΗΜΟ()
   ! Η διαφορά είναι ότι σε επιστημονικούς υπολογισμούς μπορεί κανεις
   ! να κάνει έτσι την ΠΡΟΣΗΜΟ ώστε σε ένα μικρό διάστημα γύρω από το μηδέν
   ! να δίνει μηδέν π.χ. ( ΑΝ -.00000000000000005<ΑΛΦΑ<.00000000000000005 ΤΟΤΕ ΑΛΦΑ=0)
   ! Στους αυτοματισμούς το λέμε DEAD ZONE:
   ! όσο αυξάνουμε τη νεκρή περιοχή τόσο αναίσθητο κάνουμε το σύστημα!!!!

ΣΥΝΑΡΤΗΣΗ ΠΡΟΣΗΜΟ(ΑΛΦΑ):ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:  ΑΛΦΑ
ΑΡΧΗ
  ΑΝ ΑΛΦΑ=0 ΤΟΤΕ
    ΠΡΟΣΗΜΟ <-- 0
  ΑΛΛΙΩΣ_ΑΝ ΑΛΦΑ>0 ΤΟΤΕ
    ΠΡΟΣΗΜΟ <-- 1
  ΑΛΛΙΩΣ
    ΠΡΟΣΗΜΟ <-- -1
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

 

_________________
Γλώσσα προγραμματισμού M2000


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters