Τώρα είναι Τρί 15 Οκτ 2019 10:30 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εύρεση ΜΚΔ και ΕΚΠ 2 ακεραίων
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 12 Νοέμ 2009 10:21 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 11 Σεπ 2009 05:31 pm
Δημοσιεύσεις: 4
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΜΚΔ_ΕΚΠ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α, Β, ΜΕΤΡΗΤΗΣ, ΜΚΔ, ΕΚΠ, ΜΙΚΡΟΤΕΡΟΣ, ΜΕΓΑΛΥΤΕΡΟΣ
  ΛΟΓΙΚΕΣ: ΟΚ
ΑΡΧΗ
  ΓΡΑΨΕ 'Το πρόγραμμα αυτό υπολογίζει τον Μέγιστο Κοινό Διαιρέτη (ΜΚΔ) και'
  ΓΡΑΨΕ 'το Ελάχιστο Κοινό Πολλαπλάσιο (ΕΚΠ) δυο αριθμών Α και Β.'
  ΓΡΑΨΕ
  ΓΡΑΨΕ 'Δώσε μια τιμή για τον αριθμό Α και στη συνέχεια μια τιμή για τον αριθμό Β:'
  ΔΙΑΒΑΣΕ Α
  ΔΙΑΒΑΣΕ Β
  ΟΣΟ (Α<0) ΚΑΙ (Β<0)  ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'Δώσε δυο αριθμούς για Α και Β:'
    ΔΙΑΒΑΣΕ Α
    ΔΙΑΒΑΣΕ Β
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΜΚΔ <-- 1
  ΜΚΔ <-- Υπολογισμός_ΜΚΔ(Α, Β, ΜΚΔ)
  ΓΡΑΨΕ
  ΓΡΑΨΕ 'Ύστερα από τους πρόχειρους υπολογισμούς μου βρήκα ότι:'
  ΓΡΑΨΕ 'ΜΚΔ(',Α,',',Β,')','=', ΜΚΔ
  ΜΕΤΡΗΤΗΣ <-- 1
  ΜΙΚΡΟΤΕΡΟΣ <-- 1
  ΜΕΓΑΛΥΤΕΡΟΣ <-- 1
  ΕΚΠ <-- 1
  ΕΚΠ <-- Υπολογισμός_ΕΚΠ(Α, Β, ΜΕΤΡΗΤΗΣ, ΜΙΚΡΟΤΕΡΟΣ, ΜΕΓΑΛΥΤΕΡΟΣ, ΕΚΠ)
  ΓΡΑΨΕ 'και'
  ΓΡΑΨΕ 'ΕΚΠ(',Α,',',Β,')','=', ΕΚΠ
  ΓΡΑΨΕ
  ΓΡΑΨΕ 'Έκανα λάθος; Δε νομίζω!!!'
  ΓΡΑΨΕ 'Made by John Kopanelos ©2009'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΜΚΔ_ΕΚΠ
ΣΥΝΑΡΤΗΣΗ  Υπολογισμός_ΜΚΔ(Συν_Α, Συν_Β, Συν_ΜΚΔ) :  : ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Συν_Α, Συν_Β, Συν_ΜΚΔ
  ΛΟΓΙΚΕΣ:  Συν_ΟΚ
ΑΡΧΗ
  ΑΝ   Συν_Α<Συν_Β ΤΟΤΕ
    Συν_ΜΚΔ <-- Συν_Α
  ΑΛΛΙΩΣ
    Συν_ΜΚΔ <-- Συν_Β
  ΤΕΛΟΣ_ΑΝ
  Συν_ΟΚ <-- ΨΕΥΔΗΣ
  ΟΣΟ  Συν_ΟΚ = ΨΕΥΔΗΣ  ΕΠΑΝΑΛΑΒΕ
    ΑΝ (Συν_Α MOD Συν_ΜΚΔ = 0) ΚΑΙ(Συν_Β MOD Συν_ΜΚΔ = 0) ΤΟΤΕ
      Συν_ΟΚ <-- ΑΛΗΘΗΣ
    ΑΛΛΙΩΣ
      Συν_ΜΚΔ <-- Συν_ΜΚΔ - 1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Υπολογισμός_ΜΚΔ <-- Συν_ΜΚΔ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
ΣΥΝΑΡΤΗΣΗ Υπολογισμός_ΕΚΠ(Συν_Α, Συν_Β, Συν_ΜΕΤΡΗΤΗΣ, Συν_ΜΙΚΡΟΤΕΡΟΣ, Συν_ΜΕΓΑΛΥΤΕΡΟΣ, Συν_ΕΚΠ) : ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Συν_Α, Συν_Β, Συν_ΜΕΤΡΗΤΗΣ, Συν_ΜΙΚΡΟΤΕΡΟΣ, Συν_ΜΕΓΑΛΥΤΕΡΟΣ, Συν_ΕΚΠ
  ΛΟΓΙΚΕΣ: Συν_ΟΚ
ΑΡΧΗ
  ΑΝ Συν_Α>Συν_Β ΤΟΤΕ
    Συν_ΜΙΚΡΟΤΕΡΟΣ <-- Συν_Β
    Συν_ΜΕΓΑΛΥΤΕΡΟΣ <-- Συν_Α
  ΑΛΛΙΩΣ
    Συν_ΜΙΚΡΟΤΕΡΟΣ <-- Συν_Α
    Συν_ΜΕΓΑΛΥΤΕΡΟΣ <-- Συν_Β
  ΤΕΛΟΣ_ΑΝ
  Συν_ΟΚ <-- ΨΕΥΔΗΣ
  Συν_ΜΕΤΡΗΤΗΣ <-- 1
  ΟΣΟ Συν_ΟΚ = ΨΕΥΔΗΣ  ΕΠΑΝΑΛΑΒΕ
    ΑΝ (Συν_ΜΕΓΑΛΥΤΕΡΟΣ*Συν_ΜΕΤΡΗΤΗΣ) MOD Συν_ΜΙΚΡΟΤΕΡΟΣ = 0  ΤΟΤΕ
      Συν_ΟΚ <-- ΑΛΗΘΗΣ
      Συν_ΕΚΠ <-- Συν_ΜΕΓΑΛΥΤΕΡΟΣ*Συν_ΜΕΤΡΗΤΗΣ
    ΑΛΛΙΩΣ
      Συν_ΜΕΤΡΗΤΗΣ <-- Συν_ΜΕΤΡΗΤΗΣ + 1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Υπολογισμός_ΕΚΠ <-- Συν_ΕΚΠ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ




 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters