Τώρα είναι Τρί 31 Μαρ 2020 10:52 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Παρ 01 Ιουν 2007 11:51 am 
Χωρίς σύνδεση

Εγγραφή: Πέμ 31 Μάιος 2007 03:34 am
Δημοσιεύσεις: 3
Τοποθεσία: Θεσσαλονικη
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΕΙΣΑΓΩΓΗ_ΔΕΔΟΜΕΝΩΝ_ΜΕ_ΣΥΝΑΡΤΗΣΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι,Α[10]
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    Α[Ι] <-- ΕΙΣΑΓΩΓΗ(Ι)
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Ο ΠΙΝΑΚΑΣ Α ΠΕΡΙΕΧΕΙ:'
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ Α[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ ΕΙΣΑΓΩΓΗ(Ι):ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι,Χ
ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ',Ι,'ΣΤΟΙΧΕΙΟ ΤΟΥ ΠΙΝΑΚΑ Α'
  ΔΙΑΒΑΣΕ Χ
  ΕΙΣΑΓΩΓΗ <-- Χ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


Το παραπανω δεν μπορει να θεωρηθει Εισαγωγη Δεδομενων με Συναρτηση??? :evil:

Εγω με βαση αυτο στο μυαλο μου, απαντησα εχτες στις Εξετασεις στο Θεμα 1, στο Β2, οτι με συναρτηση μπορει να γινει και εισαγωγη ενος δεδομενου. Σημερα στις απαντησεις που κυκλοφορουν στο Internet βλεπω οτι ειναι το μοναδικο λαθος που εκανα... :?


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Παρ 01 Ιουν 2007 01:34 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 26 Ιαν 2006 07:53 pm
Δημοσιεύσεις: 2
Συμφωνώ μαζί σου Phlegethon18. Σήμερα στα βαθμολογικά κέντρα όλης της χώρας θα γίνει ενημέρωση σχετικά με τη βαθμολόγηση του μαθήματος. Είμαι περίεργος να δω τί θα θεωρηθεί σωστό...
Ακολουθεί ένα μικρό πρόγραμμα με συνάρτηση που κάνει εισαγωγή δεδομένων.

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Θέμα_1_Β2_α
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: α
ΑΡΧΗ
  ΓΡΑΨΕ Φ(α)
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ Φ(β): ΧΑΡΑΚΤΗΡΑΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: β
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε τιμή:'
  ΔΙΑΒΑΣΕ β
  Φ <-- β
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Παρ 01 Ιουν 2007 04:55 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Η ΑΕΠΠ σαν καινούριο μάθημα ήταν φυσικό να πάσχει από αρκετές... παιδικές ασθένειες.
Με τον καιρό θα ξεπεραστούν όλες.

Με αφορμή τις δύο παραπάνω δημοσιεύσεις θέλω να θίξω δύο σημεία:

1. Προσήλωση στα Πληροφορικά πρότυπα

Σε περίπτωση που κάποιο θέμα δεν αποσαφηνίζεται επαρκώς στο βιβλίο, τι διδάσκουμε στα παιδιά; Λαμβάνουμε υπόψη μας τα ισχύοντα στον Πληροφορικό χώρο και εξάγουμε μια λογική συνισταμένη, ή ανατρέχουμε στο ιερό τέρας των Μαθηματικών που ενδεχομένως έχει τη δική του απάντηση;

Η άποψή μου είναι ότι πρέπει να ακολουθήσουμε αυτά που επιτάσσει η Πληροφορική.
Ναι μεν "στόχος του μαθήματος δεν είναι η δημιουργία προγραμματιστών", αλλά το μάθημα λέγεται "ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ". Δεν λέγεται ούτε "Λογική Ανάλυση", ούτε "Αλγοριθμική Θεωρία", ούτε...

Αυτό μας υποδεικνύει κάτι: Ναι μεν στόχος είναι η προαγωγή της αναλυτικής και συνθετικής σκέψης, αλλά ΜΕ ΧΡΗΣΗ ΕΝΟΣ ΣΥΓΚΕΚΡΙΜΕΝΟΥ ΕΡΓΑΛΕΙΟΥ - ΤΟΥ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟΥ ΠΕΡΙΒΑΛΛΟΝΤΟΣ ΣΕ Η/Υ.
Γι αυτό το μάθημα μπήκε στην Τεχνολογική και όχι στην Θετική Κατεύθυνση και γι αυτό το διδάσκουν Πληροφορικοί και όχι Μαθηματικοί.

Βέβαια όλα τα παραπάνω ισχύουν όσο δεν υπάρχουν διευκρινήσεις από τους επίσημους φορείς. Αν και όποτε υπάρξουν τέτοιες, εξυπακούεται ότι πρέπει να τις ακολουθήσουμε κατά γράμμα.

2. Βελτιστοποίηση προγραμμάτων

Μέγα θέμα, με δύο προεκτάσεις:
- Πως αξιολογούμε μη-αποδοτικά προγράμματα, δηλαδή αυτά που ναι μεν καταλήγουν στο σωστό αποτέλεσμα, αλλά υλοποιούν υπέρ του δέοντος απαιτητικές (σε χρόνο και υπολογιστική ισχύ) μεθόδους;
- Πως αξιολογούμε ανορθόδοξα προγράμματα, δηλαδή αυτά που ναι μεν καταλήγουν στο σωστό αποτέλεσμα, αλλά το κάνουν καταστρατηγώντας προγραμματιστικές αρχές;
Το θέμα σηκώνει πολλή συζήτηση...


"Επιτρέπονται εντολές εισόδου/εξόδου σε συνάρτηση;"

Σε όποιον έχει ασχοληθεί στοιχειωδώς με τον προγραμματισμό (πέρα από την ΑΕΠΠ), αυτή η ερώτηση φαντάζει -επιεικώς- περίεργη, αφού η συγκεκριμένη τακτική χρησιμοποιείται κατά κόρον στις γλώσσες προγραμματισμού.
Ίσως οι ΓΡΑΨΕ/ΔΙΑΒΑΣΕ μέσα σε συνάρτηση να κάνουν τη λειτουργία της πιο δυσνόητη (για κάποιον στο γνωστικό επίπεδο των μαθητών), αλλά αυτό δεν σημαίνει ότι πρέπει να ευνουχίσουμε της δυνατότητες της γλώσσας. Υπάρχει σημαντική διαφορά ανάμεσα στο "ΕΝΔΕΙΚΝΥΤΑΙ" και στο "ΑΠΑΓΟΡΕΥΕΤΑΙ".
Η γνώμη μου είναι ότι η χρήση εντολών εισόδου/εξόδου μέσα σε συνάρτηση δεν πρέπει να θεωρείται προγραμματιστικό σφάλμα.


ΥΓ: Σε γενικές γραμμές η φιλοσοφία των φετινών θεμάτων ήταν ένα ελπιδοφόρο άλμα προς τη σωστή κατεύθυνση.


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters