Τώρα είναι Πέμ 02 Απρ 2020 12:17 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 31 Μάιος 2007 05:53 am 
Χωρίς σύνδεση

Εγγραφή: Πέμ 31 Μάιος 2007 03:34 am
Δημοσιεύσεις: 3
Τοποθεσία: Θεσσαλονικη
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΥΠΟΛΟΓΙΣΜΟΣ_ΜΟΡΙΩΝ
ΣΤΑΘΕΡΕΣ
  α=1.3
  β=0.7
  γ=0.9
  δ=0.4
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: Τ1,Τ2,ΜΟ1,ΜΟ2,ΜΟ3,ΜΟ4,ΜΟ5,ΜΟ6,ΜΟ7,ΠΑΝ,ΓΒΠ,ΜΟΡΙΑ,ΕΠΙΛ,ΟΙΚ,ΚΑΤ
  ΑΚΕΡΑΙΕΣ: ΠΕΔΙΟ
ΑΡΧΗ
  ΓΡΑΨΕ 'ΠΛΗΚΤΡΟΛΟΓΗΣΕ ΤΟ ΑΝΤΙΣΤΟΙΧΟ ΑΡΙΘΜΟ ΓΙΑ ΝΑ ΕΠΙΛΕΞΕΙΣ:'
  ΓΡΑΨΕ '===================================================='
  ΓΡΑΨΕ 'ΚΑΤΕΥΘΥΝΣΗ:'
  ΓΡΑΨΕ '----------------------------------------------------'
  ΓΡΑΨΕ '1 - ΘΕΩΡΗΤΙΚΗ'
  ΓΡΑΨΕ '2 - ΘΕΤΙΚΗ'
  ΓΡΑΨΕ '3 - ΤΕΧΝΟΛΟΓΙΚΗ'
  ΔΙΑΒΑΣΕ ΚΑΤ
  ΓΡΑΨΕ '----------------------------------------------------'
  ΓΡΑΨΕ 'ΜΑΘΗΜΑ ΕΠΙΛΟΓΗΣ:'
  ΓΡΑΨΕ '----------------------------------------------------'
  ΓΡΑΨΕ '1 - ΜΑΘΗΜΑΤΙΚΑ ΚΑΙ ΣΤΟΙΧΕΙΑ ΣΤΑΤΙΣΤΙΚΗΣ ΓΕΝΙΚΗΣ'
  ΓΡΑΨΕ '2 - ΒΙΟΛΟΓΙΑ ΓΕΝΙΚΗΣ'
  ΓΡΑΨΕ '3 - ΦΥΣΙΚΗ ΓΕΝΙΚΗΣ'
  ΓΡΑΨΕ '4 - ΙΣΤΟΡΙΑ ΓΕΝΙΚΗΣ'                                                      
  ΔΙΑΒΑΣΕ ΕΠΙΛ
  ΓΡΑΨΕ '----------------------------------------------------'
  ΓΡΑΨΕ 'ΑΡΧΕΣ ΟΙΚΟΝΟΜΙΚΗΣ ΘΕΩΡΙΑΣ:'
  ΓΡΑΨΕ '----------------------------------------------------'
  ΓΡΑΨΕ '1 - ΤΟ ΔΙΝΩ ΠΑΝΕΛΛΑΔΙΚΑ'
  ΓΡΑΨΕ '0 - ΔΕΝ ΤΟ ΔΙΝΩ ΠΑΝΕΛΛΑΔΙΚΑ'
  ΔΙΑΒΑΣΕ ΟΙΚ
  ΓΡΑΨΕ '----------------------------------------------------'
  ΓΡΑΨΕ 'ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ:'
  ΓΡΑΨΕ '----------------------------------------------------'
  ΓΡΑΨΕ '1 - ΑΝΘΡΩΠΙΣΤΙΚΕΣ, ΝΟΜΙΚΕΣ ΚΑΙ ΚΟΙΝΩΝΙΚΕΣ ΕΠΙΣΤΗΜΕΣ'
  ΓΡΑΨΕ '2 - ΘΕΤΙΚΕΣ ΕΠΙΣΤΗΜΕΣ'
  ΓΡΑΨΕ '3 - ΕΠΙΣΤΗΜΕΣ ΥΓΕΙΑΣ'
  ΓΡΑΨΕ '4 - ΤΕΧΝΟΛΟΓΙΚΕΣ ΕΠΙΣΤΗΜΕΣ'
  ΓΡΑΨΕ '5 - ΕΠΙΣΤΜΕΣ ΟΙΚΟΝΟΜΙΑΣ ΚΑΙ ΔΙΟΙΚΗΣΗΣ'
  ΔΙΑΒΑΣΕ ΠΕΔΙΟ
  ΓΡΑΨΕ '===================================================='
  ΓΡΑΨΕ '===================================================='
  ΓΡΑΨΕ 'ΔΩΣΕ ΒΑΘΜΟΥΣ ΤΩΝ ΔΥΟ ΤΕΤΡΑΜΗΝΩΝ ΣΤΗΝ ΝΕΟΕΛΛΗΝΙΚΗ ΓΛΩΣΣΑ ΚΑΙ ΒΑΘΜΟΛΟΓΙΑ ΣΟΥ ΣΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ:'
  ΔΙΑΒΑΣΕ Τ1,Τ2,ΠΑΝ
  ΜΟ1 <-- ΥΠΟΛΟΓΙΣΜΟΣ(Τ1,Τ2,ΠΑΝ)
  ΑΝ ΚΑΤ=1 ΤΟΤΕ
    ΓΡΑΨΕ 'ΔΩΣΕ ΒΑΘΜΟΥΣ ΤΩΝ ΔΥΟ ΤΕΤΡΑΜΗΝΩΝ ΣΤΑ ΑΡΧΑΙΑ ΚΑΤΕΥΘΥΝΣΗΣ ΚΑΙ ΒΑΘΜΟΛΟΓΙΑ ΣΟΥ ΣΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ:'
    ΔΙΑΒΑΣΕ Τ1,Τ2,ΠΑΝ
    ΜΟ2 <-- ΥΠΟΛΟΓΙΣΜΟΣ(Τ1,Τ2,ΠΑΝ)
    ΓΡΑΨΕ 'ΔΩΣΕ ΒΑΘΜΟΥΣ ΤΩΝ ΔΥΟ ΤΕΤΡΑΜΗΝΩΝ ΣΤΗΝ ΙΣΤΟΡΙΑ ΚΑΙ ΒΑΘΜΟΛΟΓΙΑ ΣΟΥ ΣΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ:'
    ΔΙΑΒΑΣΕ Τ1,Τ2,ΠΑΝ
    ΜΟ3 <-- ΥΠΟΛΟΓΙΣΜΟΣ(Τ1,Τ2,ΠΑΝ)
    ΓΡΑΨΕ 'ΔΩΣΕ ΒΑΘΜΟΥΣ ΤΩΝ ΔΥΟ ΤΕΤΡΑΜΗΝΩΝ ΣΤΗΝ ΝΕΟΕΛΛΗΝΙΚΗ ΛΟΓΟΤΕΧΝΙΑ ΚΑΙ ΒΑΘΜΟΛΟΓΙΑ ΣΟΥ ΣΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ:'
    ΔΙΑΒΑΣΕ Τ1,Τ2,ΠΑΝ
    ΜΟ4 <-- ΥΠΟΛΟΓΙΣΜΟΣ(Τ1,Τ2,ΠΑΝ)
    ΓΡΑΨΕ 'ΔΩΣΕ ΒΑΘΜΟΥΣ ΤΩΝ ΔΥΟ ΤΕΤΡΑΜΗΝΩΝ ΣΤΤΑ ΛΑΤΙΝΙΚΑ ΚΑΙ ΒΑΘΜΟΛΟΓΙΑ ΣΟΥ ΣΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ:'
    ΔΙΑΒΑΣΕ Τ1,Τ2,ΠΑΝ
    ΜΟ5 <-- ΥΠΟΛΟΓΙΣΜΟΣ(Τ1,Τ2,ΠΑΝ)
  ΑΛΛΙΩΣ_ΑΝ ΚΑΤ=2 ΤΟΤΕ
    ΓΡΑΨΕ 'ΔΩΣΕ ΒΑΘΜΟΥΣ ΤΩΝ ΔΥΟ ΤΕΤΡΑΜΗΝΩΝ ΣΤΗΝ ΒΙΟΛΟΓΙΑ ΚΑΤΕΥΘΥΝΣΗΣ ΚΑΙ ΒΑΘΜΟΛΟΓΙΑ ΣΟΥ ΣΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ:'
    ΔΙΑΒΑΣΕ Τ1,Τ2,ΠΑΝ
    ΜΟ2 <-- ΥΠΟΛΟΓΙΣΜΟΣ(Τ1,Τ2,ΠΑΝ)
    ΓΡΑΨΕ 'ΔΩΣΕ ΒΑΘΜΟΥΣ ΤΩΝ ΔΥΟ ΤΕΤΡΑΜΗΝΩΝ ΣΤΗΝ ΧΗΜΕΙΑ ΚΑΤΕΥΘΥΝΣΗΣ ΚΑΙ ΒΑΘΜΟΛΟΓΙΑ ΣΟΥ ΣΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ:'
    ΔΙΑΒΑΣΕ Τ1,Τ2,ΠΑΝ
    ΜΟ3 <-- ΥΠΟΛΟΓΙΣΜΟΣ(Τ1,Τ2,ΠΑΝ)
    ΓΡΑΨΕ 'ΔΩΣΕ ΒΑΘΜΟΥΣ ΤΩΝ ΔΥΟ ΤΕΤΡΑΜΗΝΩΝ ΣΤΑ ΜΑΘΗΜΑΤΙΚΑ ΚΑΤΕΥΘΥΝΣΗΣ ΚΑΙ ΒΑΘΜΟΛΟΓΙΑ ΣΟΥ ΣΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ:'
    ΔΙΑΒΑΣΕ Τ1,Τ2,ΠΑΝ
    ΜΟ4 <-- ΥΠΟΛΟΓΙΣΜΟΣ(Τ1,Τ2,ΠΑΝ)
    ΓΡΑΨΕ 'ΔΩΣΕ ΒΑΘΜΟΥΣ ΤΩΝ ΔΥΟ ΤΕΤΡΑΜΗΝΩΝ ΣΤΗ ΦΥΣΙΚΗ ΚΑΤΕΥΘΥΝΣΗΣ ΚΑΙ ΒΑΘΜΟΛΟΓΙΑ ΣΟΥ ΣΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ:'
    ΔΙΑΒΑΣΕ Τ1,Τ2,ΠΑΝ
    ΜΟ5 <-- ΥΠΟΛΟΓΙΣΜΟΣ(Τ1,Τ2,ΠΑΝ)
  ΑΛΛΙΩΣ_ΑΝ ΚΑΤ=3 ΤΟΤΕ
    ΓΡΑΨΕ 'ΔΩΣΕ ΒΑΘΜΟΥΣ ΤΩΝ ΔΥΟ ΤΕΤΡΑΜΗΝΩΝ ΣΤΑ ΜΑΘΗΜΑΤΙΚΑ ΚΑΤΕΥΘΥΝΣΗΣ ΚΑΙ ΒΑΘΜΟΛΟΓΙΑ ΣΟΥ ΣΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ:'
    ΔΙΑΒΑΣΕ Τ1,Τ2,ΠΑΝ
    ΜΟ2 <-- ΥΠΟΛΟΓΙΣΜΟΣ(Τ1,Τ2,ΠΑΝ)
    ΓΡΑΨΕ 'ΔΩΣΕ ΒΑΘΜΟΥΣ ΤΩΝ ΔΥΟ ΤΕΤΡΑΜΗΝΩΝ ΣΤΗ ΦΥΣΙΚΗ ΚΑΤΕΥΘΥΝΣΗΣ ΚΑΙ ΒΑΘΜΟΛΟΓΙΑ ΣΟΥ ΣΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ:'
    ΔΙΑΒΑΣΕ Τ1,Τ2,ΠΑΝ
    ΜΟ3 <-- ΥΠΟΛΟΓΙΣΜΟΣ(Τ1,Τ2,ΠΑΝ)
    ΓΡΑΨΕ 'ΔΩΣΕ ΒΑΘΜΟΥΣ ΤΩΝ ΔΥΟ ΤΕΤΡΑΜΗΝΩΝ ΣΤΟ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟ ΚΑΙ ΒΑΘΜΟΛΟΓΙΑ ΣΟΥ ΣΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ:'
    ΔΙΑΒΑΣΕ Τ1,Τ2,ΠΑΝ
    ΜΟ4 <-- ΥΠΟΛΟΓΙΣΜΟΣ(Τ1,Τ2,ΠΑΝ)
    ΓΡΑΨΕ 'ΔΩΣΕ ΒΑΘΜΟΥΣ ΤΩΝ ΔΥΟ ΤΕΤΡΑΜΗΝΩΝ ΣΤΟ Α.Ο.Δ.Ε. ΚΑΙ ΒΑΘΜΟΛΟΓΙΑ ΣΟΥ ΣΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ:'
    ΔΙΑΒΑΣΕ Τ1,Τ2,ΠΑΝ
    ΜΟ5 <-- ΥΠΟΛΟΓΙΣΜΟΣ(Τ1,Τ2,ΠΑΝ)
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΕΠΙΛ=1 ΤΟΤΕ
    ΓΡΑΨΕ 'ΔΩΣΕ ΒΑΘΜΟΥΣ ΤΩΝ ΔΥΟ ΤΕΤΡΑΜΗΝΩΝ ΣΤΑ ΜΑΘΗΜΑΤΙΚΑ ΚΑΙ ΣΤΟΙΧΕΙΑ ΣΤΑΤΙΣΤΙΚΗΣ ΓΕΝΙΚΗΣ ΚΑΙ ΒΑΘΜΟΛΟΓΙΑ ΣΟΥ ΣΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ:'
  ΑΛΛΙΩΣ_ΑΝ ΕΠΙΛ=2 ΤΟΤΕ
    ΓΡΑΨΕ 'ΔΩΣΕ ΒΑΘΜΟΥΣ ΤΩΝ ΔΥΟ ΤΕΤΡΑΜΗΝΩΝ ΣΤΗ ΒΙΟΛΟΓΙΑ ΓΕΝΙΚΗΣ ΚΑΙ ΒΑΘΜΟΛΟΓΙΑ ΣΟΥ ΣΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ:'
  ΑΛΛΙΩΣ_ΑΝ ΕΠΙΛ=3 ΤΟΤΕ
    ΓΡΑΨΕ 'ΔΩΣΕ ΒΑΘΜΟΥΣ ΤΩΝ ΔΥΟ ΤΕΤΡΑΜΗΝΩΝ ΣΤΗ ΦΥΣΙΚΗ ΓΕΝΙΚΗΣ ΚΑΙ ΒΑΘΜΟΛΟΓΙΑ ΣΟΥ ΣΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ:'
  ΑΛΛΙΩΣ_ΑΝ ΕΠΙΛ=4 ΤΟΤΕ
    ΓΡΑΨΕ 'ΔΩΣΕ ΒΑΘΜΟΥΣ ΤΩΝ ΔΥΟ ΤΕΤΡΑΜΗΝΩΝ ΣΤΗΝ ΙΣΤΟΡΙΑ ΓΕΝΙΚΗΣ ΚΑΙ ΒΑΘΜΟΛΟΓΙΑ ΣΟΥ ΣΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ:'
  ΤΕΛΟΣ_ΑΝ
  ΔΙΑΒΑΣΕ Τ1,Τ2,ΠΑΝ
  ΜΟ6 <-- ΥΠΟΛΟΓΙΣΜΟΣ(Τ1,Τ2,ΠΑΝ)
  ΑΝ ΟΙΚ=1 ΤΟΤΕ
    ΓΡΑΨΕ 'ΔΩΣΕ ΒΑΘΜΟΥΣ ΤΩΝ ΔΥΟ ΤΕΤΡΑΜΗΝΩΝ ΣΤΙΣ ΑΡΧΕΣ ΟΙΚΟΝΟΜΙΚΗΣ ΘΕΩΡΙΑΣ ΚΑΙ ΒΑΘΜΟΛΟΓΙΑ ΣΟΥ ΣΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ:'
    ΔΙΑΒΑΣΕ Τ1,Τ2,ΠΑΝ
    ΜΟ7 <-- ΥΠΟΛΟΓΙΣΜΟΣ(Τ1,Τ2,ΠΑΝ)
    ΓΒΠ <-- (ΜΟ1+ΜΟ2+ΜΟ3+ΜΟ4+ΜΟ5+ΜΟ6+ΜΟ7)/7
  ΑΛΛΙΩΣ
    ΓΒΠ <-- (ΜΟ1+ΜΟ2+ΜΟ3+ΜΟ4+ΜΟ5+ΜΟ6)/6
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΚΑΤ=1 ΤΟΤΕ
    ΑΝ ΠΕΔΙΟ=1 ΤΟΤΕ
      ΜΟΡΙΑ <-- (ΓΒΠ*8+ΜΟ2*α+ΜΟ3*β)*100
    ΑΛΛΙΩΣ_ΑΝ ΠΕΔΙΟ=3 Ή ΠΕΔΙΟ=4 Ή ΠΕΔΙΟ=2 ΤΟΤΕ
      ΜΟΡΙΑ <-- (ΓΒΠ*8+ΜΟ6*γ+ΜΟ1*δ)*100
    ΑΛΛΙΩΣ_ΑΝ ΠΕΔΙΟ=5 ΤΟΤΕ
      ΜΟΡΙΑ <-- (ΓΒΠ*8+ΜΟ7*α+ΜΟ6*β)*100
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ ΚΑΤ=2 ΤΟΤΕ
    ΑΝ ΠΕΔΙΟ=2 Ή ΠΕΔΙΟ=4 ΤΟΤΕ
      ΜΟΡΙΑ <-- (ΓΒΠ*8+ΜΟ4*α+ΜΟ5*β)*100
    ΑΛΛΙΩΣ_ΑΝ ΠΕΔΙΟ=3 ΤΟΤΕ
      ΜΟΡΙΑ <-- (ΓΒΠ*8+ΜΟ2*α+ΜΟ3*β)*100
    ΑΛΛΙΩΣ_ΑΝ ΠΕΔΙΟ=1 ΤΟΤΕ
      ΜΟΡΙΑ <-- (ΓΒΠ*8+ΜΟ6*δ+ΜΟ1*γ)*100
    ΑΛΛΙΩΣ_ΑΝ ΠΕΔΙΟ=5 ΤΟΤΕ
      ΜΟΡΙΑ <-- (ΓΒΠ*8+ΜΟ7*α+ΜΟ6*β)*100
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ ΚΑΤ=3 ΤΟΤΕ
    ΑΝ ΠΕΔΙΟ=1 ΤΟΤΕ
      ΜΟΡΙΑ <-- (ΓΒΠ*8+ΜΟ6*δ+ΜΟ1*γ)*100
    ΑΛΛΙΩΣ_ΑΝ ΠΕΔΙΟ=3 ΤΟΤΕ
      ΜΟΡΙΑ <-- (ΓΒΠ*8+ΜΟ6*γ+ΜΟ1*δ)*100
    ΑΛΛΙΩΣ_ΑΝ ΠΕΔΙΟ=2 Ή ΠΕΔΙΟ=4 ΤΟΤΕ
      ΜΟΡΙΑ <-- (ΓΒΠ*8+ΜΟ2*α+ΜΟ3*β)*100
      ΓΡΑΨΕ ΜΟ2*Α
      ΓΡΑΨΕ ΜΟ3*Β
    ΑΛΛΙΩΣ_ΑΝ ΠΕΔΙΟ=5 ΤΟΤΕ
      ΜΟΡΙΑ <-- (ΓΒΠ*8+ΜΟ7*α+ΜΟ6*β)*100
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'Ο ΓΕΝΙΚΟΣ ΒΑΘΜΟΣ ΠΡΟΣΒΑΣΗΣ ΕΙΝΑΙ:',(ΓΒΠ*1000)
  ΓΡΑΨΕ 'Ο ΣΥΝΟΛΙΚΟΣ ΑΡΙΘΜΟΣ ΜΟΡΙΩΝ ΣΟΥ ΕΙΝΑΙ:',ΜΟΡΙΑ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ ΥΠΟΛΟΓΙΣΜΟΣ(Χ,Υ,ΓΡ):ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΠΡ,Χ,Υ,ΓΡ
ΑΡΧΗ
  ΠΡ <-- (Χ+Υ)/2
  ΑΝ ΠΡ>(ΓΡ+2) ΤΟΤΕ
    ΠΡ <-- ΓΡ+2
  ΑΛΛΙΩΣ_ΑΝ ΠΡ<(ΓΡ-2) ΤΟΤΕ
    ΠΡ <-- ΓΡ-2
  ΤΕΛΟΣ_ΑΝ
  ΥΠΟΛΟΓΙΣΜΟΣ <-- (ΠΡ*0.3)+(ΓΡ*0.7)
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


Το παραπανω "Προγραμμα-Τερας" το εκανα απο περιεργια για τον εαν θα ηταν δυνατο να φτιαχθει ενα ακριβες προγραμμα υπολογισμου των μοριων ολων των κατευθυνσεων και ολων των πεδιων... :P

ΠΡΟΣΟΧΗ ΟΜΩΣ...!
Ο παραπανω αλγοριθμος δεν εχει ελεγχο ειδοσου! Αυτο σημαινει οτι ο,τι και να δωσετε για βαθμολογια, μαθημα επιλογης, πεδιο...κτλ θα το δεχτει απλως δεν θα βγαλει σωστα αποτελεσματα! Απεφυγα να βαλω ελεγχο εισοδου και περιορισμους στην επιλογη μαθηματος επιλογης και πεδιου διοτι το αποτελεσμα θα ηταν ενα ΑΚΟΜΑ ΠΙΟ ΜΕΓΑΛΟ προγραμμα! :?

Αυτο που θελω αρχικα ειναι να ελεγξει καποιος, αν πραγματι το προγραμμα λειτουργει κανονικα (αν δηλαλη τα μορια βγαινουν σωστα)... Εγω δεν του βρισκω λαθος αλλα ειναι αρκετα μεγαλο για να ειμαι σιγουρος... :oops:

Εαν το παραπανω προγραμμα λειτουργει σωστα (με την προυποθεση να του δωθουν σωστα στοιχεια, δηλαδη 0<βαθμοι<=20 και μαθηματα επιλογης με σωστα πεδια) θα ηθελα να ρωτησω πως θα γινοταν να το "μικρυνω" λιγο π.χ με αλλο ενα υποπρογραμμα κτλ... :)

Ευχαριστω εκ των προτερων... :wink:

Υ.Γ.: Το προγραμμα ειναι γραμμενο στην τελευταια εκδοση Μεταγλωττιστη (Compiler) της ΓλωσσοΜαθειας. Για καλο των νευρων σας μην δοκιμασετε να το τρεξετε στην εκδοση του Διερμηνευτη παρα μονο αν θελετε να το εξετασετε "εξωνυχιστικα"... :lol: :lol:


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters