Τώρα είναι Τρί 26 Μάιος 2020 08:52 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Παρ 18 Μάιος 2007 08:08 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! = ΤΕΛ05 =================================================================
! Για τον έλεγχο της αποτελεσματικότητας ενός νέου εμβολίου κατά της γρίπης
! μια φαρμακευτική εταιρεία χρησιμοποίησε 10.000 άτομα. Στα μισά περίπου
! από αυτά χορηγήθηκε το εμβόλιο και στα υπόλοιπα απλός φυσιολογικός ορός.
! Το εμβόλιο θεωρείται αποτελεσματικό αν το ποσοστό των ατόμων που νόσησαν
! από αυτούς που εμβολιάσθηκαν διαφέρει από το αντίστοιχο ποσοστό αυτών που
! τους χορηγήθηκε ο ορός περισσότερο από 20%.
! Να γραφεί πρόγραμμα το οποίο :
! · για κάθε ένα από τα άτομα που πήραν μέρος στην έρευνα ζητά και καταχωρεί
!   σε κατάλληλους πίνακες (κάνοντας και έλεγχο εγκυρότητας):
!   - αν του χορηγήθηκε εμβόλιο ή απλός ορός με την καταχώρηση 1 ή 0 αντί-
!     στοιχα.
!   - αν νόσησε ή όχι στο χρονικό διάστημα της έρευνας με την καταχώρηση
!     ΝΑΙ ή ΟΧΙ αντίστοιχα.
! · υπολογίζει με κατάλληλο υποπρόγραμμα το ποσοστό αυτών που νόσησαν σε
!   κάθε μία από τις δύο κατηγορίες.
! · βρίσκει και εμφανίζει αν το εμβόλιο είναι αποτελεσματικό ή όχι.
! =========================================================================
!
ΠΡΟΓΡΑΜΜΑ TEL_05
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : em[10000] , i , j , n1 , n2 , s1 , s2
  ΠΡΑΓΜΑΤΙΚΕΣ : x1 , x2
  ΧΑΡΑΚΤΗΡΕΣ : ar[10000]
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10000
    ΓΡΑΨΕ 'O' , i , 'πήρε εμβόλιο ; 1 = ΝΑΙ ή 0 = ΟΧΙ'
    ΔΙΑΒΑΣΕ em[i]
    ΟΣΟ em[i] <> 0 ΚΑΙ em[i] <> 1 ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'Λάθος. Ξαναδώσε.'
      ΔΙΑΒΑΣΕ em[i]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Αρρώστησε ΝΑΙ ή ΟΧΙ'
    ΔΙΑΒΑΣΕ ar[i]
    ΟΣΟ ar[i] <> 'NAI' ΚΑΙ ar[i] <> 'OXI' ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'Λάθος. Ξαναδώσε.'
      ΔΙΑΒΑΣΕ ar[i]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  n1 <-- 0                   ! Πόσοι πήραν εμβόλιο
  s1 <-- 0                   ! Πόσοι πήραν εμβόλιο και αρρώστησαν
  n2 <-- 0                   ! Πόσοι δεν πήραν εμβόλιο
  s2 <-- 0                   ! Πόσοι δεν πήραν εμβόλιο και αρρώστησαν
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10000
    ΑΝ em[i] = 1 ΤΟΤΕ
      n1 <-- n1 + 1
      ΑΝ ar[i] = 'NAI' ΤΟΤΕ
        s1 <-- s1 + 1
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ
      n2 <-- n1 + 1
      ΑΝ ar[i] = 'NAI' ΤΟΤΕ
        s2 <-- s2 + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  x1 <-- posost(n1 , s1)
  x2 <-- posost(n2 , s2)
  ΑΝ x2 - x1 > 20 ΤΟΤΕ               ! Προφανώς πρέπει να είναι περισσότεροι
    ΓΡΑΨΕ 'ΑΠΟΤΕΛΕΣΜΑΤΙΚΟ ΕΜΒΟΛΙΟ'   ! αυτοί που νόσησαν χωρίς εμβόλιο.
  ΑΛΛΙΩΣ                             ! Έτσι πρέπει x2 > x1.
    ΓΡΑΨΕ 'ΑΝΑΠΟΤΕΛΕΣΜΑΤΙΚΟ ΕΜΒΟΛΙΟ' !
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ posost(x,y) : ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: x , y
ΑΡΧΗ
  posost <-- y / x * 100
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters