Τώρα είναι Τρί 02 Ιουν 2020 11:58 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Τέλειοι και Φίλιοι αριθμοί
ΔημοσίευσηΔημοσιεύτηκε: Παρ 23 Φεβ 2007 02:41 am 
Χωρίς σύνδεση

Εγγραφή: Τετ 15 Δεκ 2004 04:26 am
Δημοσιεύσεις: 10
Τοποθεσία: Πρέβεζα
Syntax: [ Download ] [ Hide ]
!---------------------------------------------------------------------------------------
! Να υπολογισθούν οι τέλειοι και οι φίλιοι αριθμοί από το 2 μέχρι το ... 10000
! Τέλειος έιναι ο αριθμός που είναι ίσος με το άθροισμα των διαιρετών του.
! Φίλιοι είναι 2 αριθμοί όταν ο κάθε ένας ισούται με το άθροισμα των διαιρετών του άλλου.
!-----------------------------------------------------------------------------------------
! netnick
!----------------------------
ΠΡΟΓΡΑΜΜΑ διαιρέτες_φίλιοι
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ν,νν, αθρ
ΑΡΧΗ
  ΓΙΑ ν ΑΠΟ 2 ΜΕΧΡΙ 10000
    νν  <-- αθροισμα_Διαιρετών(ν)
    ΑΝ ν <= νν ΤΟΤΕ
      αθρ <-- αθροισμα_Διαιρετών(νν)
    ΑΛΛΙΩΣ
      αθρ <-- 0
    ΤΕΛΟΣ_ΑΝ
    ΑΝ (ν = νν) ΤΟΤΕ
      γράψε 'Ο ', ν, ' είναι τέλειος.'
    ΑΛΛΙΩΣ_ΑΝ (ν = αθρ) ΤΟΤΕ
      γράψε 'Οι ', ν,' ',νν, ' είναι φίλιοι αριθμοί.'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ αθροισμα_Διαιρετών(αριθμος): ακέραια
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: αριθμος,ι,ρίζα,ιι,αθρ,ν1,ν2
ΑΡΧΗ
  ρίζα <-- α_μ(Τ_Ρ(αριθμος))
  αθρ <-- 1
  ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ ρίζα
    ιι <-- αριθμος MOD ι
    ΑΝ ιι = 0 ΤΟΤΕ
      αθρ <-- αθρ + ι + (αριθμος DIV ι)
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  αθροισμα_Διαιρετών <-- αθρ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters