Τώρα είναι Δευτ 01 Ιουν 2020 08:03 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Σύγκριση πινάκων
ΔημοσίευσηΔημοσιεύτηκε: Τρί 25 Μαρ 2003 09:18 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! ===============================================================
! Να γίνει πρόγραμμα το οποίο:
!   Α) Να ζητάει έναν αριθμό Κ από το 1 ως το 100 (αν δωθεί λάθος
!      αριθμός να επαναλαμβάνει την ερώτηση).
!   Β) Να διαβάζει Κ αριθμούς τους οποίους θα αποθηκεύει στις
!      πρώτες Κ θέσεις ενός πίνακα Α ακεραίων.
!   Γ) Να διαβάζει Κ αριθμούς τους οποίους θα αποθηκεύει στις
!      πρώτες Κ θέσεις ενός πίνακα Β ακεραίων.
!   Δ) Να ελέγχει αν οι δύο πίνακες είναι όμοιοι, δηλαδή αν στις
!      πρώτες Κ θέσεις περιέχουν ακριβώς τους ίδιους αριθμούς.
! ΣΗΜΕΙΩΣΗ:
!   Ο έλεγχος για το αν οι δύο πίνακες είναι όμοιοι να γίνεται με
!   χρήση ΛΟΓΙΚΗΣ ΣΥΝΑΡΤΗΣΗΣ που θα έχει τη μορφή:
!                Όμοιοι_πίνακες(πιν1, πιν2, Κ)
!   όπου πιν1, πιν2 οι δύο πίνακες και Κ το πλήθος των στοιχείων
!   που θα ελεγχθούν.
! ===============================================================


ΠΡΟΓΡΑΜΜΑ Σύγκριση_πινάκων

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α[100], Β[100], Κ, i

ΑΡΧΗ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Δώσε το πλήθος των στοιχείων των πινάκων (1<=κ<=100):'
    ΔΙΑΒΑΣΕ κ
  ΜΕΧΡΙΣ_ΟΤΟΥ (Κ>=1) ΚΑΙ (Κ<=100)

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Κ
    ΓΡΑΨΕ 'Δώσε το ', i, 'ο στοιχείο του 1ου πίνακα:'
    ΔΙΑΒΑΣΕ Α[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Κ
    ΓΡΑΨΕ 'Δώσε το ', i, 'ο στοιχείο του 2ου πίνακα:'
    ΔΙΑΒΑΣΕ Β[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΑΝ Όμοιοι_πίνακες(Α, Β, Κ)=ΑΛΗΘΗΣ ΤΟΤΕ
    ΓΡΑΨΕ 'Οι πίνακες ΕΙΝΑΙ όμοιοι.'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Οι πίνακες ΔΕΝ ΕΙΝΑΙ όμοιοι.'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Σύγκριση_πινάκων

!----------------------------------------------------------------
ΣΥΝΑΡΤΗΣΗ Όμοιοι_πίνακες(πιν1, πιν2, Κ): ΛΟΓΙΚΗ

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: πιν1[100], πιν2[100], Κ, i
  ΛΟΓΙΚΕΣ: βρέθηκε_διαφορά

ΑΡΧΗ

  i <-- 1
  βρέθηκε_διαφορά <-- ΨΕΥΔΗΣ

  ΟΣΟ (i<=Κ) ΚΑΙ (βρέθηκε_διαφορά=ΨΕΥΔΗΣ) ΕΠΑΝΑΛΑΒΕ
    ΑΝ πιν1[i]<>πιν2[i] ΤΟΤΕ
      βρέθηκε_διαφορά <-- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
    i <-- i+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΑΝ βρέθηκε_διαφορά=ΑΛΗΘΗΣ ΤΟΤΕ
    Όμοιοι_πίνακες <-- ΨΕΥΔΗΣ
  ΑΛΛΙΩΣ
    Όμοιοι_πίνακες <-- ΑΛΗΘΗΣ
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
!----------------------------------------------------------------

 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters