Τώρα είναι Τρί 02 Ιουν 2020 12:29 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Mέγιστος από 4 αριθμούς
ΔημοσίευσηΔημοσιεύτηκε: Τρί 04 Απρ 2006 09:42 am 
Χωρίς σύνδεση

Εγγραφή: Πέμ 21 Ιούλ 2005 10:34 am
Δημοσιεύσεις: 11
Τοποθεσία: ΚΑΣΤΟΡΙΑ
Να γραφεί πρόγραμμα που θα διαβάζει 4 αριθμούς α, β, γ, δ και θα εντοπίζει τον μεγαλύτερο από αυτούς.

Syntax: [ Download ] [ Hide ]
! Να γραφεί πρόγραμμα που θα διαβάζει 4 αριθμούς α, β, γ, δ και θα εντοπίζει τον μεγαλύτερο από αυτούς.

ΠΡΟΓΡΑΜΜΑ ΜΕΓΙΣΤΟΣ_ΤΕΣΣΑΡΩΝ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:α,β,γ,δ,μεγ1,μεγ2,μεγιστος
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε 4 αριθμούς'
  ΔΙΑΒΑΣΕ α,β,γ,δ
  μεγ1 <-- max_of_2(α,β)                ! Αντί να καλέσουμε 3 φορές τη συνάρτηση max_of_2
  μεγ2 <-- max_of_2(γ,δ)                ! μπορούμε να την καλέσουμε ΜΟΝΟ μία ως εξής:
  μεγιστος <-- max_of_2(μεγ1,μεγ2)      ! μέγιστος<--max_of_2( max_of_2(α,β) , max_of_2(γ,δ) )
  ΓΡΑΨΕ 'Ο μεγαλύτερος αριθμός από τους εισαχθέντες είναι ο',μεγιστος
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ max_of_2(x,y): ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: x,y
ΑΡΧΗ
  ΑΝ x>=y ΤΟΤΕ
    max_of_2 <-- x
  ΑΛΛΙΩΣ
    max_of_2 <-- y
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

 


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Παρ 14 Απρ 2006 09:20 am 
Χωρίς σύνδεση

Εγγραφή: Πέμ 21 Ιούλ 2005 10:34 am
Δημοσιεύσεις: 11
Τοποθεσία: ΚΑΣΤΟΡΙΑ
Μπορεί να μελετηθεί αυτή η άσκηση σε αντιπαραβολή με σχετική άσκηση που βρίσκεται στο τμήμα των διαδικασιών, όπου ζητείται η εύρεση ταυτόχρονα του μέγιστου και ελάχιστου. Εκεί γίνεται χρήση διαδικασίας αφού τα επιστρεφόμενα αποτελέσματα είναι δύο, max και min.


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters