Τώρα είναι Τρί 02 Ιουν 2020 10:35 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 03 Απρ 2006 07:31 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 17 Νοέμ 2005 06:46 pm
Δημοσιεύσεις: 4
Τοποθεσία: Αθήνα
Syntax: [ Download ] [ Hide ]
! Το πρόγραμμα δέχεται δύο ακεραίους ν και κ ( ν>κ )
! και υπολογίζει και εμφανίζει το πλήθος των συνδυασμών των
! ν αντικειμένων ανά κ . Χρήση της συνάρτησης Παραγοντικό από
! τα παραδείγματα του τμηνατικού προγραμματισμού του site.
! Ο τύπος που χρησιμοποιείται είναι : πλήθος=ν!/κ!*(ν-κ)!

ΠΡΟΓΡΑΜΜΑ Συνδυασμοί

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ν,κ,πληθος,π1,π2,π3

ΑΡΧΗ

  ΓΡΑΨΕ 'Δώσε το συνολικό πλήθος των αντικειμένων :'
  ΔΙΑΒΑΣΕ ν
  ΓΡΑΨΕ 'Δώσε το πλήθος των αντικειμένων του κάθε συνδυασμού ( <ν ):'
  ΔΙΑΒΑΣΕ κ
  π1 <-- Παραγοντικό(ν)
  π2 <-- Παραγοντικό(κ)
  π3 <-- Παραγοντικό(ν-κ)
  πληθος <-- π1 DIV (π2*π3)
  ΓΡΑΨΕ 'Το πλήθος των συνδυασμών είναι :', πληθος

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Τμηματικός_προγραμματισμός_2

!-----------------------------------------------------------
ΣΥΝΑΡΤΗΣΗ Παραγοντικό(αριθμός): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: αριθμός, i, παρ
ΑΡΧΗ
  παρ <-- 1
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ αριθμός
    παρ <-- παρ*i
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Παραγοντικό <-- παρ             ! Η τιμή που θα επιστραφεί
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Τετ 19 Απρ 2006 09:07 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 01 Μάιος 2003 10:25 pm
Δημοσιεύσεις: 38
Τοποθεσία: Καλλιθέα Αττικής
Παρόμοιο πρόγραμμα χωρίς να χρησιμοποιεί αναδρομή εδώ:
http://www.spinet.gr/glossomatheia/prog ... hlight=#92

_________________
Γλώσσα προγραμματισμού M2000


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters