Τώρα είναι Τρί 02 Ιουν 2020 10:03 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εναλλακτική Ταξινόμηση
ΔημοσίευσηΔημοσιεύτηκε: Τετ 29 Μαρ 2006 08:28 pm 
Syntax: [ Download ] [ Hide ]
!Το πρόγραμμα διαβάζει 10 αριθμούς σε έναν πίνακα και με την βοήθεια
!συνάρτησης ταξινομεί και εμφανίζει τα δεδομένα του πίνακα.

ΠΡΟΓΡΑΜΜΑ πινακας
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ι,ν,κ,θεση
  ΠΡΑΓΜΑΤΙΚΕΣ: π[10],τεμπ
ΑΡΧΗ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ 'ΔΩΣΕ ΣΤΟΙΧΕΙΑ '
    ΔΙΑΒΑΣΕ π[ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  κ <-- 1
  ν <-- 10
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ ν
    θεση <-- classification(π,ν,κ)
    τεμπ <-- π[ι]
    π[ι] <-- π[θεση]
    π[θεση] <-- τεμπ
    κ <-- κ+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ ν
    ΓΡΑΨΕ_ π[ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ πινακας

ΣΥΝΑΡΤΗΣΗ classification(π1,ν1,κ1):ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: φ,position,ν1,κ1
  ΠΡΑΓΜΑΤΙΚΕΣ: π1[10],min
ΑΡΧΗ
  min <-- π1[κ1]
  position <-- κ1
  ΓΙΑ φ ΑΠΟ (κ1+1) ΜΕΧΡΙ ν1
    ΑΝ π1[Φ]<min ΤΟΤΕ
      min <-- π1[φ]
      position <-- φ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  classification <-- position
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


Κορυφή
  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters