Τώρα είναι Τρί 02 Ιουν 2020 11:10 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εύρεση μικρότερου
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 05 Μαρ 2005 06:48 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 15 Φεβ 2004 09:10 pm
Δημοσιεύσεις: 18
Τοποθεσία: Ενιαίο Λύκειο Χιλιομοδίου Κορινθίας
Να αναπτύξετε:
i. υποπρόγραμμα που θα δέχεται ως παραμέτρους δυο ακέραιους αριθμούς και θα επιστρέφει τον μικρότερο από αυτούς. Τι τύπο θα διαλέξετε;
ii. υποπρόγραμμα που θα δέχεται ως παραμέτρους τρεις ακεραίους αριθμούς και να επιστρέφει τον μικρότερο, Τι τύπο θα διαλέξετε; Υπόδειξη: να χρησιμοποιήσετε το υποπρόγραμμα του προηγούμενου ερωτήματος
iii. Να αναπτύξετε πρόγραμμα που θα διαβάζει τρεις ακέραιους αριθμούς και θα εκτυπώνει τον μικρότερο, χρησιμοποιώντας τα υποπρογράμματα που αναπτύχθηκαν στα προηγούμενα ερωτήματα

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Εύρεση_Ελαχίστου
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : στοιχείο1, στοιχείο2, στοιχείο3, ελάχιστο
ΑΡΧΗ
  ΔΙΑΒΑΣΕ στοιχείο1, στοιχείο2, στοιχείο3
  ελάχιστο <-- Μικρότερος_από_3 (στοιχείο1, στοιχείο2, στοιχείο3)
  ΓΡΑΨΕ ελάχιστο
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Εύρεση_Ελαχίστου            
! =========================================
ΣΥΝΑΡΤΗΣΗ Μικρότερος_από_3 (α, β, γ): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : α, β, γ, εκτίμηση
ΑΡΧΗ
  εκτίμηση <-- Μικρότερος_από_2 (α, β)! Βρίσκω τον μικρότερο από τους 2 πρώτους
  εκτίμηση <-- Μικρότερος_από_2 (εκτίμηση, γ)! Τον συγκρίνω με τον τρίτο κι κρατάω τον μικρότερο
  Μικρότερος_από_3 <-- εκτίμηση
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
! =========================================
ΣΥΝΑΡΤΗΣΗ Μικρότερος_από_2 (x, y): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: x, y, min
ΑΡΧΗ
  ΑΝ x < y ΤΟΤΕ
    min <-- x
  ΑΛΛΙΩΣ
    min <-- y
  ΤΕΛΟΣ_ΑΝ
  Μικρότερος_από_2 <-- min
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ            
 


Πλήρης περιγραφή στο: http://users.kor.sch.gr/ptsiotakis/aepp ... s/ask5.pdf

Με εκτίμηση,

Τσιωτάκης Παναγιώτης


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters