Τώρα είναι Παρ 28 Φεβ 2020 08:40 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Άρτιος ή περιττός
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 10 Μαρ 2003 10:38 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! ==================================
! Να γίνει πρόγραμμα που να διαβάζει
! έναν ακέραιο αριθμό και να
! εμφανίζει ένα μήνυμα σχετικά με το
! αν είναι άρτιος ή περιττός.
! ΣΗΜΕΙΩΣΗ:
! - Ο έλεγχος για το αν ο αριθμός
!   είναι άρτιος ή περιττός να
!   γίνεται με κλήση ΛΟΓΙΚΗΣ
!   ΣΥΝΑΡΤΗΣΗΣ.
! ==================================


ΠΡΟΓΡΑΜΜΑ Άρτιος_ή_περιττός

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: x

ΑΡΧΗ

  ΓΡΑΨΕ 'Δώσε έναν ακέραιο αριθμό:'
  ΔΙΑΒΑΣΕ x

  ΑΝ Είναι_άρτιος(x)=ΑΛΗΘΗΣ ΤΟΤΕ
    ΓΡΑΨΕ 'Ο αριθμός είναι άρτιος'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Ο αριθμός είναι περιττός'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Άρτιος_ή_περιττός

!-----------------------------------
ΣΥΝΑΡΤΗΣΗ Είναι_άρτιος(α): ΛΟΓΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α
ΑΡΧΗ
  ΑΝ α MOD 2 = 0 ΤΟΤΕ
    Είναι_άρτιος <-- ΑΛΗΘΗΣ
  ΑΛΛΙΩΣ
    Είναι_άρτιος <-- ΨΕΥΔΗΣ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
!-----------------------------------

 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters